cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
759
Views
0
Helpful
8
Replies

CISCO 881 ROUTER

AhmedQa
Level 1
Level 1

Hi, 

 

its my configuration right ? only need review and check if there is any mistake in my settings. 

 

#show running-config
Building configuration...

Current configuration : 2013 bytes

!
ip domain name saudi.com.sa
ip name-server 84.235.6.xx
ip name-server 84.235.57.xxx
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated

interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet4.1115
 description " TO ITC Modem "
 encapsulation dot1Q 60
 ip address 37.224.119.xx 255.255.255.254
 ip nat outside
 ip virtual-reassembly in
!
interface Vlan1
 description " Conneted To Switch "
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 101 interface FastEthernet4.1115 overload
ip route 0.0.0.0 0.0.0.0  0.0.0.0 0.0.0.0 37.224.119.xx
!
!
access-list 101 deny   ip any 192.168.1.0 0.0.0.255
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
1 Accepted Solution

Accepted Solutions

Hello,

 

you need to remove the 'deny' statement from your access list 101. You could also add DHCP server functionality to your router (this is of course optional):

 

#show running-config
Building configuration...

Current configuration : 2013 bytes
!
ip domain name saudi.com.sa
ip name-server 84.235.6.xx
ip name-server 84.235.57.xxx
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated

interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet4.1115
description " TO ITC Modem "
encapsulation dot1Q 60
ip address 37.224.119.xx 255.255.255.254
ip nat outside
ip virtual-reassembly in
!
interface Vlan1
description " Conneted To Switch "
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface FastEthernet4.1115 overload
ip route 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 37.224.119.xx
!
--> no access-list 101 deny ip any 192.168.1.0 0.0.0.255
access-list 101 permit ip 192.168.1.0 0.0.0.255 any

View solution in original post

8 Replies 8

Hello,

 

you need to remove the 'deny' statement from your access list 101. You could also add DHCP server functionality to your router (this is of course optional):

 

#show running-config
Building configuration...

Current configuration : 2013 bytes
!
ip domain name saudi.com.sa
ip name-server 84.235.6.xx
ip name-server 84.235.57.xxx
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated

interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet4.1115
description " TO ITC Modem "
encapsulation dot1Q 60
ip address 37.224.119.xx 255.255.255.254
ip nat outside
ip virtual-reassembly in
!
interface Vlan1
description " Conneted To Switch "
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface FastEthernet4.1115 overload
ip route 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 37.224.119.xx
!
--> no access-list 101 deny ip any 192.168.1.0 0.0.0.255
access-list 101 permit ip 192.168.1.0 0.0.0.255 any

Hello, 

 

once i start to configured the subinterface i got this message 

 

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or ISL vLAN 

The "ip route" has an additional block of "0.0.0.0 0.0.0.0", the rest looks ok.

Hello

what is servicing your LAN for dynamic ip address allocation (dhcp) 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello, 

 

am using the static IP for my LAN network 

AhmedQa
Level 1
Level 1

Hello, 

 

i found many issue when i start configuration the cisco router 881 

 

first: 

 

nterface FastEthernet4.1115
description " TO ITC Modem "
encapsulation dot1Q 60
ip address 37.224.119.xx 255.255.255.254
ip nat outside
ip virtual-reassembly in

the message appeared: 

 

Warning: use /31 mask on non point-to-point interface cautiously. 

 

 

 

Hello,

 

--> Warning: use /31 mask on non point-to-point interface cautiously.

 

This is just the IOS telling you that you have to be sure that you use an IP address that has a corresponding peer address on the other side.

 

You can proceed with configuring that IP address on the interface, right ?

Hello, 

 

its already proceed with interface but the interface status is down. 

 

Router#
Router#sh ip int br
Interface                  IP-Address      OK? Method Status                Prot                           ocol
FastEthernet0              unassigned      YES unset  down                  down                           
FastEthernet1              unassigned      YES unset  down                  down                           
FastEthernet2              unassigned      YES unset  up                    down                           
FastEthernet3              unassigned      YES unset  up                    down                           
FastEthernet4              unassigned      YES NVRAM  administratively down down                           
FastEthernet4.1            37.224.119.XX   YES manual administratively down down                           
NVI0                       unassigned      YES unset  administratively down down                           
Vlan1                      192.168.1.1     YES NVRAM  down                  down                           
Router#
Review Cisco Networking products for a $25 gift card