03-04-2015 10:54 AM - edited 03-05-2019 12:56 AM
I wan't to ping from "PC" in the right (DIRECTION FES) to PC in the left (DIRECTION KENITRA) but when I ping it fail , I tried to connect "Multilayer Switch3" and "Multilayer Switch0" but I failed , I used the next commands :
Multilayer Switch3(config)# router rip
Multilayer Switch3(config)#network 10.0.0.0
Multilayer Switch3(config)#network 192.168.30.0
and
Multilayer Switch3(config)# router eigrp 1000
Multilayer Switch3(config)#network 10.0.0.0
Multilayer Switch3(config)#network 192.168.30.0
but without any effect.
Please help me to ping succefuly and connect all the networks succefuly.
Solved! Go to Solution.
03-04-2015 01:50 PM
Khalil
You need to look at your switch configurations and go through them carefully.
Just looking at them I can see the EIGRP configurations are wrong.
On each switch you should only have network statements for connected networks, not for networks that are not directly connected.
If you go through them again and reference your diagram you should be able to see that you have configured network statements under EIGRP for networks that are connected to other switches.
That is why EIGRP is not coming up.
Jon
03-04-2015 11:07 AM
Pick one routing protocol. I would use EIGRP because RIP is classful and you have major networks separated by other major networks.
On each L3 switch configure EIGRP and include network statements for the attached subnets.
Add "no auto-summary" under the EIGRP configuration. If you add it and it doesn't show up that's fine it just means it is the default.
Jon
03-04-2015 11:32 AM
Thanks Jon for replying , I just did what you told me and did not work :-(
I can't find the problem ... could you tell me how to configure major networks separated by other major networks using multilayer switchs ?
Thank you very much.
Khalil
03-04-2015 11:42 AM
Khalil
It looks like you have 4 L3 switches in your topology.
In addition it's not clear which subnet is being used to link the middle two switches. I have assumed 10.0.0.0/24.
So remove any existing RIP or EIGRP configuration and from left to right on your diagram in terms of switches add this -
left switch
===============
router eigrp 10
network 13.0.0.0 0.0.0.255
network 192.168.30.0 0.0.0.255
no auto-summary
middle left switch
==================
router eigrp 10
network 10.0.0.0 0.0.0.255
network 13.0.0.0 0.0.0.255
no auto-summary
middle right switch
===================
router eigrp 10
network 10.0.0.0 0.0.0.255
network 12.0.0.0 0.0.0.255
no auto-summary
right switch
===================
router eigrp 10
network 12.0.0.0 0.0.0.255
network 192.168.10.0 0.0.0.255
no auto-summary
try that out.
When you add these commands you should see EIGRP neighbors coming up. To check -
"sh ip eigrp neighbors"
see if it works and if it doesn't come back.
If it does and you want an explanation then please come back as well.
Jon
03-04-2015 12:39 PM
I did a new project and configure from the first , and when I used your commands I have this result :
sw# IP-EIGRP neighbors for process 10
sw#
I don't know why ?
I have some questions ? can I use trunk mode on the middle but I just know how to configure the 802.1Q and set the trunk mode , sould it pass the ping ? and I am using "SVI" and "routed port" now to connect inter-switchs :
Switch2>en
Switch2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch2(config)#int f0/2
Switch2(config-if)#no sw
Switch2(config-if)#no switchport
Switch2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Switch2(config-if)#ip ad
Switch2(config-if)#ip address 10.0.0.1 255.255.255.0
Switch2(config-if)#
is that good ?
thank you very much
Khalil
03-04-2015 12:44 PM
Please post the configurations of all four switches.
Add them as attachments to the post.
And please indicate which configuration is for which switch in your diagram.
Jon
03-04-2015 01:44 PM
SWITCH 0 :
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/2
Switch(config-if)#no switchport
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Switch(config-if)#ip address 10.0.0.1 255.255.255.0
Switch#
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#no sw
Switch(config-if)#no switchport
Switch(config-if)#ip ad
Switch(config-if)#ip address 13.0.0.1 255.0.0.0
Switch(config-if)#no sh
Switch(config-if)#end
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#ip routi
Switch(config)#ip routing
Switch(config)#end
Switch(config)#rou
Switch(config)#router e
Switch(config)#router eigrp 10
Switch(config-router)#n
Switch(config-router)#ne 192.168.10.0 0.0.0.255
Switch(config-router)#ne 192.168.30.0 0.0.0.255
Switch(config-router)#ne 12.0.0.0 0.255.255.255
Switch(config-router)#no au
Switch(config-router)#no auto-summary
Switch(config-router)#end
SWITCH 2 :
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#no sw
Switch(config-if)#no switchport
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch(config-if)#ip ad
Switch(config-if)#ip address 10.0.0.2 255.0.0.0
Switch(config-if)#no sh
Switch(config-if)#end
Switch#
Switch(config)#ip routing
Switch(config)#int f0/2
Switch(config-if)#no switchport
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Switch(config-if)#ip address
% Incomplete command.
Switch(config-if)#ip address 12.0.0.1 255.0.0.0
Switch(config-if)#no shutdown
Switch(config-if)#end
Switch(config)#router eigrp 10
Switch(config-router)#ne 13.0.0.0 0.255.255.255
Switch(config-router)#ne 192.168.10.0 0.0.0.255
Switch(config-router)#ne 192.168.30.0 0.0.0.255
Switch(config-router)#no a
Switch(config-router)#no auto-summary
Switch(config-router)#end
SWITCH 3 :
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#int range f0/2 , f0/3
Switch(config-if-range)#sw
Switch(config-if-range)#switchport ac
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#int vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
Switch(config-if)#ip ad
Switch(config-if)#ip address 192.168.10.1 255.0.0.0
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no sh
Switch(config-if)#no shutdown
Switch(config-if)#
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#int f0/1
Switch(config-if)#no sw
Switch(config-if)#no switchport
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch(config-if)#ip ad
Switch(config-if)#ip address 12.0.0.2 255.0.0.0
Switch(config-if)#no sh
Switch(config-if)#exitSwitch(config)#router eigrp 10
Switch(config-router)#ne
Switch(config-router)#network 10.0.0.0 0.255.255.255
Switch(config-router)#ne 13.0.0.0 0.255.255.255
Switch(config-router)#ne 192.168.30.0 0.0.0.255
Switch(config-router)#no a
Switch(config-router)#no auto-summary
Switch(config-router)#end
That's all the configuration that I did now ...
please , could I show you my complete project ?
Thank you again
Khalil
03-04-2015 01:50 PM
Khalil
You need to look at your switch configurations and go through them carefully.
Just looking at them I can see the EIGRP configurations are wrong.
On each switch you should only have network statements for connected networks, not for networks that are not directly connected.
If you go through them again and reference your diagram you should be able to see that you have configured network statements under EIGRP for networks that are connected to other switches.
That is why EIGRP is not coming up.
Jon
03-04-2015 02:14 PM
Yeah absolutly right , It helped me.
This is my Full project :
I just have to add some PCs on the green and pink (left) ones.
- I have to do all the pings successfully
- Pass all the calls
- and connect all the servers rightly
and DHCP and vLANs ...
Khalil
05-14-2015 10:08 PM
Hello Khalil,
Can you please send me your topology config?
Thank you.
08-27-2020 09:59 AM
Hello Khalil,
I am studying Network as a student from Myanmar. I want to learning about your topology config. Can you please send me your topology config?
Thank you.
08-03-2023 01:45 PM
i have been trying to complete this lab but i failed .i need help please
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide