12-04-2015 03:54 AM - edited 03-05-2019 02:52 AM
Hi,
The scenario will be a Cisco router (not sure what type yet), connecting via PPPoE to a separate DSL modem. The modem can be managed via IP on the same interface as used for PPPoE. Is that a supported configuration with a Cisco router, ie able to apply an IP address to the WAN interface as well as the PPPoE configuration?
Ta in advance, Tony S
Solved! Go to Solution.
12-04-2015 05:07 AM
Hello Tony,
Yes, that is a supported configuration. On a Cisco router, an Ethernet interface can be set up both for its own IP address, and run a PPPoE client at the same time.
interface FastEthernet0/0
ip address 192.168.255.1 255.255.255.0
pppoe-client dial-pool-number 1
no shutdown
!
interface Dialer0
encapsulation ppp
dialer pool 1
mtu 1492
ip address negotiated
ip tcp adjust-mss 1452
ppp pap sent-username SomeLogin password SomePassword
ppp chap hostname SomeLogin
ppp chap password SomePassword
! ... other config like NAT, etc.
!
ip route 0.0.0.0 0.0.0.0 Dialer0
Best regards,
Peter
12-04-2015 05:07 AM
Hello Tony,
Yes, that is a supported configuration. On a Cisco router, an Ethernet interface can be set up both for its own IP address, and run a PPPoE client at the same time.
interface FastEthernet0/0
ip address 192.168.255.1 255.255.255.0
pppoe-client dial-pool-number 1
no shutdown
!
interface Dialer0
encapsulation ppp
dialer pool 1
mtu 1492
ip address negotiated
ip tcp adjust-mss 1452
ppp pap sent-username SomeLogin password SomePassword
ppp chap hostname SomeLogin
ppp chap password SomePassword
! ... other config like NAT, etc.
!
ip route 0.0.0.0 0.0.0.0 Dialer0
Best regards,
Peter
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide