06-03-2011 02:24 AM - edited 03-04-2019 12:36 PM
hi,
my problem is this:
we have two 2811 router with configured interfaces:
Router1
interface FastEthernet0/0.380
encapsulation dot1Q 380
ip address 192.168.232.18 255.255.255.248
no snmp trap link-status
crypto map clientmap
!
interface FastEthernet0/0.382
encapsulation dot1Q 382
ip address 10.132.1.126 255.255.255.252
no snmp trap link-status
interface Vlan1
ip address 192.168.5.1 255.255.255.128
ip nat inside
ip virtual-reassembly
ip route 0.0.0.0 0.0.0.0 192.168.232.17
ip route 10.132.254.35 255.255.255.255 10.132.1.125
Router2
interface FastEthernet0/0.197
encapsulation dot1Q 197
ip address 192.168.222.2 255.255.255.248
ip nat inside
ip virtual-reassembly
no cdp enable
interface Vlan1
ip address 192.168.1.1 255.255.255.128
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
so my case is:computer from router1's network can ping 192.168.222.2 (router2 -FastEthernet0/0.197 )
computer from router2 network can ping 192.168.232.18 (router1- FastEthernet0/0.380),but can't ping 10.132.1.126 (router1- FastEthernet0/0.382)
How can i connect vlan 380 and vlan382.I want the three vlan to see each other.Is this happen with IRB or not?
TNX
06-03-2011 02:48 AM
Can you please post traceroute result from computer2 to 10.132.1.126
06-03-2011 03:01 AM
we are missing a diagram with which is connected to which.
Regards.
Alain
06-03-2011 03:03 AM
before that i'm sorry because i did't post the routes for router2:
ip route 192.168.0.0 255.255.0.0 192.168.222.1
ip route 10.132.1.124 255.255.255.252 192.168.232.18
and the result ot traceroute:
traceroute to 10.132.1.126 (10.132.1.126), 30 hops max, 60 byte packets
1 192.168.1.1 (192.168.1.1) 5.667 ms 6.185 ms 6.570 ms
2 192.168.222.1 (192.168.222.1) 1.020 ms 1.018 ms 1.002 ms
3 192.168.222.2 (192.168.222.2) 6.871 ms 7.953 ms 8.575 ms
4 192.168.222.1 (192.168.222.1) 1.413 ms 1.395 ms 1.372 ms
5 192.168.222.2 (192.168.222.2) 8.877 ms 9.260 ms 9.659 ms
6 192.168.222.1 (192.168.222.1) 1.569 ms 1.496 ms 1.477 ms
7 192.168.222.2 (192.168.222.2) 9.284 ms 9.151 ms 9.551 ms
8 192.168.222.1 (192.168.222.1) 1.408 ms 1.433 ms 1.313 ms
and from computer2 another traceroute:
traceroute to 192.168.232.18 (192.168.232.18), 30 hops max, 60 byte packets
1 192.168.1.1 (192.168.1.1) 1.919 ms 2.259 ms 2.626 ms
2 192.168.222.1 (192.168.222.1) 0.897 ms 0.897 ms 0.871 ms
3 192.168.232.17 (192.168.232.17) 2.878 ms 2.869 ms 2.846 ms
4 192.168.232.18 (192.168.232.18) 3.104 ms * *
06-03-2011 03:10 AM
What device is 192.168.222.1 ?
06-03-2011 03:16 AM
06-03-2011 03:52 AM
Ok, as I can see from the traceroute, Router2 doesnt know how to reach 10.132.1.124, thats why it sends packet to 192.168.222.1
It means that this route on Router 2
ip route 10.132.1.124 255.255.255.252 192.168.232.18
is not working.
If you issue show ip route static on your Router2 I believe you will not see this route because next-hop (192.168.232.18) is not available
Check routing table on 192.168.222.1 to see if there is a route to 10.132.1.124 255.255.255.252
06-03-2011 04:08 AM
yes there is route,but look at this:
router1#ping 10.132.1.125
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.132.1.125, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
router1#ping 10.132.1.125 source fastEthernet 0/0.380
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.132.1.125, timeout is 2 seconds:
Packet sent with a source address of 192.168.232.18
.....
Success rate is 0 percent (0/5)
router1#ping 192.168.232.17 source fastEthernet 0/0.382
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.232.17, timeout is 2 seconds:
Packet sent with a source address of 10.132.1.126
.....
Success rate is 0 percent (0/5)
so there is no connection between fa0/0.380 and fa0/0.382
that's why i ask is it possible to some kind configure IRB or something.
if i configure nat between fa0/0.380 and fa0/0.382 ping appears between these two subinterfaces but ping from fa0/0.197 to fa0/0.382 still not respond.
I think both fa0/0.380 and fa0/0.382 are not mapped each other on the other side.
oh sorry.i don't see that you mean routing table on 192.168.222.1
actually i don't know.i don't have access.i think there isn't
06-03-2011 04:22 AM
Well, I have never dealt with IRB, but it is not about vlan mapping, it is about rouiting
This:
router1#ping 10.132.1.125 source fastEthernet 0/0.380
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.132.1.125, timeout is 2 seconds:
Packet sent with a source address of 192.168.232.18
.....
Success rate is 0 percent (0/5)
Happens because there is no route from 10.132.1.125 to 192.168.232.18, device 10.132.1.125 doesnt know where to send packets destined to 192.168.232.18. If it is a computer, its default gateway should point to router1 FastEthernet0/0.382 interface (10.132.1.126)
The same happens here:
router1#ping 192.168.232.17 source fastEthernet 0/0.382
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.232.17, timeout is 2 seconds:
Packet sent with a source address of 10.132.1.126
.....
Success rate is 0 percent (0/5)
192.168.232.17 doesnt know how to reach 10.132.1.126. Again, if it is a computer, check its default gateway
06-03-2011 04:40 AM
"oh sorry.i don't see that you mean routing table on 192.168.222.1
actually i don't know.i don't have access.i think there isn't"
Well, I believe this is what causing problems
06-03-2011 05:01 AM
yes i know it.but i don't know alternative method to bypass this:) any suggestions?
06-03-2011 05:08 AM
You can ask your ISP to configure addition vlan between two routers, configure point-to-point ip addresses between routers and you will be able to route trafic without ISP
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide