cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2900
Views
0
Helpful
3
Replies

DDNS updates produce name resolution errors.

Daniel Perez
Level 1
Level 1

I have been trying to get my 851W to work with DDNS for a long while now. In fact I walked away from the problem in frustration and loaded DDClient on a Linux box until I had time to re-visit this. The folks at ZoneEdit were not able to offer much help with CLI problems. So now I humbly ask for help here.

When I debug DDHS updates I get to a point where the the router tries to resolve the DDNS update address and fails.


So I have a number of questions:

a) Is this error the result of lack of DNS server names written to the config?

b) My WAN interface is a DHCP client to my modem. If the DDNS updater does need to resolve a name, shouldnt the DNS server info be provided by the DHCP process for the WAN interface? How do I ensure that name servers are automatically assigned for the DDNS updater to use?

c) If all the above is not true then could some kind soul please point me in the right direction?

Thank you very much.

This is the error I receive:

*Feb 13 03:47:16.927: DYNDNSUPD: Removing DNS mapping for sillyname.com <=> 98.55.162.226
*Feb 13 03:47:16.927: HTTPDNS: Update remove called for sillyname.com <=> 98.55.162.226
*Feb 13 03:47:16.927: HTTPDNSUPD: Session ID = 0x5
*Feb 13 03:47:16.927: HTTPDNSUPD: URL = 'http://xxxxxxx:xxxxxxxxxx@legacyddns.zoneedit.com/auth/dynamic.html?zones=sillyname.com&dnsto=98.55.162.226xxxxxxxxxx@legacyddns.zoneedit.com/auth/dynamic.html?zones=sillyname.com&dnsto=98.55.162.226'
*Feb 13 03:47:16.927: HTTPDNSUPD: Sending request... status='Host name resolution failed', tid=0
*Feb 13 03:47:34.931: DYNDNSUPD: timer process exiting

This is what I have done in to try and remdy this (from searching for a similar thread)

# ip domain-lookup

# ip name-server 209.18.47.61

# ip name server 209.18.47.62

After doing the above the DNS ip shows up in the debug but the name still does not resolve.

Here is my partial conf if you wish to take a look.....

no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.2.1 192.168.2.100
!
ip dhcp pool Internal-net
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   domain-name sillylabs.local
   lease 4
!
ip dhcp pool VLAN20
   import all
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   domain-name sillylabs.guest
   lease 4
!
!
ip cef
ip inspect name MYFW tcp
ip inspect name MYFW udp
ip ddns update method sdm_ddns1
HTTP
  add http://XXXXXXXXXXX:XXXXXXXXX@legacyddns.zoneedit.com/auth/dynamic.html?zones=XXXXXXXXX@legacyddns.zoneedit.com/auth/dynamic.html?zones=<h>&dnsto=<a>
  remove http://XXXXXXXXXXXX:XXXXXXXX@legacyddns.zoneedit.com/auth/dynamic.html?zones=XXXXXXXX@legacyddns.zoneedit.com/auth/dynamic.html?zones=<h>&dnsto=<a>

(IF I COPY THE ABOVE ADDRESS INTO MY BROWSER AND REPLACE a&h WITH REAL VALUES THE UPDATE IS SUCCESSFUL)
!
!
!
username xxxxxxxxxxxx privilege 15 password 7 141111305B07252575
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface FastEthernet4
ip ddns update hostname sillyname.com
ip ddns update sdm_ddns1
ip address dhcp
ip access-group Internet-inbound-ACL in
ip inspect MYFW out
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1460
duplex auto
speed auto
no cdp enable
!
interface Dot11Radio0
no ip address
no dot11 extension aironet
!
encryption vlan 1 mode ciphers aes-ccm
!
encryption vlan 20 mode ciphers aes-ccm
!
encryption mode ciphers aes-ccm
!
ssid SillyLabs
!
ssid SillyLabsGuest
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2437
station-role root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.20
description Guest wireless LAN - routed WLAN
encapsulation dot1Q 20
ip address 192.168.2.1 255.255.255.0
ip access-group Guest-ACL in
ip inspect MYFW out
ip nat inside
ip virtual-reassembly
!
interface Vlan1
description Internal Network
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
description Bridge to Internal Network
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 dhcp
!
ip http server
ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
!
ip access-list extended Guest-ACL
deny   ip any 192.168.1.0 0.0.0.255
permit ip any any
ip access-list extended Internet-inbound-ACL
permit udp any eq bootps any eq bootpc
permit icmp any any echo
permit icmp any any echo-reply
permit icmp any any traceroute
permit gre any any
permit esp any any
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
control-plane
!
bridge 1 route ip
!
line con 0
password 7 11051C1D144440255
no modem enable
line aux 0
line vty 0 4
password 7 151E05540D29242A79
!
scheduler max-task-time 5000
end

3 Replies 3

nachogdiaz
Level 1
Level 1

Hi I have the same problem, how did you fix it?

The workaround for this is to enter the ip of dyndns.org in the url.

Note we have this name resolution issue on other automatic processes of the router, like event manager applets sending emails. The smtp server cannot be sesolved.

Note also that if we ping the host from the router it is resolved fine, only automatic processes do not resolve names.

This is an old issue, but for those who arrive here with the same problem......

 

The ddns documentation requires (recommends) that you define name-servers for this zone. This primarily applies for ddns updates where these are the master name servers.

 

If you are using HTTP as the update method, these same name-servers are not necessarily complete, and only masters for the dyndns hosts that they cover, therefore not necessarily valid; in this case. it is important that you set name-server to a complete name-server, and then this issue will go away as iOS does check, but only on the first name-server.

 

This is easily verified by typing the name of the domain at the enable prompt and seeing if it resolves.

 

 

Review Cisco Networking for a $25 gift card