12-19-2018 03:11 PM
Hi! Im having a bit of trouble with packet tracer. im not sure if i made it right because 2 PCs cant renew their ipadd,subnet mask and default gateway but the other one is correct. here is the table that i made
r1------g0/0-----192.168.1.254-----255.255.255.0 int g0/0
------g0/1-----192.168.2.254-----255.255.255.0 ip helper-address 192.168.3.2
------s0/0/0----192.168.3.1-------255.255.255.0 int g0/1
ip helper-address 192.168.3.2
r2------s0/0/0----192.168.3.2-------255.255.255.0 ip dhcp excluded-address 192.168.1.254
------s0/0/1-----209.165.200.225---255.255.255.252 ip dhcp excluded-address 192.168.2.254
ip dhcp excluded-address 10.1.1..2
ip dhcp pool PC1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
ip dhcp pool PC2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
ip dhcp pool PC3
network 10.1.1.0 255.255.255.252
default-router 10.1.1.2
r3------s0/0/1-----209.165.200.226----255.255.255.252
------g0/0-------10.1.1.2-----------255.255.255.252
12-19-2018 03:42 PM
12-19-2018 03:47 PM
oh okay. here it is
12-19-2018 04:08 PM
12-19-2018 04:13 PM
12-19-2018 04:24 PM
Router0#conf t
Router0(config)#int g0/0
Router0(config-if)#ip helper-address 192.168.3.2
Router0(config-if)ex
Router0(config)#int g0/1
Router0(config-if)#ip helper-address 192.168.3.2
Router1#conf t
Router1(config)#int g0/0
Router1(config-if)#ip helper-address 209.165.200.225
Router2#conf t
Router2(config)#ip dhcp excluded-address 10.1.1.2
Router2(config)#ip dhcp excluded-address 192.168.1.254
Router2(config)#ip dhcp excluded-address 192.168.2.254
Router2(config)#ip dhcp pool SERVER
Router2(dhcp-config)#network 10.1.1.0 255.255.255.252
Router2(dhcp-config)#default-router 10.1.1.2
Router2(config)#ip dhcp pool PC1
Router2(dhcp-config)#network 192.168.1.0 255.255.255.0
Router2(dhcp-config)#default-router 192.168.1.254
Router2(config)#ip dhcp pool PC2
Router2(dhcp-config)#network 192.168.2.0 255.255.255.0
Router2(dhcp-config)#default-router 192.168.2.254
12-19-2018 04:25 PM
dhcp works in router1 > PC2
12-19-2018 05:08 PM
Thank you for posting the network diagram and part of the config. It seems like some commands are missing. Please share the output of sh run on all three routers. Also, sh ip int bri | ex unassigned
12-19-2018 05:19 PM
router 0
Router#sh ip int bri | ex unassigned
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.1.254 YES manual up up
GigabitEthernet0/1 192.168.2.254 YES manual up up
Serial0/0/0 192.168.3.1 YES manual up up
hostname Router0
!
!
interface GigabitEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip helper-address 192.168.3.2
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.2.254 255.255.255.0
ip helper-address 192.168.3.2
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.3.1 255.255.255.0
!
router rip
network 192.168.1.0
network 192.168.2.0
!
ip classless
!
!
end
router 2
Router#sh ip int bri | ex unassigned
Interface IP-Address OK? Method Status Protocol
Serial0/0/0 192.168.3.2 YES manual up up
Serial0/0/1 209.165.200.225 YES manual up up
hostname Router2
!
!
ip dhcp excluded-address 10.1.1.2
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.2.254
!
ip dhcp pool SERVER
network 10.1.1.0 255.255.255.252
default-router 10.1.1.2
ip dhcp pool PC1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
ip dhcp pool PC2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.3.2 255.255.255.0
clock rate 2000000
!
interface Serial0/0/1
ip address 209.165.200.225 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 192.168.0.0
default-information originate
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
end
router 1
Router# sh ip int bri | ex unassigned
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 10.1.1.2 YES manual up up
Serial0/0/1 209.165.200.226 YES manual up up
hostname Router1
!
!
interface GigabitEthernet0/0
ip address 10.1.1.2 255.255.255.252
ip helper-address 209.165.200.225
duplex auto
speed auto
!
interface Serial0/0/1
ip address 209.165.200.226 255.255.255.252
clock rate 2000000
!
ip classless
ip route 192.168.0.0 255.255.252.0 Serial0/0/1
!
e con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
12-19-2018 05:35 PM
Pauline,
PC2 was getting IP address because there is a default route on Router2 ( ip route 0.0.0.0 0.0.0.0 s0/0/1) pointing back to Router1; however, there is no route to the other networks connected to Router0. I saw that there is a routing issue.
You run RIP on Router0 and Router2. You will need to modify the advertised networks a little bit as follows:
On Router0:
router rip
network 192.168.3.0
!
On Router2:
router rip
network 192.168.3.0
!
HTH,
Meheretab
12-19-2018 06:20 PM
Hi @paulineagawin,
Also, in router 0 you must add the commands in the RIP configuration:
version 2
no auto-summary
Regards
12-19-2018 07:11 PM
it worked! thank you!!!
12-19-2018 06:58 PM
oh my god!
it works!!!
thank you thank you so much! whats left is ACL but I can handle it
again thank you thank you so much!
12-19-2018 07:06 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide