cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
463
Views
0
Helpful
2
Replies
Beginner

DIA routing assistance

Today, we route Internet traffic to our datacenter.  We are going to be doing a pilot at one of our branch offices where we are bringing a broadband connection to offload Internet locally.  What I would like to do is have this setup so that if this connection goes down, Internet traffic will fail back to the datacenter.


Our current design is we have two MPLS routers - Router 1 and Router 2.  Router 2 is where the default traffic goes today.  At the branch, we have a pair of switches that are L3, and each router is connected to each switch.  We run EIGRP internally, and BGP with the providers.  We will be introducing a third router for the DIA connection.  

My questions are:

Where do I put this new default route?  

Do I need to change the configuration for the failover requirement to our datacenter?

What do I need to do to prevent this local default route to be populated to other offices?

I have attached a basic diagram if it helps.

Everyone's tags (1)
2 REPLIES 2
Not applicable

Hi Jones,

  • Hi Jones,

its little bit difficult, if primary to datacenter and secondary to broadband we could have make it by advertising default route with higher metric from bgp to eigrp and static default route towards dia with less metric, if bgp goes down you dont have dynamic default route in your routing table and option is only static default, so traffic will go to dia.

as per my expertise you could make it your goal by adding internet loadbalancer you have to place it  in a way that one of its connection goes to l3 switches for lan traffic and for wan one connection to dia lan interface and one connection to your router 2 lan interface. in router 2 you have default route coming from bgp this you dont need to advertise to your eigrp, simply add static default route in l3 switches towards your internet load balancer so that failover or load balancing will be take care by load balancer.

in load balancer you can create a rule that if DIA goes down internet traffic should go to another interface which is connected to router 2 , here in router 2 you already have default route which is coming from bgp. so traffic will forward to datacenter. 

in router 2 what you have to do is, you check if any extra routed interface available. if available you just take /30 from your organisation private pool configure one ip to router2 and one ip to load balancer, second step in router 2 is redistribute this newly created /30 into your bgp so that traffic reaches from datacener to your router2.

in router2 if you dont have routed interface and switch interface is availble you can make a routed connection to your load balanver by sub interface or using vlan interfac

if you dont have any interface available you can buy hwic card so that you have some interfaces.

for your scenario best load balancer is cyberoam 25ia and it is very cheap.

thanks 

Shaik Raffath

Highlighted
Beginner

Sorry if I did not explain it

Sorry if I did not explain it correctly.  For the pilot, we want the broadband circuit to be primary, and if that goes down, we want Internet traffic to fall back to the datacenter as it does today.

Here is the configuration today for eigrp on the L3 switches:

router eigrp XX
redistribute static
passive-interface default
no passive-interface Vlan1
no passive-interface GigabitEthernety/y
no passive-interface GigabitEthernety/y
no passive-interface GigabitEthernety/y
no passive-interface GigabitEthernety/y
network n.n.n.n
no auto-summary

ip route x.x.x.x /16 Null0

Here is what routing looks like on the WAN routers

Router 1:

router eigrp XX
default-metric 10000 3000 255 1 1500
network x.x.x.x
redistribute bgp <asn>
passive-interface default
no passive-interface GigabitEthernety/y
no passive-interface GigabitEthernety/y
!
router bgp <asn>
bgp log-neighbor-changes
network x.x.x.x
network x.x.x.x
neighbor x.x.x.x remote-as NNNN
neighbor x.x.x.x description --> L3 WAN I BGP Peer
neighbor x.x.x.xsoft-reconfiguration inbound
neighbor x.x.x.x filter-list 50 out

Router 2:

router eigrp XX
default-metric 10000 1000 255 1 1500
network x.x.x.x x.x.x.x
network x.x.x.x
redistribute bgp <asn>
passive-interface default
no passive-interface GigabitEthernety/y
no passive-interface GigabitEthernety/y
!
router bgp <asn>
bgp log-neighbor-changes
network x.x.x.x
neighbor x.x.x.x remote-as xxxxx
neighbor x.x.x.x description WAN_II EBGP Peer
neighbor x.x.x.x soft-reconfiguration inbound
neighbor x.x.x.x filter-list 50 out

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards