05-26-2019 06:48 PM - edited 05-26-2019 06:49 PM
i am trying to make a dialin server using a cisco 2650xm and an nm-16am. ive configured it based on https://www.cisco.com/c/en/us/support/docs/interfaces-modules/2600-3600-series-16-port-analog-modem-network-module/24393-nm-xam-dialin.html but when i connect to this router by the client, the call is dropped during the dialing process. am i missing anything or have i done somthing incorrect? router version is 12.4(25d)
06-11-2019 12:27 AM
Hello Ali6359,
the configuration with the 16 port module should be the following. Please note that the static route should point out of Fas0/0 to make NAT to work.
Keep a copy of configuration as a text file in your PC.
! for the 16 port Async module
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Group-Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
async mode dedicated
peer default ip address dhcp
ppp authentication chap pap
group-range 33 48
!
ip local pool DIALIN 10.1.1.1 10.1.1.19
ip forward-protocol nd
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 10.1.1.0 0.0.0.15
dialer-list 1 protocol ip permit
! note the default static route should point to a next-hop out of fas0/0 for NAT to work
ip route 0.0.0.0 0.0.0.0 10.0.0.138
! it should be something like:
ip route 0.0.0.0 0.0.0.0 192.168.1.2
line con 0
line 33 48
modem Dialin
transport input all
autoselect ppp
line aux 0
line vty 0 4
login
!
!
end
The command I had added in Group-Async 1 is group-range 33 48 to link it to the async lines.
Let me know if this is what you are looking for.
Hope to help
Giuseppe
06-11-2019 01:53 AM
what about just the WIC-1AM config without the 16 port config?
06-11-2019 02:26 AM
Hello Ali,
for the 1 Async module you need the following. The same important note about default static route applies your default route MUST use interface fa0/0 as outgoing interface for NAT to work.
! with single Async module
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
ip tcp header-compression
async mode dedicated
peer default ip address 172.16.10.2
ppp authentication pap chap
routing dynamic
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.2
!
access-list 5 permit host 172.16.10.2
ip nat inside source list 5 interface FastEthernet0/0 overload
line con 0
line 1
modem Dialin
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
!
!
end
Hope to help
Giuseppe
06-11-2019 02:49 AM
still no internet on client. ethernet is on FA0/0 of router. ill post the config. my home router is on 10.0.0.138 by the way. i also changed the fastethernet address so my home router can recognise it.
Router#sh conf
Using 1255 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication ppp default if-needed local
!
aaa session-id common
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ali password 0 1234
!
!
controller E1 0/1
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.30 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
ip tcp header-compression
async mode dedicated
peer default ip address 172.16.10.2
ppp authentication pap chap
routing dynamic
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.138
!
!
ip http server
no ip http secure-server
ip nat inside source list 5 interface FastEthernet0/0 overload
!
access-list 5 permit 172.16.10.2
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line 1
modem Dialin
stopbits 1
speed 115200
flowcontrol hardware
line 33 48
line aux 0
line vty 0 4
!
!
end
whats going on?
06-11-2019 02:56 AM - edited 06-11-2019 02:57 AM
Hello Ali,
ok now 10.0.0.138 is an acceptable IP next-hop directly connected to the fas0/0.
First of all, check from the Cisco router that the home router is doing its own NAT job
From the Cisco router try to ping 8.8.8.8, if the home router does NAT for router IP address 10.0.0.30 this ping should be successful.
If it is you need to verify the NAT on the Cisco router.
use
show ip nat translations
Connect with remote on the async port, from the remote user attempts to ping 8.8.8.8
Check the NAT behaviour with
show ip nat translation
Enabling terminal monitor on the session
terminal monitor
debug ip nat ?
view the available options
Hope to help
Giuseppe
06-11-2019 03:14 AM
ping 8.8.8.8 on router works but show ip nat translations shows blank.
06-11-2019 04:20 AM
Hello Ali,
so the home router NAT works well.
Now, to understand why the sho ip nat translations output is blank you need to use appropriate debug commands.
Can you post the output of the following (from enabled prompt not in configuration mode)
router# debug ip nat ?
It should provide a list of options
You need terminal monitor on the session to see debug output
Hope to help
Giuseppe
06-11-2019 01:00 PM
Router#debug ip nat ?
<1-99> Access list
detailed NAT detailed events
fragment NAT fragment events
generic NAT generic ALG handler events
h323 NAT H.323 events
ipsec NAT IPSec events
nvi NVI events
port NAT PORT events
pptp NAT PPTP events
route NAT Static route events
sip NAT SIP events
skinny NAT skinny events
vrf NAT VRF events
wlan-nat WLAN NAT events
<cr>
06-11-2019 01:49 PM
Hello Ali,
try to use the following
enable terminal monitor
debug ip nat detailed
Connect from remote user via Async 1. Then try to ping 8.8.8.8 from remote user.
Then post the output of the debug command here (in the hope there is anything to check)
Hope to help
Giuseppe
06-11-2019 02:06 PM
debug ip nat detailed gives me IP NAT detailed debugging is on.
pinging 8.8.8.8 from remote user gives host unreachable
06-11-2019 02:38 PM
Hello Ali,
have you enabled terminal monitor on the session ?
so no NAT action is performed and as a result of this the remote user cannot access internet.
However, the configuration should be fine now with the correct default route using exit interface fas0/0.
We need to verify if NAT is supported over an Async interface.
Hope to help
Giuseppe
06-11-2019 07:20 PM
terminal monitor is enabled
06-12-2019 12:06 AM
Hello Ali,
OK termiinal monitor is enabled but no NAT debugging output is provided by the router.
I have reviewed this thread and you have mentioned the missing of a default gateway on the remote user end device.
I propose you to perform a test to verify if the remote user sends the packet for destination 8.8.8.8 to the router or not.
Configure the following ACL
access-list 101 permit ip any host 8.8.8.8
use
terminal monitor
debug ip packet detail 101
Try from the remote user to ping 8.8.8.8, if even in this case the debug output is empty the remote user is not using the PPP session to send the packet to 8.8.8.8.
By the way, what is the remote user device?
If it is a PC running Windows you can check the routing table with
route print
in the shell
Note:
if the remote user is missing the default gateway or uses a default gateway that is not the PPP session we need to try again using a DHCP pool of addresses where we can provide the default-router option.
Hope to help
Giuseppe
06-18-2019 06:10 AM
i found a very minor problem that was preventing the default gateway from being set up in the client. what i did was enabled the option to use default gateway on network and now, i have internet access. everything works all good now.
06-18-2019 10:20 AM
Hello Ali,
nice to know that you have found the issue.
If my understanding is correct the issue was on the remote client side not accepting the default gateway provided in IPCP negotiation in PPP session setup.
May I ask you what change you did so that this story can be complete and may be helpful for someone else?
Hope to help
Giuseppe
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide