10-11-2024 10:39 AM
I have an Analog Voice Gateway that I need to creare a vrf and this VG accepts these commands ip vrf "word" and vrf definition "word" and I really don't know the differences beyond that the first one is for IPv4 and the second one accept IPv4 and IPv6 , can you guys tell me the diferences between them and which one will help to define a new routing table.
10-11-2024 11:09 AM - edited 10-11-2024 11:48 AM
Check below
MHM
10-11-2024 11:34 AM - edited 10-12-2024 02:29 AM
https://www.cisco.com/c/en/us/td/docs/ios/12_2sr/12_2srb/feature/guide/sr_mpvrf.html
So to simplify the difference (IF you use IPv6)
If ypu use ip vrf <name> which is single protocol i.e. support ipv4 or ipv6 <<- double check in lab not support ipv6
What if we have dual stack interface
You can not add two vrf name under same interface
So here cisco introduce vrf def.
Which can by one name have multi protocol ipv4&ipv6
This make add single vrf under dual stack interface accpet.
MHM
10-12-2024 12:27 AM
Hello mdrangell22,
ip vrf <word> is for is IPV4 VRFs only
--------------------------------------
ip vrf vpn2
rd 1:1
route-target both 1:1
!
!
interface Loopback1
ip vrf forwarding vpn2
ip address 10.43.43.43 255.255.255.255
!
vrf definition <word> is for multi-protocol VRF(both ipv4 and ipv6)
-------------------------------------------------------------
vrf definition vpn1
rd 1:1
route-target both 1:1
!
address-family 1pv4
exit-address-family
!
!
interface Loopback1
ip vrf forwarding vpn1
ip address 10.43.43.43 255.255.255.255
Best regards
******* If This Helps, Please Rate *****
10-13-2024 03:16 AM
Hello @mdrangell22
There are differences between them, they are not the same as others have stated.
ip vrf xx = ipv4 only
vrf definition = dual ipv4/ipv6, multiprotocol address families aware
Example1:
ip vrf stan
vrf definition fred
rd 1:10
address-family ipv4 unicast| multicast
address-family ipv6 unicast
The show commands differ also with either supporting routing context
Example:2
Rx#sh ip vrf
Rx#sh vrf ( protocol support)
Rx#sh ip route vrf xxx
Rx#routing-context vrf xx
Rx#%stan#sh ip route
Rx#%fred#sh ip route
Rx#sh ip vrf detail stan | in CL
Old CLI format, supports IPv4 only
Rx#sh ip vrf detail fred | in CL
New CLI format, supports multiple address-families
The rtr IOS should provide an option to upgrade vrf from the old CLi to the new but casr must be taken if you have ipv6 addressing on any interface
example3:
vrf upgrade-cli multi-af-mode ?
common-policies IPv4 VRF policies are moved to common VRF policies
non-common-policies IPv4 VRF policies are not moved to common VRF
policies,but kept as ipv4 only VRF policies.
vrf upgrade-cli multi-af-mode non-common-policies
You are about to upgrade to the multi-AF VRF syntax commands.
You will lose any IPv6 addresses configured on interfaces
belonging to upgraded VRFs.
Are you sure ? [yes]:
So I would say Vrf definition is defiantly the best option as /when you implement vrf for any static/ IGP routing and especially for BGP..
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide