cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
90354
Views
50
Helpful
10
Replies
wfqk
Contributor

Difference between "copy run start" and wr

Do you think if there is Difference between "copy run start" and wr? Thank you

10 REPLIES 10
Luke Oxley
Beginner

Hey showipinterface,

Thanks for the post. They essentially achieve the same things by saving the running configuration to the memory so that after a reload it retains the same configuration. The write memory command, often shortened to just "wr" is the official way to do this.
The "copy run start" command is just a variation of the "copy" command. The copy command can be used to copy any files in or out of the flash etc. - as opposed to just saving the configuration.
I always suggest using "copy run start", as if you are in the wrong configuration register "wr" will lose your configuration after a reload/when you change the configuration register whereas "copy run start" will just copy the contents of the running configuration to the start-up configuration.
HTH

Kind regards,
Luke


Please rate helpful posts and mark correct answers.

Thank you so much for your reply. I think you are right. 

The both commands can copy running-config to the same nvram. In asr1k, is the nvram the bootflash? New configuration can be copied to stby-bootflash automatically when using the two same commands ? Thank you

showipinterface,

Yes, indeed. With regards to your questions, refer to the table in the link below. This outlines all of the different types of Cisco storage. It is the same situation for NX-OS/ASR and so on.
http://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/4_0/nx-os/fundamentals/configuration/guide2/fun_nx-os_book/fun_file_systems.html
HTH

Kind regards,
Luke


Please rate helpful posts and mark correct answers.
Joseph W. Doherty
Hall of Fame Expert

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Functionally, not much (as noted by Luke), but write memory is the "ancient" way, and copy running-config startup-config is the "newer" way".  NB: some newer platforms no longer accept write memory, I believe Nexus platforms might not.

I suspect write memory, often abbreviated just wr, is still around because it's so popular.

Leo L
VIP Community Legend

Do you think if there is Difference between "copy run start" and wr? 

When doing the CCNA exams, the command "write" is not allowed.  It has to be the official "copy running-config startup-config".  

The reason why the "wr" or "write" command is very popular are: 

1.  A minimum of two characters to save a config; 

2.  It is easy to confuse "copy start run" with "copy run start".  

In asr1k, is the nvram the bootflash?

The Nexus range is the first platform not to accept "wr" or "write" command but the workaround is to create an alias.

Needless to say, I totally don't "get" the big idea why Nexus BU and developers decided to can the "wr" command.   The amount of network administrators enabling the "wr" alias is proof enough that the "official" method isn't working and/or isn't popular should be more than enough.  

In asr1k, is the nvram the bootflash?

Heck no.  The NVRAM is a different partition altogether.  

cidco71
Beginner

neither one work for me, i have the Cisco 1711 and it does not save the config, some reason everytime i log out i have to redo the entire configuration all over again. is there a fix for this?

the process i do at the end of a configuration is

Router# copy run start

!

!

Router# wr

The symptom that you describe suggests that your config register is set to 0x2142 rather than the usual 0x2102. Check the  value of your config register using the output of show version and let us know how it is set.

HTH

Rick

HTH

Rick

Ty Richard, that helped. Now I am having issues running SMD, no matter what I do each browser I have tried keeps telling me Java error or one thing or another. last error I received said it was a " SDM has not been granted with the necessary privileges in order to startup successfully, or another unknown error occurred during startup.Please close all involved browser windows and try again by granting all requested privileges." error

I am running Windows 2012 R2 Datacenter with IE 11. I Have tried google, firefox and even netscape. none of them seem to want to work. what browser and Java version do you suggest?

this is one of the issues