cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
645
Views
25
Helpful
32
Replies

Discussion on Eigrp Load Balancing

Hello All,

 

Happy new year to everyone!!!

 

We have two WAN links Primary with 40 Mbps and Secondary with 10 Mbps link. 

 

Both routers are connected to Core switch, single core switch.

 

There is a EIGRP between these three devices. In Core switch, we have used one L3 VLAN. Same VLAN used in Routers connected  interface as L2 VLAN. 

 

So EIGRP neighbor forming between two routers on same interface as L3 VLAN

 

Hence we could see 2 Successor. And traffic is load balancing, sometime traffic takes secondary and it is 10 Mbps link. So users complaining slowness. 

 

If it is two Physical interface then we can configure Delay and make primary as metric value. but in this case how can we achieve Primary Router as Successor and Secondary router as Feasible successor?

 

Please help me on this. Thanks!!!

Thanks and regards, Chandhuru.M
2 ACCEPTED SOLUTIONS

Accepted Solutions

Hello,

 

the 'distance' command indeed does not work for 'D EX' routes, it only works for 'D' (internal) routes.

 

Your best bet is to use an offset list with an arbitrary offset value. On the router with the 10MB link that connects to the core switch, configure this:

 

access-list 1 permit 0.0.0.0 255.255.255.255

!

router eigrp 1

offset-list 1 out 171

 

This should affect all D EX and D routes.

View solution in original post

Hello

if you are thinking about re-addressing then you need to liaise with the isp anyway so to save you    the heartache of changes to your end hense the suggestion about querying the isp into making changes 

However if you want to have the administrative control then yes options could include re-addressing and have eigrp unicast peering  or use static and policy based routing -but as it stands it seems to me that eigrp metric manipulation from the l3 core is limited but not from the isp perspective which can be easily administered.

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

32 REPLIES 32
Georg Pauwen
VIP Expert

Hello,

 

let's say the IP address of the router interface with the 10MB uplink is 192.168.13.3 (connected to the Vlan interface on the core switch), you could just increase the distance for that neighbor. That way, the link to the 40Mbps router will always be used, until that link has a failure:

 

Core Switch

router eigrp 1

distance 91 192.168.13.3 0.0.0.0

Hello Georg,

 

Thanks for your reply!!!

 

You mean increasing administrative distance value of this secondary router right?

 

Like how we will add metric value in static route. Right?

 

Example:

ip route 0.0.0.0 0.0.0.0 192.168.13.2 200 --> Like this we can use distance for the secondary router path right?

 

Adding to that,

 

D*EX 0.0.0.0/0 [170/256512] via 10.X.X.2(Sec), 6d02h, Vlan100
                        [170/256512] via 10.X.X.1(Pri), 6d02h, Vlan100

 

We are getting EIGRP external routes. So distance we need to use above 170 right for this secondary routes?

Thanks and regards, Chandhuru.M

Hello,

 

the 'distance' command indeed does not work for 'D EX' routes, it only works for 'D' (internal) routes.

 

Your best bet is to use an offset list with an arbitrary offset value. On the router with the 10MB link that connects to the core switch, configure this:

 

access-list 1 permit 0.0.0.0 255.255.255.255

!

router eigrp 1

offset-list 1 out 171

 

This should affect all D EX and D routes.

View solution in original post

Hello @Georg Pauwen 
Looks like your example will offset all routes from both wan routers as such it wont prvoide a preffered path?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

I am not following to be honest. The offset list is applied on the advertising router. What does your test lab look like ? I don't see how all routes from both WAN routers can be affected by the offset list applied on only one of them...?

If I correctly understood he has one router and two legs towards the ISP.

This is a presumption



If you have named eigrp configuration, then under topology you can add the offset list. It can be done 'outgoing' routes or 'incomming' routes.

With the ACL you decide what routes you modify the metric. This way it changes the calculation for all routes, or some.



If you do this on the OUT from your router to the ISP (if it is even EiGRP?), then the ISP gets a falsified metric. The ISP EIGRP will re-calculate the metric and will notice that the other 'fast leg' is indeed the best option.

So you direct traffic.

I apply this in this condition.



I do not know what happens on two routers. But, in my humble opinion I think this is the same idea and action.



Please, give me information about the latter. Always interested in updating my limited knowledge



B




Hello


@_|brt.drml|_ wrote:

If you do this on the OUT from your router to the ISP (if it is even EiGRP?), then the ISP gets a falsified metric. The ISP EIGRP will re-calculate the metric and will notice that the other 'fast leg' is indeed the best option.


You wont apply offset from the L3 switch northbound towards the ISP, you woudl do this from one of the wan rtrs southbound towards the L3

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Hello


@Georg Pauwen wrote:

The offset list is applied on the advertising router


I havent tested anything, not is a position im afraid however given your statement above which i missed so apologies- then offset should indeed work from the advertsing router towards the L3 switch.

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
paul driver
VIP Mentor

Hello
You don't mention what prefixes you are receiving from each eigrp wan links (default routes or specific internal /external prefixes) 

Also It sounds like you eigrp adjacency's are on a shared network, as such they are peered with each other, it so changing the he interface delay may not work to your advantage, however changing the admin distance on the L3 switch eigrp process towards one of the less preferred eigrp links may be the way forward.

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Thanks Paul!!!

 

so you mean admin distance on the L3 switch eigrp process towards secondary WAN links will work right? As Georg told in his earlier reply?

 

Adding Admin distance for secondary will make it as Feasible Successor and actual Admin distance routes will be as Successor know?

Thanks and regards, Chandhuru.M

Hello

yes but you need to understand by default this will only work for internal prefixes (default admin distance of 90) not external prefixes (default admin distance if 170) hence why i asked what prefixes you are receiving?

 

Another possibility is if you are receiving default routes you could add your own conditional default static routes and with the increasing admin distances with ipsla tracking.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
_|brt.drml|_
Beginner

Another option is creating an offset list that increases the metric of your 'out' routes. 

The ISP will then calculate a new path via your fast link. This creates routing in and out via the fast link.

Furthermore, you are able to load balance some parts of your network over the slow link. Read about it. I hope this works. 

But, if the 'prefixes' are not an issue, then admin distance is the quickest solution. 

The above does need some testing in a lab, so you know what will happen. On this forum there is enough information to be found. Success

Hello
@_|brt.drml|_ @Georg Pauwen 
An offset list will and can change the composite metric of a route however when you have dual received routes I’m quite sure you cannot specify a particular router that originated that route to be offset.

@Chandhuru sekaran marimuthu Do you have admin access to your wan rtrs is so you have options- As looks like those default routes being advertised into eigrp for the L3 switch is via redistribution as such you could specify append an offset value as suggested by @Georg Pauwen  and @_|brt.drml|_ @ outbound or set a higher/lower redistribution metric on the wan router
Either then I think would solve your issue however is all depends on how you are advertising the default routes, so please confirm.

Example1:Wan RTR- preferred
router eigrp xxx
redistribute static metric 1500 40000 255 1 1500

Example2:Wan RTR- least preferred
int x/x
description wan rtr
offset-list 0 out 5000 <interface>



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Thanks a lot for all your reply. @paul driver @_|brt.drml|_ @Georg Pauwen .

 

Before everything, am sorry for late response.

 

We dont have access to WAN Routers. There is a dependency.

 

Both WAN routers Primary and Secondary redistributing the routes which learned through BGP. Default route(0.0.0.0) also redistributed to Core Switch.

 

Is there any other way to restrict the route learning from Core Switch end. Since there is a dependency on WAN Routers. Thanks!

 

Thanks and regards, Chandhuru.M