cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1111
Views
0
Helpful
9
Replies
Highlighted
Beginner

dot1q subinterface mapping to each vrf in a Port-Channel of ASR1002

Does ASR1002 supports dot1q subinterface mapping to each vrf in a Port-Channel? and with BFD enabled?

For example

ASR1002#conf t

interface Port-channel1
no negotiation auto
no bfd echo
lacp min-bundle 2

!
!interface GigabitEthernet0/0/1
no ip address
no negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/0/2
no ip address
no negotiation auto
channel-group 1 mode active
!
interface Port-channel1.101
encapsulation dot1Q 101
ip vrf forwarding first_vrf
ip address 10.10.10.1 255.255.255.252
bfd interval 250 min_rx 250 multiplier 3
no bfd echo
service-policy input COS-IN
!
interface Port-channel1.201
encapsulation dot1Q 201
ip vrf forwarding second_vrf
ip address 10.10.10.5 255.255.255.252
bfd interval 250 min_rx 250 multiplier 3
no bfd echo
service-policy input COS-IN

!

9 REPLIES 9
Highlighted
Advisor

Hmm, BFD on the port-channel itself.  I don't think that makes sense.  Surely you would only have it on the physical members, GigabitEthernet0/0/1 and GigabitEthernet0/0/2.  BFD is trying to detect a physical failure.

Highlighted

Thanks Philip, How about port-channel subinterface with dot1q and vrf mapping?

Highlighted

That is fine.

Highlighted

so, the command is supported for port-channel subinterface with dot1q and vrf mapping?

Highlighted

Highlighted

Thanks, I read it before as it doesn't mention about VRF and BFD on port-channel

Highlighted

BFD on the physical interfaces, vrf on the sub-interfaces of the port-channel.

Highlighted

So, as the bfd neighbor is on vlan 101 and vlan 201, the actual configuration will be?

ASR1002#conf t

interface Port-channel1

no ip address
no negotiation auto
lacp min-bundle 2

!
!interface GigabitEthernet0/0/1
no ip address
no negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/0/2
no ip address
no negotiation auto
channel-group 1 mode active
!
interface Port-channel1

service instance 1 ethernet
encapsulation dot1Q 101
ip vrf forwarding first_vrf
ip address 10.10.10.1 255.255.255.252
service-policy input COS-IN

bfd interval 250 min_rx 250 multiplier 3
no bfd echo
!
service instance 2 ethernet
encapsulation dot1Q 201
ip vrf forwarding second_vrf
ip address 10.10.10.5 255.255.255.252
service-policy input COS-IN

bfd interval 250 min_rx 250 multiplier 3
no bfd echo

!

Highlighted

Negative (with regard to BFD).  I would expect it to be:

interface GigabitEthernet0/0/1
 no ip address
 no negotiation auto
 channel-group 1 mode active
 bfd interval 250 min_rx 250 multiplier 3
no bfd echo


interface GigabitEthernet0/0/2
 no ip address
 no negotiation auto
 channel-group 1 mode active
 bfd interval 250 min_rx 250 multiplier 3
no bfd echo