01-17-2017 11:17 PM - edited 03-05-2019 07:52 AM
Hi,
I have terminated two isp on asa-5508 and want to use both link at the same time. some selected user use the isp-1 and other users with isp-2.
I configured PBR for this but all the traffic goes through default route. Is this possible or not in asa?
Please help me to resolve this issue.
I configured the following:
1. Interface - Inside, Outside, backup
2. Default route outside with default metric and the backup with higher metric
3. Nat Inside to outside and Inside to backup.
4. Policy for PBR
5. Route map created
6. attached to inside interface
Regards
Anand Chourasia
Solved! Go to Solution.
01-18-2017 11:25 PM
The next hop is set to the ASAs own address. Please remove that and try again:
route-map PBR permit 10
match ip address web-outside
set ip next-hop 10.3.96.50 10.3.96.1
01-20-2017 12:22 AM
The config shown is one way to do it. You could also skip the second PBR block and just point your active default-route to 172.16.1.1.
01-18-2017 03:34 AM
These are the steps you need to follow to configure PBR. Can you show your config? Perhaps something went wrong while configuring ...
01-18-2017 10:53 PM
01-18-2017 11:25 PM
The next hop is set to the ASAs own address. Please remove that and try again:
route-map PBR permit 10
match ip address web-outside
set ip next-hop 10.3.96.50 10.3.96.1
01-20-2017 12:02 AM
Hi Karsten Iwen,
Thanks a lot It works now.
And one more question I have, If I want to pass my web traffic through Outside ISP (10.3.96.1) and other traffic through the Backup ISP (172.16.1.1) then will the following change works fine ?
access-list web extended permit tcp any any eq www
access-list web extended permit tcp any any eq https
access-list other-traffic extended permit ip any any
route-map PBR permit 10
match ip address web
set ip next-hop 10.3.96.1
!
route-map PBR permit 20
match ip address other-traffic
set ip next-hop 172.16.1.1
or any other command required?
01-20-2017 12:22 AM
The config shown is one way to do it. You could also skip the second PBR block and just point your active default-route to 172.16.1.1.
01-20-2017 04:35 AM
Hi,
Thanks a lot. It works
Regards
Anand Chourasia
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide
cisco# sh run
: Saved
:
: Serial Number: JA#######AK
: Hardware: ASA5508, 8192 MB RAM, CPU Atom C2000 series 2000 MHz, 1 CPU (8 cores)
:
ASA Version 9.5(1)
!
hostname cisco
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface GigabitEthernet1/1
nameif outside
security-level 0
ip address 10.3.96.50 255.255.224.0
!
interface GigabitEthernet1/2
nameif backup
security-level 0
ip address 172.16.1.10 255.255.255.0
!
interface GigabitEthernet1/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/7
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/8
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
policy-route route-map PBR
!
interface Management1/1
management-only
no nameif
no security-level
no ip address
!
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network obj_backup
subnet 0.0.0.0 0.0.0.0
access-list sfr extended permit ip any any
access-list web-outside extended permit ip host 192.168.1.50 any
access-list web-backup extended permit ip host 192.168.1.60 any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu backup 1500
mtu inside 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
nat (inside,outside) dynamic interface
object network obj_backup
nat (inside,backup) dynamic interface
!
route-map PBR permit 10
match ip address web-outside
set ip next-hop 10.3.96.50 10.3.96.1
!
route-map PBR permit 20
match ip address web-backup
set ip next-hop 172.16.1.1
!
route outside 0.0.0.0 0.0.0.0 10.3.96.1 1
route backup 0.0.0.0 0.0.0.0 172.16.1.1 2
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 backup
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint ASDM_Launcher_Access_TrustPoint_0
enrollment self
fqdn none
subject-name CN=192.168.1.1,CN=cisco
keypair ASDM_LAUNCHER
crl configure
crypto ca trustpool policy
crypto ca certificate chain ASDM_Launcher_Access_TrustPoint_0
certificate b7167c58
308202c8 308201b0 a0030201 020204b7 167c5830 0d06092a 864886f7 0d010105
05003026 310e300c 06035504 03130563 6973636f 31143012 06035504 03130b31
002db1a6 7bbbd943 da32e2b5 8db39bd1 71bae438 cae1b9ad 925ef01f 32a974bc
2fab2758 e58d3904 32181fb2 2ac2bc70 5cdd6d1b f906637f 0a73e81d be4e710f
789872d3 090056f0 ec45b495
quit
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl trust-point ASDM_Launcher_Access_TrustPoint_0 inside
ssl trust-point ASDM_Launcher_Access_TrustPoint_0 inside vpnlb-ip
dynamic-access-policy-record DfltAccessPolicy
username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15
!
class-map sfr
match access-list sfr
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
inspect icmp error
class sfr
sfr fail-open
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:283196bf1468dcc0a30be87d4276d3ce
: end
cisco#