cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
947
Views
5
Helpful
3
Replies

Dualstack DMVPN

the-lebowski
Level 4
Level 4

Currently have a dual HUB dual cloud DMVPN running over IPv4.  I have an IPv6 circuit at our DC where we back-haul all IPv6 traffic through over private links.  Those links are going away and we are left with DMVPN so I need to now backhaul IPv6 traffic via the already existing DMVPN tunnels. 

 

My plan is to simply dual stack our DC hub/cloud and pass IPv6 traffic across the gre tunnel but I am not clear on how to do that.  Following the article below it looks like it can be done but wanted to see if anyone had any firsthand experience with it.  If so can you share a sanitized config? I ask because the article below isn't overtly clear on what is needed and what isn't on the spoke side. 

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/configuration/15-2mt/ipv6-15-2mt-book/ip6-dmvpn.html

1 Accepted Solution

Accepted Solutions

Hello,

 

below is a sample config (IPv4 and IPv6 addresses are arbitrary). To add IPv6 to the existing DMVPN tunnels, add the lines marked in bold:

 

HUB

 

ipv6 unicast-routing
!
interface Tunnel0
bandwidth 8000
ip address 172.16.1.1 255.255.255.0
no ip redirects
no ip next-hop-self eigrp 1
ip nhrp map multicast dynamic
ip nhrp network-id 1
no ip split-horizon eigrp 1
ipv6 address 2001:DB8::1/64
ipv6 nhrp map multicast dynamic
ipv6 nhrp network-id 101
ipv6 eigrp 101
ip mtu 1400
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ipv6 mtu 1400
ipv6 nhrp holdtime 300
no ipv6 split-horizon eigrp 101
no ipv6 next-hop-self eigrp 101
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
!
ipv6 router eigrp 101

 

SPOKE

 

ipv6 unicast-routing
!
interface Tunnel0
bandwidth 8000
ip address 172.16.1.2 255.255.255.0
no ip redirects
ip nhrp map multicast 72.38.12.234
ip nhrp map 172.16.1.1 72.38.12.234
ip nhrp network-id 1
ip nhrp nhs 172.16.1.1
ipv6 address 2001:DB8::101/64
ipv6 nhrp map 2001:DB8::1/128 72.38.12.234
ipv6 nhrp map multicast 72.38.12.234
ipv6 nhrp network-id 101
ipv6 nhrp nhs 2001:DB8::1
ip mtu 1400
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ipv6 mtu 1400
ipv6 nhrp holdtime 300
ipv6 eigrp 101
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
!
ipv6 router eigrp 101

View solution in original post

3 Replies 3

the-lebowski
Level 4
Level 4

I took a shot at this but doesn't seem to work.  Something is amiss and I am not sure exactly what.  

 

EDIT: I edited this to show a working configuration, make sure to map the IPv6 nhrp map to the public IPv4 address of your HUB router.  

 

HUB:
interface Tunnel1
 bandwidth 8000
 ip address 10.1.1.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp xxxx
 no ip split-horizon eigrp xxxx
 ip flow ingress
 ip flow egress
 ip nhrp authentication xxxxx
 ip nhrp network-id 1
 ip nhrp holdtime 300
 ip nhrp server-only
 ip nhrp redirect
 ip tcp adjust-mss 1360
 ipv6 address FE80::2001 link-local
 ipv6 address 2320:99A:1000:101::1/64
 ipv6 mtu 1400
 no ipv6 next-hop-self eigrp 3111
 no ipv6 split-horizon eigrp 3111
 ipv6 nhrp authentication examplexx
 ipv6 nhrp network-id 100
 ipv6 nhrp holdtime 300
 ipv6 nhrp redirect
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel key xxx
 tunnel protection ipsec profile DMVPN shared
 
SPOKE:
 interface Tunnel2
  bandwidth 3000
  ip address 10.1.1.200 255.255.255.0
  no ip redirects
  ip mtu 1400
  no ip split-horizon eigrp xxxx
  ip nhrp authentication examplexx
  ip nhrp map 10.1.1.1 99.99.99.99
  ip nhrp map multicast 99.99.99.99
  ip nhrp network-id 1
  ip nhrp holdtime 300
  ip nhrp nhs 10.1.1.1
  ip tcp adjust-mss 1360
  ipv6 address FE80::2001 link-local
  ipv6 address 2320:99A:1000:101::200/64
  ipv6 mtu 1400
  ipv6 nhrp authentication examplexx
  ipv6 nhrp map 2320:99A:1000:101::1/64 99.99.99.99
  ipv6 nhrp map multicast 99.99.99.99
  ipv6 nhrp network-id 100
  ipv6 nhrp holdtime 300
  ipv6 nhrp nhs 2320:99A:1000:101::1
  tunnel source GigabitEthernet0/0
  tunnel mode gre multipoint
  tunnel key xxx
 tunnel protection ipsec profile DMVPN shared
spoke-routerc# show ipv6 nhrp
2320:99A:1000:101::/64 via 2320:99A:1000:101::1
   Tunnel2 created 01:22:03, never expire
   Type: static, Flags: used
   NBMA address: 10.1.1.1

 If I run that same command on the HUB it comes back blank.  

 

Hello,

 

below is a sample config (IPv4 and IPv6 addresses are arbitrary). To add IPv6 to the existing DMVPN tunnels, add the lines marked in bold:

 

HUB

 

ipv6 unicast-routing
!
interface Tunnel0
bandwidth 8000
ip address 172.16.1.1 255.255.255.0
no ip redirects
no ip next-hop-self eigrp 1
ip nhrp map multicast dynamic
ip nhrp network-id 1
no ip split-horizon eigrp 1
ipv6 address 2001:DB8::1/64
ipv6 nhrp map multicast dynamic
ipv6 nhrp network-id 101
ipv6 eigrp 101
ip mtu 1400
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ipv6 mtu 1400
ipv6 nhrp holdtime 300
no ipv6 split-horizon eigrp 101
no ipv6 next-hop-self eigrp 101
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
!
ipv6 router eigrp 101

 

SPOKE

 

ipv6 unicast-routing
!
interface Tunnel0
bandwidth 8000
ip address 172.16.1.2 255.255.255.0
no ip redirects
ip nhrp map multicast 72.38.12.234
ip nhrp map 172.16.1.1 72.38.12.234
ip nhrp network-id 1
ip nhrp nhs 172.16.1.1
ipv6 address 2001:DB8::101/64
ipv6 nhrp map 2001:DB8::1/128 72.38.12.234
ipv6 nhrp map multicast 72.38.12.234
ipv6 nhrp network-id 101
ipv6 nhrp nhs 2001:DB8::1
ip mtu 1400
ip nhrp holdtime 300
ip tcp adjust-mss 1360
ipv6 mtu 1400
ipv6 nhrp holdtime 300
ipv6 eigrp 101
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
!
ipv6 router eigrp 101

I saw that and tried that configuration to no avail.  Some of the commands don't even take on 15.7(3)M5.  

 

Specifically "router(config-if)#ipv6 nhrp map multicast dynamic" doesn't take on the HUB.  Meaning it allows me to enter the command but it doesn't show up on the tunnel interface after the fact.  Also I think that article you got those from is outdated and if I remember correctly was from back in 2011.  Either way I think you fixed it for me as I was using the private IPs of the HUB for the two statements below, once I changed it to the public IPs it worked! 

 

ipv6 nhrp map 2001:DB8::1/128 72.38.12.234
ipv6 nhrp map multicast 72.38.12.234

 

Thanks!

 

 

Review Cisco Networking for a $25 gift card