cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1983
Views
0
Helpful
11
Replies
bschaper
Beginner

EHWIC-ESG-P on 2911 and 1921

Gurus,

     Ok, I recently recieved the EHWIC so I can eliminate a cheap switch at our remote sites, and have POE as well so I can power the IP phone and camera.  I have installed the card into the router and it has no problems recognizing the card, ports gig 0/0/0 - 0/0/3.  I upgraded to Version 15.2(3)T2 on the router, but still having a couple problems.

1.  I do not have any POE commands

2.  For some reason I cannot get it configured properly

     All I want to do is use it as a switch for the local lan, which is literally a computer, printer, ip phone and camera.  The router has a T1 serial card for access to the network.  No problems with the current config, gig 0/0 lan and serial 0/0/0 is the T1.  How do I go about making all the ports on the EHWIC part of the LAN?

Thanks,

Bryant

1 ACCEPTED SOLUTION

Accepted Solutions

Bryant

It is an expected behavior that when there are no devices plugged into any switch ports that the switch ports will be down and that the Vlan will be down. So if you would be willing to do it, please plug your laptop back in and try the show ip interface brief and show arp again.

Also I wonder if you would check on and report some things to establish what is working and what is not working.

With the laptop connected to a switch port, and from the command line of the router:

- can you ping the laptop?

- can you ping the router gateway at 10.0.0.1?

- can you ping something in the network beyond 10.0.0.1?

then from the laptop:

- can you ping the router Vlan interface at 10.0.200.1?

- can you ping the router interface at 10.0.0.11?

- can you ping the router gateway at 10.0.0.1?

- can you ping anything in the network beyond 10.0.0.1?

And it occurs to me to ask whether the device at 10.0.0.1 has a route to 10.0.200.0?

HTH

Rick

HTH

Rick

View solution in original post

11 REPLIES 11
vmiller
Rising star

Do you have the PoE power supply

PWR-2901-POE=   ?

Thanks VMiller,

Nope, not for the 2911.  I was just reading about that.  The 1911 may have just been a firmware version problem, but it recognised the card.

I still can't it to work as a switch though.  It passes traffic and functions fine if I connect everything to the switch, but it does not route any traffic.  Here is a wire of what I would like to accomplish:

T1------>Serial 0/0/0 10.10.10.10---------> Gig 0/0 and Gig 0/0/0-3 Internal LAN 10.0.0.x/24

Then I can get rid of the 5 linksys switch which currently connects to gig0/0.

You have not told us what you have tried to configure. So it is hard for us to figure out why it did not work.

As a start have you configured

interface vlan 1

ip address 10.0.0.1 255.255.255.0

HTH

Rick

HTH

Rick

I have tried may things and I am sure I have gone downthe wrong path may times.

If I try assigning an IP to the vlan1 it overlaps with gig0/0 which is on the same subnet.  This is if I remove the IP from gig0/0, I can ping the vlan, but it will not route out gig0/1 to the of the network.

Here is the settings:

hostname router1

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

no ip domain lookup

ip domain name domain.local

!

multilink bundle-name authenticated

!

voice-card 0

!

hw-module pvdm 0/0

!

redundancy

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.0.0.11 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/3/0

no ip address

!

interface GigabitEthernet0/3/1

no ip address

!

interface GigabitEthernet0/3/2

no ip address

!

interface GigabitEthernet0/3/3

no ip address

!

interface Vlan1

ip address 10.0.200.1 255.255.255.0

!

ip default-gateway 10.0.200.1

ip forward-protocol nd

!

ip route 0.0.0.0 0.0.0.0 10.0.0.1

!

control-plane

!

mgcp profile default

!

gatekeeper

shutdown

Bryant

Thanks for the additional information. The main issue that I see is that your default gateway statement points to the vlan address

ip default-gateway 10.0.200.1

I would suggest that you change it to

ip default-gateway 10.0.0.1

which would make it agree with the default route that is configured.

Other than this I do not see any particular issues in the config. what address and what default gateway are configured on the devices attached to the switch ports?

HTH

Rick

HTH

Rick

No, luck, do I need vlan routing setup as well?

hostname router1

!

no aaa new-model

!

!

no ipv6 cef

ip source-route

ip cef

!

no ip domain lookup

ip domain name domain.local

!

multilink bundle-name authenticated

!

voice-card 0

!

hw-module pvdm 0/0

!

redundancy

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address 10.0.0.11 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.0.0.11 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/3/0

no ip address

!

interface GigabitEthernet0/3/1

no ip address

!

interface GigabitEthernet0/3/2

no ip address

!

interface GigabitEthernet0/3/3

no ip address

!

interface Vlan1

ip address 10.0.200.1 255.255.255.0

!

ip default-gateway 10.0.0.1

ip forward-protocol nd

!

ip route 0.0.0.0 0.0.0.0 10.0.0.1

!

control-plane

!

mgcp profile default

!

gatekeeper

shutdownhostname router1
!
no aaa new-model
!
!
no ipv6 cef
ip source-route
ip cef
!
no ip domain lookup
ip domain name domain.local
!
multilink bundle-name authenticated
!
voice-card 0
!
hw-module pvdm 0/0
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
no ip address 10.0.0.11 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.0.11 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/3/0
no ip address
!
interface GigabitEthernet0/3/1
no ip address
!
interface GigabitEthernet0/3/2
no ip address
!
interface GigabitEthernet0/3/3
no ip address
!
interface Vlan1
ip address 10.0.200.1 255.255.255.0
!
ip default-gateway 10.0.0.1
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
control-plane
!
mgcp profile default
!
gatekeeper
shutdown

Bryant

I thought that this ought to have worked. I do notice one change/problem from the config that you posted before. Now both Gig0/0 and Gig0/1 have the same IP address. I would have thought that you would get an error message when you tried to configure this.

Perhaps some additional information might shed some light on this. Would you post the output of show ip protocol, of show ip interface brief, and of show arp?

Also can you confirm for us what is the ip address, what mask, and what gateway configured on a PC connected to a switch port?

HTH

Rick

HTH

Rick

Sorry, typo on the gig0/0, set to no IP.

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.0.0.11 255.255.255.0

duplex auto

speed auto

!

router1#show ip protocol

*** IP Routing is NSF aware ***

router1#show ip interface br

Interface                  IP-Address      OK? Method Status                Protocol

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         unassigned      YES manual down                  down

GigabitEthernet0/1         10.0.0.11       YES manual up                    up

GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down

GigabitEthernet0/3/0       unassigned      YES unset  down                  down

GigabitEthernet0/3/1       unassigned      YES unset  down                  down

GigabitEthernet0/3/2       unassigned      YES unset  down                  down

GigabitEthernet0/3/3       unassigned      YES unset  down                  down

Vlan1                      10.0.200.1      YES manual down                  down

VLAN1 is no shutdown, put when I disconnect my laptop from the router it goes down

router1#show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.0.0.1                0   2c54.2dca.1ae0  ARPA   GigabitEthernet0/1

Internet  10.0.0.11               -   a493.4ca2.f771  ARPA   GigabitEthernet0/1

Internet  10.0.200.1              -   a493.4ca2.f773  ARPA   Vlan1

Client is hard coded with IP 10.0.200.2, SM 255.255.255.0 and GM 10.0.200.1

Bryant

It is an expected behavior that when there are no devices plugged into any switch ports that the switch ports will be down and that the Vlan will be down. So if you would be willing to do it, please plug your laptop back in and try the show ip interface brief and show arp again.

Also I wonder if you would check on and report some things to establish what is working and what is not working.

With the laptop connected to a switch port, and from the command line of the router:

- can you ping the laptop?

- can you ping the router gateway at 10.0.0.1?

- can you ping something in the network beyond 10.0.0.1?

then from the laptop:

- can you ping the router Vlan interface at 10.0.200.1?

- can you ping the router interface at 10.0.0.11?

- can you ping the router gateway at 10.0.0.1?

- can you ping anything in the network beyond 10.0.0.1?

And it occurs to me to ask whether the device at 10.0.0.1 has a route to 10.0.200.0?

HTH

Rick

HTH

Rick

View solution in original post

Thank-you so much.

Here are the results, but the other router was missing the route, and that fixed the problem instantly.  I guess I am not sure why the other router would have needed it to talk to devices on the gig0/1 interface?  They devices would be on the same subnet, so why did it have to go to the router to talk back to 10.0.0.11?

router1#show ip interface bri
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         unassigned      YES manual down                  down
GigabitEthernet0/1         10.0.0.11       YES manual up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3/0       unassigned      YES unset  up                    up
GigabitEthernet0/3/1       unassigned      YES unset  down                  down
GigabitEthernet0/3/2       unassigned      YES unset  down                  down
GigabitEthernet0/3/3       unassigned      YES unset  down                  down
Vlan1                      10.0.200.1      YES manual up                    up


router1#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.0.0.1                0   2c54.2dca.1ae0  ARPA   GigabitEthernet0/1
Internet  10.0.0.11               -   a493.4ca2.f771  ARPA   GigabitEthernet0/1
Internet  10.0.200.1              -   a493.4ca2.f773  ARPA   Vlan1

I can ping the laptop from the router, and the router from the laptop.

Router can ping 10.0.0.11 (local gig0/1) and 10.0.0.10, next hop router

Laptop can ping 10.0.0.11 but not 10.0.0.1

Laptop cannot ping anything on 10.0.0.0/24 besides 10.0.0.11

Bryant

I am glad that you got it worked out. Thanks for using the rating system to mark this question as resolved. It makes the form more useful when people can read about a problem and can know that an answer was found. Your marking has contributed to this process.

I hope you have already figured it out. But just in case let me make the point that packets from the lap could get anywhere in the network. But that as long as the other router was missing the route to 10.0.200 there was no way for responses to get back to the laptop.

HTH

Rick

HTH

Rick