01-19-2006 08:23 AM - edited 03-03-2019 11:30 AM
I just want to make sure I'm doing this correctly. If you change the IP address of a router using eigrp. Assuming the partial config below, Would these be the commands to modify the router? Thank you for your time.
router(config)# interface Ethernet0/0
router(config-if)# no ip address <old_ip> <mask>
router(config-if)# ip address <new_ip> <mask>
router(config-if)# exit
router(config)# router eigrp 100
router(config)# no network <old_network>
router(config)# network <new_network>
router(config)# exit
controller T1 0/0
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-12 speed 64
!
controller T1 0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-12 speed 64
!
controller T1 0/2
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/3
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
!
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
no ip route-cache
no ip mroute-cache
half-duplex
!
interface Serial0/0:0
description Frame-Relay Network
ip address 192.168.2.1 255.255.255.0
encapsulation frame-relay
no ip route-cache
traffic-shape rate 768000 19200 19200 1000
traffic-shape adaptive 128000
!
interface Serial0/1:0
ip address x.x.x.x 255.255.255.x
ip nat outside
shutdown
!
interface Serial0/2:0
ip address 192.168.3.1 255.255.255.252
no ip route-cache
!
interface Serial0/3:0
ip address 192.168.3.5 255.255.255.252
no ip route-cache
!
router eigrp 100
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
no eigrp log-neighbor-changes
!
Solved! Go to Solution.
01-19-2006 12:23 PM
If you change all the equipment connected on that segment, and if you change the other router connected on that segment, then you should avoid the issue that I described.
To the extent that you coordinate the change on both routers to be at the same time you minimize the interruption to connectivity and to the neighbor relationship. Obviously while you are changing the address on the equipment connected on that segment there will be some impact on connectivity for that equipment. There is an approach that will provide connectivity during the transition:
when the changes start:
configure terminal
interface fastethernet 0
no ip address
ip address
ip address
router eigrp 100
network
This will allow the router to forward packets to both subnets and provide connectivity to both stations with new addressing and stations with old addressing.
After the addressing change is completed:
configure terminal
interface fastethernet 0
no ip address
router eigrp 100
no network
This removes the references to the old addressing and leaves the router processing the new address space.
HTH
Rick
01-19-2006 08:56 AM
Hello,
it depends. If you change the IP address of the interface to an address that is already included in the ´network´ statement under EIGRP, you just have to change the IP address on the interface. Here is an example:
router(config)# interface Ethernet0/0
router(config-if)# no ip address 192.168.1.1 255.255.255.0
router(config-if)# ip address 192.168.1.2 255.255.255.0
router(config-if)# exit
In this case, since the new IP address is already included in the ´network 192.168.1.0´ statement, you would not have to make any changes to your EIGRP configuration.
In this example:
router(config)# interface Ethernet0/0
router(config-if)# no ip address 192.168.1.1 255.255.255.0
router(config-if)# ip address 192.168.4.1 255.255.255.0
router(config-if)# exit
You would have to add that network to your EIGRP configuration:
router(config)# router eigrp 100
router(config)# no network 192.168.1.0
router(config)# network 192.168.4.0
router(config)# exit
Keep in mind that with the network statement, you actually tell the router which interfaces to include in the EIGRP process. So if you say e.g. ´network 192,168.0.0 0.0.255.255´, you would need only one network statement to advertise all your interfaces with IP addresses falling into that range...
Does that make sense ?
Regards,
GP
01-19-2006 09:02 AM
I believe that the commands that you posted will do well. It is not strictly necessary to remove the old ip address from the interface before you apply the new one. But I would do it the way that you show by removing the old address and then apply the new address.
One thing to consider is whether there are any EIGRP neighbors on the interface that you are changing. If there are no neighbors then your changes are straightforward. If there are neighbors on that interface then they formed neighbor relationships through the old address. When you change the interface to a new address (in a new network) the old neighbor relationships should not work any more, and if the neighbors continue to send EIGRP hello messages with the old address then your EIGRP will generate error messages about not on common subnet.
HTH
Rick
01-19-2006 10:30 AM
This ip address change is to a new subnet. All the equipment currently on this subnet will be changed. There is another router on the local subnet that will also be changed. It is using eigrp with the common 192.168.10 network listed. To my knowledge this is the only other router that uses eigrp in the network. So by changing both eigrp enabled routers do I avoid your scenario of broken eigrp neighbors? Thank you for taking the time to respond.
Here is a snippet from the other router:
interface FastEthernet0
ip address 192.168.1.2 255.255.255.0
ip access-group 101 in
ip access-group 100 out
ip nat inside
speed 10
half-duplex
!
interface Serial0
ip address x.x.x.x 255.255.255.x
ip access-group 100 in
ip access-group 101 out
ip nat outside
no fair-queue
service-module t1 timeslots 1-12
!
router eigrp 100
network 192.168.1.0
no auto-summary
no eigrp log-neighbor-changes
01-19-2006 12:23 PM
If you change all the equipment connected on that segment, and if you change the other router connected on that segment, then you should avoid the issue that I described.
To the extent that you coordinate the change on both routers to be at the same time you minimize the interruption to connectivity and to the neighbor relationship. Obviously while you are changing the address on the equipment connected on that segment there will be some impact on connectivity for that equipment. There is an approach that will provide connectivity during the transition:
when the changes start:
configure terminal
interface fastethernet 0
no ip address
ip address
ip address
router eigrp 100
network
This will allow the router to forward packets to both subnets and provide connectivity to both stations with new addressing and stations with old addressing.
After the addressing change is completed:
configure terminal
interface fastethernet 0
no ip address
router eigrp 100
no network
This removes the references to the old addressing and leaves the router processing the new address space.
HTH
Rick
01-19-2006 02:01 PM
Thank you both for taking the time to discuss this with me. I appreciate it.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide