cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3576
Views
0
Helpful
3
Replies
Highlighted
Beginner

Enabling https on 2950G switch

I upgraded one of our cisco 2950  switch with the IOS image :c2950-i6k2l2q4-mz.121-22.EA13.tar .

After upgradation ,enabled ssh v2.

Its accessible through ssh, but I want enable https to view the web inteface.

I tried using the cammand " ip http secure-server", but its not working on this IOS image.

Please suggest how to enable https for web-console.

3 REPLIES 3
Highlighted
Cisco Employee

Hi,

I am not completely sure if you can do it, but I think you could try the following.

To secure the http server you can configure the following commands:

"ip http access-class"

Here is the information of the command.

http://www.cisco.com/en/US/docs/ios/12_2/configfun/command/reference/frf005.html#wp1020068

"ip http authentication"

Here is the information of the command.

http://www.cisco.com/en/US/docs/ios/12_2/configfun/command/reference/frf005.html#wp1020124

I hope it may help

Thanks,

Itzcoatl Espinosa

Highlighted
Advocate

Hi,

what's your IOS feature set?

Isn't  it a Crypto Image?

You need C2950 EI AND SI IOS CRYPTO IMAGE AND CMS FILES then.

If I remember correctly, an http file structure is necessary on your Flash for a web access to work.

If I'm correct, http access is also not working on your switch currently, is it?

HTH,

Milan

Highlighted

Hi Milan,

As u can see in my discussion..... I already mentioned that I enbaled ssh..that means its a crypto image.

If it was not a crypto..then I cud not be able to enable ssh.

For your clarification....if I disable ssh..then http is working.(As i used the CMS file..i.e tar file of the IOS image to upgrade)

But if I enable ssh......http wont work,,,,as it requires secure connection.....for this we have to enble https by using the command "ip http secure-server".


The problem is that.....the above command is not supported on this current image.....so I want to know that if there is any different way to enable https, then pls suggest.