Hello. I'm having an issue with routing when it comes to a non-vrf to vrf.
on router1 i can ping and traceroute using the VRF with no problems to the destination subnet.
on router2 it will forward the traffic to router 1 but then just dies there.
router1 P2P to WAN 192.168.39.40/29
router2 to router1 10.0.251.0/24
remote site 10.19.4/24
router 1
interface port-channel1.903
encapsulation dot1q 903
ip vrf forwarding public-captive
ip address 10.0.251.253 255.255.255.0
interface port-channel1.78
encapsulation dot1q 78
ip vrf forwarding public-captive
ip address 192.168.39.42 255.255.255.248
ip route vrf public-captive 0.0.0.0 0.0.0.0 10.0.251.254
ip route vrf public-captive 10.19.4.0 255.255.255.0 192.168.39.41
===================================================
router 2
interface gig0/0.903
encapsulation dot1q 903
ip address 10.0.251.254 255.255.255.0
ip route 10.0.0.0 255.128.0.0 10.0.251.253