cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
913
Views
15
Helpful
29
Replies
Highlighted
Enthusiast

GRE Tunnel issue

Hello Experts,

I need help...urgently

 

i created a normal GRE tunnels on two routers!(routing protocol: EIGRP)

 

i can see that one side EIGRP Tunnel is up and also showing in eigrp neighbour but other side tunnel is also UP but not shwoing eigrp neighbour. Also i cant ping the tunenl IP from both end.

 

Router1:

 

interface Tunnel100
ip address 172.25.100.1 255.255.255.252
ip mtu 1300
ip tcp adjust-mss 1260
tunnel source 148.244.229.68
tunnel destination 96.85.125.162

!

router eigrp 1
distribute-list prefix filter_eigrp out
network 10.84.0.0 0.0.255.255
network 172.25.100.0 0.0.0.3
redistribute static route-map static2EIGRP
passive-interface Loopback0

 

Router2:

 

interface Tunnel100
ip address 172.25.100.2 255.255.255.252
ip mtu 1300
ip tcp adjust-mss 1260
tunnel source 96.85.125.162
tunnel destination 148.244.229.68

!

router eigrp 1
distribute-list prefix filter_eigrp out
network 10.86.0.0 0.0.255.255
network 172.25.100.0 0.0.0.3
redistribute static route-map static2EIGRP
passive-interface Loopback0

 

Thanks

 

 

29 REPLIES 29
Highlighted
Rising star

Please do show ip eigrp interfaces

Make sure that EIGRP is enabled on the tunnel interface on both routers. 

Highlighted

Also, do you have a static route pointing to the destination IP of the tunnel interface going out the correct interface on both sides?
Highlighted

yes it is there..

 

ip route 148.244.229.68 255.255.255.255 96.85.125.174 name Spoke_CO_AL-PUEBLA

 

ip route 96.85.125.162 255.255.255.255 148.244.229.65 name Spoke_AL_CO-DETROI

Highlighted

Here is isÖ

 

PURCVPN1#sh ip ei interfaces
EIGRP-IPv4 Interfaces for AS(1)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Tu1 1 0/0 0/0 186 0/2 762 0
Tu2 1 0/0 0/0 180 0/2 722 0
Vl4 1 0/0 0/0 1 0/0 50 0
Vl6 0 0/0 0/0 0 0/0 0 0
Tu187 1 0/0 0/0 70 0/5 252 0
Tu87 2 0/0 0/0 59 0/4 260 0
Tu100 0 0/0 0/0 0 6/6 0 0
PURCVPN1#

Highlighted
Rising star

ping  148.244.229.68 source 96.85.125.162
ping  96.85.125.162 source 148.244.229.68

Highlighted

result..

 

PURCVPN1#ping 96.85.125.162 source gig0/1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 96.85.125.162, timeout is 2 seconds:
Packet sent with a source address of 148.244.229.68
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/92/96 ms

 

 

DERCVPN1#ping 148.244.229.68 so 96.85.125.162
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.244.229.68, timeout is 2 seconds:
Packet sent with a source address of 96.85.125.162
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 93/98/100 ms
DERCVPN1#

 

its working

 

 

Highlighted

check acl's on both sides
Highlighted

permit ip any any 

 

 

ACL is not blcoking anything....

Highlighted

Can you ping between the tunnel interfaces now?

Highlighted

no its not working..

 

PURCVPN1#ping 172.25.100.2 so tunnel 100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.25.100.2, timeout is 2 seconds:
Packet sent with a source address of 172.25.100.1
.....
Success rate is 0 percent (0/5)
PURCVPN1#

Highlighted

show the configuration on 148.244.229.68

Highlighted

here its is:

 

 

deleted...-----------------------------

Highlighted

PURCVPN1#ping 96.85.125.162

Does this have a route to 96.85.126.162?

Highlighted

yes it has..

 

PURCVPN1#ping 96.85.125.162
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 96.85.125.162, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/91/96 ms
PURCVPN1#