cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
342
Views
5
Helpful
2
Replies
Beginner

[GRE Tunnel] Tunnel5 is up, line protocol is down

tHello,

 

I have an issue between two GRE tunnels between 2 different sites.

 

Indeed, i have the main router C2600 ("flash:c2600-js56i-mz.121-3.bin") at one site with this configuration :

 

interface Tunnel5
description Tunnel GRE vers Barbes
ip address 172.16.248.121 255.255.255.252
tunnel source Ethernet0/0
tunnel destination 10.4.18.19
!
interface Ethernet0/0
description vers LAN Devoteam
ip address 172.16.248.142 255.255.255.252
!
interface Ethernet0/1
description vers LAN Controle Acces
ip address 172.16.248.1 255.255.255.240

!

ip route 172.16.248.80 255.255.255.240 Tunnel5

 

And i have another router more recent (Cisco 881) with this IOS : "flash:c800-universalk9-mz.SPA.154-3.M9.bin" and here is the config :

 

interface Tunnel5
description tunnel GRE vers Massy
ip address 172.16.248.122 255.255.255.252
tunnel source FastEthernet0
tunnel destination 172.16.248.142

 

interface FastEthernet0
description Vers SWCABBU1N1
switchport access vlan 4
no ip address
duplex half
speed 100
!
interface FastEthernet1
description vers LAN Controle Acces
switchport access vlan 248
no ip address
duplex half
speed 100

!


interface Vlan4
ip address 10.4.18.19 255.255.255.0
!
interface Vlan248
ip address 172.16.248.81 255.255.255.240
!
no ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 Tunnel5
ip route 172.16.248.142 255.255.255.255 10.4.18.4

 

At the main site, the tunnel5 and the line protocol are OK but in the another site, the tunnel5 is up but not the line protocol which is down.

 

Could you help me please ? It's very urgent :s.

 

Thanks in advance.

 

Best regards.

 

Kevin M

Everyone's tags (5)
2 REPLIES 2
Beginner

Re: [GRE Tunnel] Tunnel5 is up, line protocol is down

Hi Kevin,

 

interface Tunnel5
description Tunnel GRE vers Barbes
ip address 172.16.248.121 255.255.255.252
tunnel source Ethernet0/0
tunnel destination 10.4.18.19 <--- missing a route for this destination IP

 

I'm only seeing the following route in the first config snippet -> ip route 172.16.248.80 255.255.255.240 Tunnel5

 

Add a route towards the destination 10.4.18.19 -> ip route 10.4.18.19 255.255.255.255 172.16.248.141

 


Hope this helps you, thanks.
-Piero

Re: [GRE Tunnel] Tunnel5 is up, line protocol is down

Hi Kevin,

 

I see two issues in your configuration:

1) For the GRE tunnel to be UP, it should have a source interface with IP address configured.

 

On (Cisco 881):

 

interface Tunnel5
description tunnel GRE vers Massy
ip address 172.16.248.122 255.255.255.252
tunnel source FastEthernet0
tunnel destination 172.16.248.142

 

interface FastEthernet0
description Vers SWCABBU1N1
switchport access vlan 4
no ip address
duplex half
speed 100

 

You will need to correct your source interface to be vlan 4. Here is the correct config:

interface Tunnel5
description tunnel GRE vers Massy
ip address 172.16.248.122 255.255.255.252
tunnel source vlan 4
tunnel destination 172.16.248.142

 

2) I do not see a route to the Cisco 881 network (route to 10.4.18.0/24) from C2600. Please add a route to 10.4.18.19 so that it could be reached from c2600.

 

HTH,

Meheretab

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards