cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
469
Views
0
Helpful
1
Replies

GRE Tunneling

kmchoong
Level 1
Level 1

I have 2 router, router A and B at two different locations. RA at HQ and RB at branch.

RA router

int tunnel 0

ip address 10.1.1.1 255.255.255.0

tunnel source s0/0/1

tunnel destination 203.1.1.1

tunnel mode gre ip

!

int s0/0/1

ip address 202.1.1.1

!

int eth 0

ip address 192.168.1.1 255.255.255.0

!

ip route 192.168.2.0 255.255.255.0 tunnel0

!

RB

interface tunnel 0

ip address 10.1.1.2 255.255.255.0

tunnel source s0/0/0

tunnel destination 202.1.1.1

tunnel mode gre ip

!

int eth 0

ip address 192.168.2.1 255.255.255.0

!

int s0/0/0

ip address 203.1.1.1 255.255.255.0

!

ip route 192.168.1.0 255.255.255.0 tunnel0

!

How should I configure the routerB, so that Internet access from branch office must go to HQ first?

1 Reply 1

Richard Burts
Hall of Fame
Hall of Fame

If you want all Internet traffic from the branch to go to HQ then on router B configure a default route which points to the tunnel:

ip route 0.0.0.0 0.0.0.0 10.1.1.1

I see one possible issue with this config as you have posted it. I do not see anything that tells the router how to get to the tunnel destination. For example router A needs to route tunnel packets to destination 203.1.1.1. How will router A know how to route to that address? If you are running a dynamic routing protocol which is not included that might solve it. (But from the number of static routes on each router I am assuming that you are not running a dynamic routing protocol.) Or each router needs a static route for the tunnel destination address.

HTH

Rick

HTH

Rick
Review Cisco Networking for a $25 gift card