12-11-2024 03:51 AM
hi all.
im trying to upgrade a ir809, but keeps getting this error:
VV_SAK_VB01#bundle install flash:ir800-universalk9-bundle.SPA.158-3.M9.bin
Installing bundle image: /ir800-universalk9-bundle.SPA.158-3.M9.bin........................................................................................................................................................................
updating Hypervisor image...
Sending file modes: C0644 25173361 ir800-hv.srp.SPA.3.1.28
%Error copy from scp://*:*@127.1.3.1//vds_system/bundle/ir800-hv.srp.SPA.3.1.28 to bootstrap:ir800-hv.srp.SPA.3.1.28
Make sure SSH source interface is not configured.
Failed to install hypervisor image!
i know if you have SSH-interface on, then this error can come. but i do not have that!
here is the config:
hostname VV_SAK_VB01
!
boot-start-marker
boot-end-marker
!
!
enable secret 9 xxxxxx
!
no aaa new-model
!
ip vrf VV_AGR_KL01
!
ip vrf VV_AGR_KL02
!
ip vrf VV_AGR_KL03
!
ip vrf VV_SKS_TR001
!
!
ip domain name forsyning.local
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
license udi pid IR809G-LTE-GA-K9 sn FCW23220HHX
!
!
username xxxxx privilege 15 secret 9 xxxxx
username xxxx privilege 15 secret 9 xxxxx
!
redundancy
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte failovertimer 5
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
!
crypto keyring site-VV_AGR_KL01
pre-shared-key address 10.254.16.14 key xxxxx
crypto keyring site-VV_AGR_KL02
pre-shared-key address 10.254.16.15 key xxxx
crypto keyring site-VV_AGR_KL03
pre-shared-key address 10.254.16.16 key xxxxx
crypto keyring site-VV_SKS_TR001
pre-shared-key address 10.254.16.21 key xxxxx
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 14
!
!
no crypto ipsec transform-set default
crypto ipsec transform-set AES-256-SHA esp-aes 256 esp-sha-hmac
mode tunnel
!
!
crypto ipsec profile tunnel-to-VV_AGR_KL01
set transform-set AES-256-SHA
!
crypto ipsec profile tunnel-to-VV_AGR_KL02
set transform-set AES-256-SHA
!
crypto ipsec profile tunnel-to-VV_AGR_KL03
set transform-set AES-256-SHA
!
crypto ipsec profile tunnel-to-VV_SKS_TR001
set transform-set AES-256-SHA
!
!
bridge irb
!
!
interface Loopback0
ip address 198.18.16.13 255.255.255.255
!
interface Tunnel1
description Tunnel to VV_AGR_KL01
ip vrf forwarding VV_AGR_KL01
ip address 172.25.0.121 255.255.255.252
ip mtu 1400
tunnel source 10.254.16.13
tunnel mode ipsec ipv4
tunnel destination 10.254.16.14
tunnel protection ipsec profile tunnel-to-VV_AGR_KL01
!
interface Tunnel2
description Tunnel to VV_AGR_KL02
ip vrf forwarding VV_AGR_KL02
ip address 172.25.0.125 255.255.255.252
ip mtu 1400
tunnel source 10.254.16.13
tunnel mode ipsec ipv4
tunnel destination 10.254.16.15
tunnel protection ipsec profile tunnel-to-VV_AGR_KL02
!
interface Tunnel3
description Tunnel to VV_AGR_KL03
ip vrf forwarding VV_AGR_KL03
ip address 172.25.0.129 255.255.255.252
ip mtu 1400
tunnel source 10.254.16.13
tunnel mode ipsec ipv4
tunnel destination 10.254.16.16
tunnel protection ipsec profile tunnel-to-VV_AGR_KL03
!
interface Tunnel7
description Tunnel to VV_SKS_TR001
ip vrf forwarding VV_SKS_TR001
ip address 172.25.0.154 255.255.255.252
ip mtu 1400
tunnel source 10.254.16.13
tunnel mode ipsec ipv4
tunnel destination 10.254.16.21
tunnel protection ipsec profile tunnel-to-VV_SKS_TR001
!
interface GigabitEthernet0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0.1501
encapsulation dot1Q 1501
ip vrf forwarding VV_AGR_KL01
ip address 172.25.1.1 255.255.255.252
!
interface GigabitEthernet0.1502
encapsulation dot1Q 1502
ip vrf forwarding VV_AGR_KL02
ip address 172.25.1.5 255.255.255.252
!
interface GigabitEthernet0.1503
encapsulation dot1Q 1503
ip vrf forwarding VV_AGR_KL03
ip address 172.25.1.9 255.255.255.252
!
interface GigabitEthernet0.1507
encapsulation dot1Q 1507
ip vrf forwarding VV_SKS_TR001
ip address 172.25.1.25 255.255.255.252
!
interface GigabitEthernet1
no ip address
duplex auto
speed auto
bridge-group 1
!
interface GigabitEthernet2
no ip address
duplex auto
speed auto
bridge-group 1
!
interface Cellular0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
!
interface Cellular1
no ip address
encapsulation slip
shutdown
!
interface Async0
no ip address
encapsulation scada
shutdown
!
interface Async1
no ip address
encapsulation scada
shutdown
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Cellular0
ip route vrf VV_AGR_KL01 0.0.0.0 0.0.0.0 172.25.1.2
ip route vrf VV_AGR_KL01 192.168.216.0 255.255.255.248 172.25.0.122
ip route vrf VV_AGR_KL02 0.0.0.0 0.0.0.0 172.25.1.6
ip route vrf VV_AGR_KL02 192.168.216.8 255.255.255.248 172.25.0.126
ip route vrf VV_AGR_KL03 0.0.0.0 0.0.0.0 172.25.1.10
ip route vrf VV_AGR_KL03 192.168.216.16 255.255.255.248 172.25.0.130
ip route vrf VV_SKS_TR001 0.0.0.0 0.0.0.0 172.25.1.26
ip route vrf VV_SKS_TR001 192.168.216.104 255.255.255.248 172.25.0.153
ip ssh rsa keypair-name SSH
ip ssh version 2
!
ip sla 1
icmp-echo 10.254.253.14 source-interface Loopback0
timeout 10000
frequency 10
ip sla schedule 1 life forever start-time now
dialer-list 1 protocol ip permit
ipv6 ioam timestamp
!
!
snmp-server community GF-SNMP RO
snmp-server enable traps wpan
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred ssh
transport output ssh
rxspeed 100000000
txspeed 50000000
line 8
no exec
transport preferred ssh
transport output ssh
rxspeed 100000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
exec-timeout 0 0
privilege level 15
login local
transport input ssh
transport output ssh
line vty 5 797
login local
transport input ssh
transport output ssh
!
no scheduler max-task-time
no iox hdm-enable
no iox client enable interface GigabitEthernet2
no iox recovery-enable
!
end
12-11-2024 04:36 AM
It seems to be a known issue and already discussed here in the community. Check below thread. At the end of the thread, some guys provide the solution.
https://community.cisco.com/t5/routing/ir829-image-upgrade-error/td-p/4007605
12-11-2024 04:53 AM
no thats not the problem. The problem descriped ind the link, is no more space in bootstrap. Thats not my problem!!!
My problem is this:
updating Hypervisor image...
Sending file modes: C0644 25173361 ir800-hv.srp.SPA.3.1.28
%Error copy from scp://*:*@127.1.3.1//vds_system/bundle/ir800-hv.srp.SPA.3.1.28 to bootstrap:ir800-hv.srp.SPA.3.1.28
Make sure SSH source interface is not configured.
Failed to install hypervisor image!
12-11-2024 05:05 AM - edited 12-11-2024 05:06 AM
The message related to %Error copy is the same. If you dont know what else to do, I believe you should give it a try.
Sometimes the device send logs that dont make sense as you already verified. If you dont have source interface for SSH, this message does not make sense. Device is trying to help you by guessing some possible issue.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide