cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2538
Views
0
Helpful
24
Replies

How do I connect router to internet

arifdatau
Beginner
Beginner

Here is my home topology:

1. Dell Server: Domain: SWLAB.lab, Static Ip 192.168.1.91/24, Default Gateway: 192.168.1.1/24, Running services DHCP and DNS. DCHP ip scope 192.168.1.1 - 192.168.1.100. Ip address excluded start ip add .1 end ip add .5, .50 - .60, and .90 - .99.

2. Asus wireless router LAN ip: 192.168.1.1/24 (DHCP Disable) Router has 4 ports.

2. WAN IP: 134.74.126.111/27

3. External Gateway 134.74.126.50

I want to connect to internet through Cisco router 1841. Currently, I connected FastEthernet0/0 to the Asus wireless router that I disable DHCP services and it captured DHCP ip from my Server.

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip virtual-reassembly

interface FastEthernet0/1

description to switch 2960 on Fa0/1

ip address 192.168.10.5 255.255.255.0

ip nat inside

ip virtual-reassembly

R1#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C    192.168.1.0/24 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 is directly connected, FastEthernet0/0

I can ping my server etc. as well as WAN IP but I cannot ping WAN IP Gateway 134.74.126.50. I also cannot ping www.yahoo.com

I would appreciate for your help on giving me the right configuration to access my PC that connected to Switch fas0/2 to the internet.

Thank you.

24 Replies 24

hi,

ok, so where does the 1841 connected? is it behind one of the asus' FE port?

based from your orginal post, my understanding was that you'll be using the 1841 as the internet edge router.

Hi John - the 1841 and also the rest of my LAN is connected to the FE port (Laptops using Wi-Fi). With all of these remarked have been said and done I still don't have proper configuration natting the 1841 to WAN internet. I 'am hoping I can get the correct answer of all of these. Thanks.

Here is the server look like...

Ok I gotcha. I was reading again your original post. Try to do as below:

interface FastEthernet0/0

description to Asus

ip address 192.168.1.2 255.255.255.0

interface FastEthernet0/1

description to switch 2960 on Fa0/1

ip address 192.168.10.5

255.255.255.0

ip helper-address 192.168.1.191

ip route 0.0.0.0 0.0.0.0 192.168.1.1

You would also need to add a static route on your Asus towards the 192.168.10.0/24 subnet and hop via the 1841. In Cisco device it would look like:

ip route 192.168.10.0 255.255.255.0 192.168.1.2

Make sure your Asus WAN interface gets an IP via DHCP from the ISP and does NAT for the LAN IP.

Sent from Cisco Technical Support iPhone App

Hi John,

Where does the ip helper-address 192.168.1.191 point to? did you mean 192.168.1.91 which it the static ip address (see diagram above) for the server 2008? Thanks

Hi,

May I suggest something? Why dont you move the Dell server from Asus and plug it into the switch?

That way it will cut out on DHCP problems. Have a /30 subnet configured between 1841 and Asus and use a default static route on 1841 to send all traffic to Asus. On Asus configured a static route for 192.168.1.0 network that points to 1841 and everything and everyone should be happy.

Regards

Eugen

yes, basically the 1841 would act as a DHCP relay agent since your DHCP server is on another subnet. i also forgot to mention you should create a new pool for the 192.168.10.0/24 with default gateway of 192.168.10.5. your 2960 should also have the ip default-gateway 192.168.10.5 command.

eugen also has a good point. try considering his advice.

ebarticel
Enthusiast
Enthusiast

Your Asus router/modem has to be the default gateway for everyone on your LAN, because every network device is chained to the Asus 4 ports. If your PC is pointing to the server or the 1841 router as a default gateway won't be able to go out of the LAN.

Hope this helps

Eugen

Hi Eugen,

the default gateway MUST be a device on the same subnet as the hosts so if the hosts are connected to the 1841 which is connected to the modem then the default gateway MUST be the 1841.

Regards.

Alain

Don't forget to rate helpful posts.

Hi Alan,

Thank again for correcting me, you are right about the router's default gateway, but from what I understood is that he wants Dell Server to give out ip addresses to everyone on the LAN. He mentioned that he disabled DHCP on Asus for this purpose.

Of course there is more than one way to skin a cat.

He can have both interfaces on 1841 get DHCP from Dell and ASUS becomes the default gateway.

He can configure helper address on router, but he needs 2 dhcp pools on Dell.......and on and on.

Regards

Eugen

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers