08-05-2005 04:13 AM - edited 03-03-2019 10:12 AM
Hello,
Newbie question.
How do I completely clear/delete the current running-configuration on a 2514? I want to start the router config totally from scratch.
TIA,
Rich
08-05-2005 04:26 AM
Hi,
You can issue "erase startup-config" and then reboot the router.
HTH
PJD
08-05-2005 05:18 AM
Thank You,
I think that will do it.
I have one additional question.
When I telnet to the router from a DOS prompt, I get the following message:
"Password required, but none set.
Connection to host lost."
I also get the same message if I connect to the router via Hypertrm.exe.
Can anyone offer a solution?
Thanks again,
Rich
08-05-2005 05:36 AM
Sure,
It sounds like on your vty lines you have the command "login" configured however you haven't set up a password.
To set up a password you can try
# configure terminal
# line vty 0 4
# password
# exit
# line console 0
# password
# end
You can then also enter an enable mode password to take you into privilage mode
# enable secret
Alternatively if you didn't want a password you could try adding "no login" without using the "password" command to the above lines, this is fine for a test lab but not for the real world!
HTH
PJD
08-05-2005 05:38 AM
The erase startup-config and reboot is exactly how to start over from scratch.
The issue you are having with telnet is that the router does not have any password configured on the vty ports. The IOS by default requires a password on the vty ports for telnet to work. It is not an issue with your access software (telnet from DOS or hyperterm or any other software) but is an issue of router configuration.
There are two potential solutions to your issue. Both of them are changes in the configuration of the router. I would prefer to solve the problem by configuring a password. To configure a password do this:
config terminal
line vty 0 4
password
end
The other solution is to explicitly configure the vty to not require a password. To do this:
config terminal
line vty 0 4
no login
This will explicitly tell IOS not to require a password and will allow telnet. From a security standpoint I do not like this solution. But from a practicality situation it will work.
HTH
Rick
08-05-2005 05:55 AM
You're right. The last line in the config is a "login". My network is at home and the config will likely be changed often as I am just trying to learn and try new things. I'll try your suggestions and reply hopefully this afternoon.
Thanks again,
Rich
08-05-2005 11:28 AM
Thanks everyone,
I am certainly learning. I have come across a problem however. I can't see where I'm actually routing. I can't ping from 1 side of the router to the other. Below is output from "show running-config". Everything was config'd from the IOS wizard after I erased the configuration. Am I missing a statement such as this:
ip route 0.0.0.0 0.0.0.0 192.168.1.254
User Access Verification
Password:
Cisco-2514>ena
Password:
Cisco-2514#show running-config
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Cisco-2514
!
enable secret xxx
enable password xxx
!
no ip routing
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip route-cache
!
interface Ethernet1
ip address 192.168.10.1 255.255.255.0
no ip route-cache
!
interface Serial0
no ip address
no ip route-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip route-cache
shutdown
!
no ip classless
snmp-server community public RO
!
line con 0
line aux 0
line vty 0 4
password xxx
login
!
end
Cisco-2514#
08-05-2005 11:43 AM
I also would like to get rid of the SNMP-related lines.
Thanks,
Rich
08-05-2005 02:01 PM
Hi,
If you have devices on each side of your router, as long as they addressed in the correct networks as per your router interfaces, and they have the correct netmask and default gateways then your router should route between the networks.
If you have other networks connected by other routers then indeed you will need to configure some routing on this router.
HTH
PJD
08-05-2005 02:04 PM
DOH: i just looked at your config and your router is not routing as it has the following command "no ip routing" so you need to change this to "ip routing", this is why its not working :)
Also to remove any commands in your config (you mentioned SNMP) you can normally do this by just putting a "no" at the beginning.
HTH
PJD
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide