12-13-2020 11:44 PM
Hi guys, so I'm new to packet tracer and am trying to learn to set up a multimedia network and I wanna include VoIP in it. I've been trying to figure out how to set up IP phones over a WAN but even after trying to follow all the tutorials I found online I'm still at a loss. I tried to enter telephony service command on my routers in global level config (which the tutorials guided me to) but all I got was "invalid input detected" instead. I'm not sure if this has something to do with my routers not being 2811 cuz I heard only 2811 support telephony service command. If that's the case is there any way you can make IP phones work on non-2811 routers? because I don't have any 2811 routers (which I just realized) in my design and I prefer not to change all my routers to 2811 and start all over (configuring protocols, IP addresses, etc), if possible.
Here's my topology design. Thanks in advance for your help!
Solved! Go to Solution.
12-15-2020 04:20 AM
Hello,
you forgot to configure the dial peers. Attached the working PT project file (saved in version 7.3.1.) and the running configs (additions marked in bold).
Living_Room_Router#sh run
Building configuration...
Current configuration : 1438 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Living_Room_Router
!
ip dhcp pool VOICE
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1
option 150 ip 192.168.4.1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 192.168.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.10.2 255.255.255.0
encapsulation frame-relay
clock rate 2000000
!
interface Serial1/1
no ip address
clock rate 2000000
shutdown
!
interface Serial1/2
no ip address
clock rate 2000000
shutdown
!
interface Serial1/3
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 192.168.10.0
network 192.168.4.0
network 192.168.5.0
auto-summary
!
ip classless
!
ip flow-export version 9
!
dial-peer voice 1 voip
destination-pattern 5400.
session target ipv4:192.168.10.1
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 192.168.4.1 port 2000
auto assign 4 to 6
auto assign 1 to 5
!
ephone-dn 1
number 54002
!
ephone 1
device-security-mode none
mac-address 0010.117B.0429
type 7960
button 1:1
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
Bedroom_Router#sh run
Building configuration...
Current configuration : 1381 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Bedroom_Router
!
ip dhcp pool VOICE
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
option 150 ip 192.168.1.1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
ip address 192.168.10.1 255.255.255.0
encapsulation frame-relay
!
interface Serial1/1
no ip address
clock rate 2000000
shutdown
!
interface Serial1/2
no ip address
clock rate 2000000
shutdown
!
interface Serial1/3
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 192.168.10.0
network 192.168.1.0
auto-summary
!
ip classless
!
ip flow-export version 9
!
dial-peer voice 1 voip
destination-pattern 5400.
session target ipv4:192.168.10.2
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 192.168.11.1 port 2000
auto assign 4 to 6
auto assign 1 to 5
!
ephone-dn 1
number 54001
!
ephone 1
device-security-mode none
mac-address 00E0.F7C6.20B8
type 7960
button 1:1
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
12-14-2020 12:02 AM
Hello,
the short answer is: you DO need the 2811 router. It is the only router in Packet Tracer that supports the 'telephony-service' command...
12-15-2020 12:40 AM
I see...that's a bummer, but anyways I just went ahead and replaced the routers with 2811 then followed the tutorials online and finished the configuration for telephony service. However, calls can't get through, phones don't even ring at all. Did I miss something? As a side note, all computers can ping each other, just IP phones don't work tho.
I've updated the file of my topology and attached it below, any idea what went wrong?
Again thanks for your help
12-15-2020 04:20 AM
Hello,
you forgot to configure the dial peers. Attached the working PT project file (saved in version 7.3.1.) and the running configs (additions marked in bold).
Living_Room_Router#sh run
Building configuration...
Current configuration : 1438 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Living_Room_Router
!
ip dhcp pool VOICE
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1
option 150 ip 192.168.4.1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 192.168.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.10.2 255.255.255.0
encapsulation frame-relay
clock rate 2000000
!
interface Serial1/1
no ip address
clock rate 2000000
shutdown
!
interface Serial1/2
no ip address
clock rate 2000000
shutdown
!
interface Serial1/3
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 192.168.10.0
network 192.168.4.0
network 192.168.5.0
auto-summary
!
ip classless
!
ip flow-export version 9
!
dial-peer voice 1 voip
destination-pattern 5400.
session target ipv4:192.168.10.1
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 192.168.4.1 port 2000
auto assign 4 to 6
auto assign 1 to 5
!
ephone-dn 1
number 54002
!
ephone 1
device-security-mode none
mac-address 0010.117B.0429
type 7960
button 1:1
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
Bedroom_Router#sh run
Building configuration...
Current configuration : 1381 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Bedroom_Router
!
ip dhcp pool VOICE
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
option 150 ip 192.168.1.1
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
ip address 192.168.10.1 255.255.255.0
encapsulation frame-relay
!
interface Serial1/1
no ip address
clock rate 2000000
shutdown
!
interface Serial1/2
no ip address
clock rate 2000000
shutdown
!
interface Serial1/3
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 192.168.10.0
network 192.168.1.0
auto-summary
!
ip classless
!
ip flow-export version 9
!
dial-peer voice 1 voip
destination-pattern 5400.
session target ipv4:192.168.10.2
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 192.168.11.1 port 2000
auto assign 4 to 6
auto assign 1 to 5
!
ephone-dn 1
number 54001
!
ephone 1
device-security-mode none
mac-address 00E0.F7C6.20B8
type 7960
button 1:1
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
12-15-2020 05:27 AM
Omg thank you so much it works!! I can't thank you enough!
Tbh I didn't know dial peers were needed because I followed the tutorials that only covered IP phones over a LAN because for some reason I couldn't find any tutorials that had the similar topology design as mine. I thought I should just gave it a try anyways even though it was different. Little did I know dial peers should be configured too
12-15-2020 06:44 AM
Hello,
dial peers are actually only needed when there are routers in betwee the phones. Most tutorials cover phone to phone connectivity on a single LAN, where you don't need dial peers, so it is easy to overlook that.
01-11-2021 11:44 PM - edited 01-11-2021 11:45 PM
Hi, sorry for taking too long to reply. Now I have another problem with my design. When I try pinging to the file server from the wireless devices (Tablet PC and Smartphone) it works just fine I get the reply, but whenever I try the other way around (From file server to both of the wireless devices) all I get is "destination host unreachable". I've been trying to figure it out why and how it doesn't work, tried removing and reconfiguring the wireless router countless times, changing the addresses, using DHCP instead of static, and even tried wired devices, in the end still it just refused to work. I'm really at a loss now, did I really miss something I'm not aware of or is it just the way it is?
01-12-2021 12:31 AM
Hello,
I think it is a restriction in Packet Tracer: wireless routers do not respond to ICMP (ping), and ICMP traffic is one way only.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide