cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1026
Views
0
Helpful
1
Replies

How to prioritize TCP traffic

Hawk
Level 1
Level 1

I have a site with a small 5mb circuit that uses a tcp based app that is constantly dropping packets because its dscp value is 0 best effort.  I tried matching it in the voice class & policy map but when I take captures the values are still 0 best effort unlike the voice which is 46 ef.  Can someone with experience who has done this before tell me how to prioritize this tcp traffic just like with voice?  Here is the config im using below which is surprisingly working for voice but not the tcp app that I need qos for.  

 

class-map match-any P21
match access-group 100
class-map match-any Voice
match dscp ef
match ip precedence 5
match protocol rtp
match protocol sip
!
policy-map CL-VOICE_AND_DATA
class Voice
priority percent 80
set ip precedence 5
class P21
set ip precedence 5
class class-default
fair-queue
random-detect
set ip precedence 0
queue-limit 256 packets
policy-map CL-ETH-SHAPING
class class-default
shape average 5000000
service-policy CL-VOICE_AND_DATA

 

access-list 100 permit tcp 10.222.224.0 0.0.0.255 10.240.0.0 0.0.3.255 eq 4444

 

interface GigabitEthernet0/0/1
description WAN Link
service-policy output CL-ETH-SHAPING

1 Reply 1

Hello,

 

can you post the output of:

 

show policy-map interface GigabitEthernet0/0/1

 

What if you add the line in bold to your access-list:

 

access-list 100 permit tcp 10.222.224.0 0.0.0.255 10.240.0.0 0.0.3.255 eq 4444
access-list 100 permit tcp 10.222.224.0 0.0.0.255 eq 4444 10.240.0.0 0.0.3.255

Review Cisco Networking products for a $25 gift card