cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
880
Views
0
Helpful
3
Replies
Highlighted

hsrp track configuration for Multilink

             I am using HSRP with in R1 and R2, where R1 is active and connected to 5 MPLS serial link and configured as1 Multilink for MPLS and R2 is connected to 4 point to point serial link. My all data should go through MPLS first and when MPLS goes down data shoud go through R2 point to point link.

             Here I want to know that  can I use (In R1 HSRP configuration) Track command standby 20 trackMultilink1 for multilink like we use in single  link

(Ex- standby 1 track serial 0) so if my R1 multilink goes down R2 will become active and data can go through R2  link

-----------------------------------------------------------------Configuration of R1---------------------------------------------------

interface Multilink1

description <  Multilink >

bandwidth 10240

ip address 10.20.128.1 255.255.255.252

ip accounting output-packets

ip flow ingress

ppp multilink

ppp multilink links maximum 5

ppp multilink links minimum 1

ppp multilink group 1

!

!

interface GigabitEthernet0/0

description <<connectivity to core switch>>

ip address 172.25.250.34 255.255.255.240

ip nat inside

no ip virtual-reassembly

duplex full

speed 100

standby 20 ip 172.25.250.33

standby 20 priority 120

standby 20 preempt

interface Serial0/0/0

description < MPLS Link >

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/1/0

description < MPLS Link >

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/1/1

description < MPLS Link >

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/2/0

description < MPLS Link >

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/2/1

description    <MPLS Link>

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

ip route 0.0.0.0 0.0.0.0 10.20.128.2

___________________________Configuration of R2---------------------------------------------------

interface Multilink1

bandwidth 8192

ip address 172.25.1.237 255.255.255.252

ip flow ingress

ppp multilink

ppp multilink group 1

!

!

interface GigabitEthernet0/0

ip address 172.25.250.35 255.255.255.240

shutdown

duplex full

speed 100

standby 20 ip 172.25.250.33

standby 20 priority 110

standby 20 preempt

!

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex full

speed 100

!

!

interface Serial0/0/0

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/1/0

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/2/0

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface Serial0/2/1

bandwidth 2048

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

!

!

interface BRI0/3/0

no ip address

encapsulation hdlc

shutdown

!

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 172.25.1.238

!

3 REPLIES 3
Highlighted
Cisco Employee

Hi Tarun,

Yes. you can configure to track multilink interface

Raju

Highlighted
Beginner

interface GigabitEthernet0/0

description <>

ip address 172.25.250.34 255.255.255.240

ip nat inside

no ip virtual-reassembly

duplex full

speed 100

standby 20 ip 172.25.250.33

standby 20 priority 120

standby 20 preempt

standby 20 track multilink1

will be configured in R1.

Highlighted

I have one comment about your configuration of HSRP. You are setting the priority to 120 and 110. By default track will decrease the priority by 10. So if the multilink goes down the priority will become 110. And with equal priority the standby will not become active. It would be more effective to set the priority to something like 115 and 110 so that when track reduces the priority it becomes lower than the standby.

HTH

Rick

HTH

Rick
Content for Community-Ad