cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1300
Views
0
Helpful
19
Replies

i need to access all routers from my local desktop

R Manjunatha
Level 3
Level 3

Hi,

I am running BGP, OSPF, and EIGRP routing protocol in EVE-NG and I need to access all my routers from my local desktop

what could be the route configuration? I can be able to ping from my desktop R120 and further I can't any other routes.

I have attached my topology. 

R120

interface Loopback1
ip address 172.120.10.1 255.255.255.0
!
interface Loopback2
ip address 172.120.20.1 255.255.255.0
!
interface Loopback3
ip address 172.120.30.1 255.255.255.0
!
interface Loopback4
ip address 172.120.40.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.120.2 255.255.255.0
duplex auto
!
interface Ethernet0/1
ip address dhcp
duplex auto
!
interface Ethernet0/2
no ip address
shutdown
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
!
router eigrp 100
network 10.10.120.0 0.0.0.255
network 172.120.10.0 0.0.0.255
network 172.120.20.0 0.0.0.255
network 172.120.30.0 0.0.0.255
network 172.120.40.0 0.0.0.255
network 192.168.1.0
network 192.168.50.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.50.1
ip ssh version 2

 

R85

interface Loopback1
ip address 192.85.10.1 255.255.255.0
!
interface Loopback2
ip address 192.85.20.1 255.255.255.0
!
interface Loopback3
ip address 192.85.30.1 255.255.255.0
!
interface Loopback4
ip address 192.85.40.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.85.2 255.255.255.0
duplex auto
!
interface Ethernet0/1
ip address 10.10.86.1 255.255.255.0
duplex auto
!
interface Ethernet0/2
ip address 10.10.10.1 255.255.255.0
duplex auto
!
interface Ethernet0/3
ip address 172.16.85.1 255.255.255.0
duplex auto
!
interface Ethernet1/0
ip address 10.10.120.1 255.255.255.0
duplex auto
!
interface Ethernet1/1
no ip address
shutdown
duplex auto
!
interface Ethernet1/2
no ip address
shutdown
duplex auto
!
interface Ethernet1/3
no ip address
shutdown
duplex auto
!
!
router eigrp 100
network 10.10.10.0 0.0.0.255
network 10.10.85.0 0.0.0.255
network 10.10.86.0 0.0.0.255
network 10.10.120.0 0.0.0.255
network 172.16.85.0 0.0.0.255
network 192.85.10.0
network 192.85.20.0
network 192.85.30.0
network 192.85.40.0

my desktop ipconfig

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2406:7400:63:a4e5:5c1c:aa1c:f59d:86e
Temporary IPv6 Address. . . . . . : 2406:7400:63:a4e5:30c6:4b8:c787:2872
Link-local IPv6 Address . . . . . : fe80::5c1c:aa1c:f59d:86e%20
IPv4 Address. . . . . . . . . . . : 192.168.0.108
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::61ca:999c:d76a:a891%3
IPv4 Address. . . . . . . . . . . : 192.168.70.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::b94e:4fbf:d4:36eb%13
IPv4 Address. . . . . . . . . . . : 192.168.50.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Bluetooth Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

C:\Windows\system32>route add 10.10.120.0 mask 255.255.255.0 192.168.50.192

19 Replies 19

Harold Ritter
Level 12
Level 12

Hi @R Manjunatha ,

The following route you configured on your local desktop only allows you to get connectivity with R120:

route add 10.10.120.0 mask 255.255.255.0 192.168.50.192

If all of the addresses you need to get access to in the lab start with prefix 10.10/16 you would need something like this:

route add 10.10.0.0 mask 255.255.0.0 192.168.50.192

Also, can you run the following command on R120:

"show ip eigrp topo | incl 192.168.50"

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thanks

I have not advertised the local interface in the BGP routes. OSPF and EIGRP all the routers are pinging now, so I added two commands to ping the BGP routes as well

route add 10.10.0.0 mask 255.255.0.0 192.168.50.192 --- this is for eigrp and ospf routers directly connected interface advertised

route add 192.0.0.0 mask 255.0.0.0 192.168.50.192 -- this for bgp routes loopback interface advertised.

R60

router bgp 65002
bgp log-neighbor-changes
network 60.60.60.0 mask 255.255.255.0
network 192.60.10.0
network 192.60.20.0
network 192.60.30.0
network 192.60.40.0
neighbor 48.48.48.48 remote-as 65002
neighbor 48.48.48.48 update-source Loopback0
neighbor 52.52.52.52 remote-as 65002
neighbor 52.52.52.52 update-source Loopback0
neighbor 61.61.61.61 remote-as 65002
neighbor 61.61.61.61 update-source Loopback0

Thanks for the update ....

 

Hi

I need one more clarification. I connected the internet cloud in the R120 router, and I am unable to ping DNS server 8.8.8.8 from the R120 router

I would like to access my all routers internet connections .. what will be the best solution.

R120

 R120#sh ip int b
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 10.10.120.2 YES NVRAM up up
Ethernet0/1 192.168.50.192 YES DHCP up up 

R120#sh run | se rou
router eigrp 100
network 10.10.120.0 0.0.0.255
network 172.120.10.0 0.0.0.255
network 172.120.20.0 0.0.0.255
network 172.120.30.0 0.0.0.255
network 172.120.40.0 0.0.0.255
network 192.168.1.0
network 192.168.50.0
ip route 0.0.0.0 0.0.0.0 192.168.50.1

 

Hi @R Manjunatha ,

1- I am not sure why R120 can't reach 8.8.8.8. It probably has something to do with your VMware configuration. Did you configure the interface going towards EVE-NG (VMnet8) as NAT?

2- You would need to redistribute the static default route into eigrp on R120, for the default to propagate through the network. R120 probably needs to nat all traffic coming from the EVE-NG network with the 192.168.50.192 when it goes towards the Internet.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

RManjunatha_0-1663497549849.png

1) Yes, internet going towards EVE-NG VMnet8 as NAT. Anyway, this I will figure out why it's not pinging 

2) clarification which default route I need to use ip route 0.0.0.0 0.0.0.0 10.10.120.1  or ip route 0.0.0.0 0.0.0.0 192.168.50.1 ( this is gateway of VM), after that I need to redistribute int eigrp - redistribute static metric 10000 0 255 1 1500

I figured out why my DNS server is not pining that is because of my default route -IP route 0.0.0.0 0.0.0.0 10.10.120.1

 IP route 0.0.0.0 0.0.0.0 192.168.50.1. After removing this default route, I am able to ping 8.8.8.8 

Hi @R Manjunatha ,

Can you now ping 8.8.8.8 just from R120 to from all routers?

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi @R Manjunatha ,

The only default route you should have on R120 should be the one towards the local host (192.168.50.1).

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

if I add this route (ip route 0.0.0.0 0.0.0.0 192.168.50.1 ) I am unable to ping DNS server from R120

R120(config)#ip route 0.0.0.0 0.0.0.0 192.168.50.1

R120(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R120(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R120(config)#no ip route 0.0.0.0 0.0.0.0 192.168.50.1
R120(config)#do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/10 ms
R120(config)#

Hi @R Manjunatha ,

You probably get the default route from DHCP then. Can you provide a "show ip route 8.8.8.8" and a "show ip route 0.0.0.0 0.0.0.0" from R120? 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

R120#show ip route 0.0.0.0 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "static", distance 254, metric 0, candidate default path
Redistributing via eigrp 100
Advertised by eigrp 100 metric 10000 0 255 1 1500
Routing Descriptor Blocks:
* 192.168.50.2
Route metric is 0, traffic share count is 1

Hi @R Manjunatha ,

Yes, next hop is actually 192.168.50.2, rather than 192.168.50.1 in the VMware context.

You still need to configure NAT on R120 for all of you routers to be able to ping 8.8.8.8. 

int e0/0

ip nat inside

int e0/1

ip nat outside

ip nat inside source list 1 interface e0/1 overload

access-list 1 permit 10.10.0.0 0.0.255.255 

This way, all of you routers will be natted to 192.168.50.192 when going towards to the Internet and will be natted one more time by VMware, which should make it work successfully.

Regards,

 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi

I can Ping all my eigrp routers and rest BGP and ospf unable to access the internet connection.

R120

interface Loopback1
ip address 172.120.10.1 255.255.255.0
!
interface Loopback2
ip address 172.120.20.1 255.255.255.0
!
interface Loopback3
ip address 172.120.30.1 255.255.255.0
!
interface Loopback4
ip address 172.120.40.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.120.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
!
interface Ethernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
!
interface Ethernet0/2
ip address 192.168.30.2 255.255.255.0
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
!
router eigrp 100
network 10.10.120.0 0.0.0.255
network 172.120.10.0 0.0.0.255
network 172.120.20.0 0.0.0.255
network 172.120.30.0 0.0.0.255
network 172.120.40.0 0.0.0.255
network 192.168.50.0
redistribute static metric 10000 0 255 1 1500
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Ethernet0/1 overload
ip route 0.0.0.0 0.0.0.0 192.168.50.2
ip ssh version 2
!
ipv6 ioam timestamp
!
!
access-list 1 permit 10.10.0.0 0.0.255.255

 

r60 - bgp router

R60#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R60#sh ip bgp | se 192.168
*>i 192.168.50.0 61.61.61.61 332800 100 0 ?
R60#sh ip route | se 192.168
B 192.168.50.0/24 [200/332800] via 61.61.61.61, 00:47:56

R63#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R63 - OSPF Router
R63#sh ip route | se 192.168
O E2 192.168.50.0/24 [110/20] via 10.10.63.1, 00:49:52, Ethernet0/1

 

Hi @R Manjunatha ,

Can you please make sure the default route propagation is reaching these routers, by doing a "show ip route 8.8.8.8" on R60 and R63? Can you also do a "show ip nat tr" on R120, while pinging 8.8.8.8 from R60 or R63?

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Review Cisco Networking for a $25 gift card