cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
323
Views
0
Helpful
1
Replies

I try to setup my first QoS...

jquintard
Level 1
Level 1

Hello,

I try to setup my first QoS configuration, but I have a little problem with one part of my configuration.

1. I capture packets for specific services with access list :

! I capture RDP and SSH packets
class-map match-all MarkQoS101
  match access-group 101

access-list 101 permit tcp any any eq 3389
access-list 101 permit tcp any any eq 22

! I capture FTP and FTP data (Active, Passive)
class-map match-all MarkQoS102
  match access-group 102

access-list 102 permit tcp any any eq ftp
access-list 102 permit tcp any any eq ftp-data
access-list 102 permit tcp any any range 40000 42000

2. I classify this packets :

policy-map ClassificationQoS
  class MarkQoS101
    set ip dscp af41
  class MarkQoS102
    set ip dscp af11

3. I apply the policy-map to my LAN interface :

interface GigabitEthernet0/1.101
  service-policy input ClassificationQoS

4. I verify :

#sh policy-map int Gi0/1.101
GigabitEthernet0/1.101

  Service-policy input: ClassificationQoS

    Class-map: MarkQoS101 (match-all)
      5605 packets, 435892 bytes
      5 minute offered rate 7000 bps, drop rate 0 bps
      Match: access-group 101
      QoS Set
        dscp af41
          Packets marked 5605

    Class-map: MarkQoS102 (match-all)
      11175 packets, 715271 bytes
      5 minute offered rate 23000 bps, drop rate 0 bps
      Match: access-group 102
      QoS Set
        dscp af11
          Packets marked 11175

    Class-map: class-default (match-any)
      42430 packets, 9236406 bytes
      5 minute offered rate 194000 bps, drop rate 0 bps
      Match: any

Ok this part work correctly. I have just a little question, what is the best value to use with QoS to mark packets : TOS or DSCP ? It seem DSCP use a bit to add a drop probability but is this a good thing ?

3. I try (this my problem) to regulate the trafic for af41 and af11 :

policy-map RegulationTrafic
  class MatchQoSaf41
    bandwidth percent 5
  class MatchQoSaf11
    bandwidth percent 5
  class class-default
    fair-queue
    random-detect
    random-detect precedence 6   30    40    4

4. I apply this new policy-map to my Dialer (I use an ADSL connection) :

interface Dialer0
  bandwidth 768
  bandwidth receive 3776
  service-policy output RegulationTrafic

My ADSL line have 768Kbps for maximum upload. So with my policy map I must have this regulation :

AF41 (5%)      : 38 Kbps (4 Ko)
AF11 (5%)     : 38 Kbps (4 Ko)

5. I verify :

#sh policy-map int Dialer0
Dialer0

  Service-policy output: RegulationTrafic

    Class-map: MatchQoSaf11 (match-all)
      17033 packets, 1120688 bytes
      5 minute offered rate 18000 bps, drop rate 0 bps
      Match: ip dscp af11 (10)
      Queueing
        Output Queue: Conversation 266
        Bandwidth 5 (%)
        Bandwidth 38 (kbps)Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: MatchQoSaf41 (match-all)
      8454 packets, 635467 bytes
      5 minute offered rate 7000 bps, drop rate 0 bps
      Match: ip dscp af41 (34)
      Queueing
        Output Queue: Conversation 267
        Bandwidth 5 (%)
        Bandwidth 38 (kbps)Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)
      177545 packets, 37955070 bytes
      5 minute offered rate 316000 bps, drop rate 0 bps
      Match: any
      Queueing
        Flow Based Fair Queueing
        Maximum Number of Hashed Queues 256
        (total queued/total drops/no-buffer drops) 0/0/0
         exponential weight: 9

  class    Transmitted      Random drop      Tail drop    Minimum Maximum  Mark
           pkts/bytes       pkts/bytes       pkts/bytes    thresh  thresh  prob
      0  177546/37955132        0/0              0/0           20      40  1/10
      1       0/0               0/0              0/0           22      40  1/10
      2       0/0               0/0              0/0           24      40  1/10
      3       0/0               0/0              0/0           26      40  1/10
      4       0/0               0/0              0/0           28      40  1/10
      5       0/0               0/0              0/0           30      40  1/10
      6       0/0               0/0              0/0           30      40  1/4
      7       0/0               0/0              0/0           34      40  1/10
   rsvp       0/0               0/0              0/0           36      40  1/10

The bandwitdth is ok for af11 and af41 but I try to upload some files, FTP use all the bandwidth, RDP or SSH is allways very low and it's impossible to use a browser.

Where is the problem ?

Jerome

1 Reply 1

meperuma
Level 1
Level 1

Hi,

Can you try with policing on the FTP class? Since it's a FTP traffic , there may be a surge in traffic at the start but it will go down once you start policing , that is tcp sliding window mechanism will kick in and remote FTP server will slow down the traffic

HTH

Sent from Cisco Technical Support iPhone App

Review Cisco Networking for a $25 gift card