cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
897
Views
5
Helpful
4
Replies

iBGP Neighbors over a Frame-Relay WAN

The.Sorrow
Level 1
Level 1

Ive been trying to get a lab scenario to work that i came up with on my own. Not expecting it to be so troublesome of course. I have the topology pictured below:

http://i586.photobucket.com/albums/ss303/The_Sorr0w/Capture.jpg

The only issue is that R2 cant ping R3 and vice-versa. All the routes show up in the BGP table and the routing table but both branch sites are unreachable to eachother. The only working network connectivity is from each spoke to the hub. All three routers are running BGP AS 100. the frame relay network is 63.100.200.0/29 So the frame relay cloud is all one subnet. The topology is a hub-spoke format with R1 having links between itself and the two branch routers. I believe the issue is the single subnet, but i'm not sure. R1 is acting as a route reflector. There is also next-hop-self configured since natively each branch wont know of the other's next hop. Next-hop-self wasnt working for some reason so i configured a route map to acomplish the same task. Here is my configs for each router.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

R1 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

interface Loopback0

ip address 172.31.255.255 255.255.255.255

description BGP Loopback

!

interface Loopback2

ip address 172.31.1.254 255.255.255.0

description LAN Reachability Test Loopback

!

interface Serial0/0

ip address 63.100.200.1 255.255.255.248

encapsulation frame-relay

clock rate 2000000

frame-relay map ip 63.100.200.2 102 broadcast

frame-relay map ip 63.100.200.3 103 broadcast

no frame-relay inverse-arp

!

router bgp 100

no synchronization

bgp log-neighbor-changes

network 172.31.1.0 mask 255.255.255.0

network 172.31.255.255 mask 255.255.255.255

neighbor 172.31.255.253 remote-as 100

neighbor 172.31.255.253 update-source Loopback0

neighbor 172.31.255.253 route-reflector-client

neighbor 172.31.255.253 next-hop-self

neighbor 172.31.255.253 route-map BGP-RR out

neighbor 172.31.255.254 remote-as 100

neighbor 172.31.255.254 update-source Loopback0

neighbor 172.31.255.254 route-reflector-client

neighbor 172.31.255.254 next-hop-self

neighbor 172.31.255.254 route-map BGP-RR out

no auto-summary

!

ip route 172.31.255.253 255.255.255.255 63.100.200.3

ip route 172.31.255.254 255.255.255.255 63.100.200.2

!

access-list 50 permit any

!

route-map BGP-RR permit 10

match ip address 50

set ip next-hop 172.31.255.255

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

R2 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

interface Loopback0

ip address 172.31.255.254 255.255.255.255

description BGP Loopback

!

interface Loopback2

ip address 172.31.2.254 255.255.255.0

description LAN Reachability Test Loopback

!

interface Serial0/0

ip address 63.100.200.2 255.255.255.248

encapsulation frame-relay

clock rate 2000000

frame-relay map ip 63.100.200.1 201 broadcast

no frame-relay inverse-arp

!

router bgp 100

no synchronization

bgp log-neighbor-changes

network 172.31.2.0 mask 255.255.255.0

network 172.31.255.254 mask 255.255.255.255

neighbor 172.31.255.255 remote-as 100

neighbor 172.31.255.255 update-source Loopback0

no auto-summary

!

ip route 172.31.255.255 255.255.255.255 63.100.200.1

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

R3 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

interface Loopback0

ip address 172.31.255.253 255.255.255.255

description BGP Loopback

!

interface Loopback2

ip address 172.31.3.254 255.255.255.0

description LAN Reachability Test Loopback

!

interface Serial0/0

ip address 63.100.200.3 255.255.255.248

encapsulation frame-relay

clock rate 2000000

frame-relay map ip 63.100.200.1 301 broadcast

no frame-relay inverse-arp

!

router bgp 100

no synchronization

bgp log-neighbor-changes

network 172.31.3.0 mask 255.255.255.0

network 172.31.255.253 mask 255.255.255.255

neighbor 172.31.255.255 remote-as 100

neighbor 172.31.255.255 update-source Loopback0

no auto-summary

!

ip route 172.31.255.255 255.255.255.255 63.100.200.1

Thank you in advance

1 Accepted Solution

Accepted Solutions

Dear The Sorrow,

let me say again you have only  two PVCs and there is no direct PVC between R2 and R3.

So Inverse ARP cannot be of help, at the other end of the unique PVC there is the hub router.

To make things working you don't need an additional PVC, but you need to help each spoke router to solve the other spoke IP WAN address. This is made by using an additional frame-relay map statement in each spoke under the interface configuration.

So try the following:

R2

config t

interface serial 0/0

frame-relay map ip 63.100.200.3 201


R3

config t

interface ser0/0

frame-relay map ip 63.100.200.2 301

After you do this you will be able to ping from spoke to spoke and also networks behind each spoke.

You have a small issue in the forwarding plane. That's all

Hope to help

Giuseppe

View solution in original post

4 Replies 4

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello,

you are missing additional frame-relay mappings

on R2

you need to map

63.100.200.3 to the same DLCI used to reach the hub router

on R3

the same you need to map

63.100.200.2 to the same DLCI used to reach the hub

Hope to help

Giuseppe

I'm actually trying to emulate a situation where management won the battle of network connectivity and thus only two PVCs.

Dear The Sorrow,

let me say again you have only  two PVCs and there is no direct PVC between R2 and R3.

So Inverse ARP cannot be of help, at the other end of the unique PVC there is the hub router.

To make things working you don't need an additional PVC, but you need to help each spoke router to solve the other spoke IP WAN address. This is made by using an additional frame-relay map statement in each spoke under the interface configuration.

So try the following:

R2

config t

interface serial 0/0

frame-relay map ip 63.100.200.3 201


R3

config t

interface ser0/0

frame-relay map ip 63.100.200.2 301

After you do this you will be able to ping from spoke to spoke and also networks behind each spoke.

You have a small issue in the forwarding plane. That's all

Hope to help

Giuseppe

Ah i see. The spokes need to know how to get to their respective parther's ip addresses. I figured they would get to there by hopping across the hub router without an issue. Thanks!

Review Cisco Networking for a $25 gift card