cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
171
Views
0
Helpful
3
Replies
Highlighted
Beginner

Im a noob setting up a Cisco 1941

Im having trouble adding my 1941 to our network 

it sitting behind a arris cable modem then runs a switch to server and computers nothing on the inside network can see out but out can see in.  here's my running config

 

Cisco1941>en
Password:
Cisco1941#show config
Using 1933 out of 262136 bytes
!
! Last configuration change at 17:21:31 UTC Tue Sep 10 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco1941
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$2.*********************.
enable password ********
!
no aaa new-model
!
no ipv6 cef
ip source-route
no ip routing
no ip cef
!
!
!
ip dhcp pool Local
!
!
ip host madserver 192.168.1.100
ip host madserver-2 192.168.1.200
ip host madserver-3 192.168.1.150
ip name-server 204.186.80.251
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9 sn FTX141480SW
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
ip address 192.168.1.41 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface Serial0/0/0
no ip address
no ip route-cache
shutdown
no clock rate 2000000
!
interface Vlan1
no ip address
no ip route-cache
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server view-group word
ip dns server
ip nat inside source list 101 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
access-list 101 permit ip 192.168.0.0 0.0.1.255 any
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
!
snmp-server community public RO
!
control-plane

3 REPLIES 3
Beginner

Re: Im a noob setting up a Cisco 1941

begin leaving no ip routing
Advocate

Re: Im a noob setting up a Cisco 1941

Hi @Rybread ,

 

Queries:
What addressing range does the arris give you?
Do your internal devices use static or  DHCP addresses?

 

In the meantime, try this:

-Change the address of your internal network:

 

interface GigabitEthernet0/1
ip address 172.16.1.41 255.255.255.0

 

ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

access-list 1 permit ip 172.16.1.0 0.0.0.255 

Obviously, your end devices should also adapt to the new address.

 

Regards

Hall of Fame Master

Re: Im a noob setting up a Cisco 1941

I believe that there are several issues in this config.

- certainly the first and most important is the no ip routing command. You should enable ip routing.

- another issue is in your static default route which points only to the outbound interface and has no next hop information

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

this might work - but it might not work (depends entirely on whether the upstream router has enabled proxy arp).

Even if it does work it is not a good idea. When the outbound interface is Ethernet than a static route specifying outbound interface without next hop will force the router to arp for every destination it is trying to forward to.

I would suggest that a better static default route would be like this

ip route 0.0.0.0 0.0.0.0 dhcp

- you mention that server and computers connect through the switch associated with the router. Do these devices receive an IP address? Your config has a name for a DHCP pool. But no pool is configured.

- also if the server and computers are connected through the switch it looks like they are all in vlan 1. But vlan 1 has no ip address. How would these devices communicate?

- I do agree with the suggestion that you make some changes in address translation. (I do not see the benefit from changing the IP addressing to 172.16). You are using an extended access list to identify the traffic to translate and I see no need, no benefit is using an extended access list when a standard access list would do just as well.

- you specify address translation for 192.168.0.0 and 192.168.1.0. But those networks do not show up anywhere else in your config. Where are they?

- you do have 192.168.4.0 in your config but do not have address translation for it. Is that on purpose?

- you specify no ip cef. Why is this? I am not sure that it is a problem. But in general routers like the 1941 operate much better when cef is enabled.

 

HTH

 

Rick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards