06-15-2017 05:36 AM - edited 03-05-2019 08:42 AM
We use C3850 Switches without a router. These switches have an ip on every interface vlan right now and act as a default gateway for all networks. Example of current configuration:
interface vlan 5
description management
ip address 10.0.5.1 255.255.255.0
exit
interface vlan 10
description data1
ip address 10.0.10.1 255.255.255.0
exit
interface vlan 20
description data2
ip address 10.0.20.1 255.255.255.0
exit
interface gigabitethernet1/0/1
description server1
switchport mode access
switchport access vlan 10
exit
interface gigabitethernet1/0/2
description server2
switchport mode access
switchport access vlan 20
exit
Switch has ip routing activated, so traffic between server1 and server2 can traverse the switch. We d'like to add a router to the network and let him be default gateway (redundant with HSRP) for all the clients. Therefore we want to deconfigure all IPs on the 3850 switch leaving him with only a management IP. Excample configuration looking like this:
interface vlan 5
description management
ip address 10.0.5.1 255.255.255.0
exit
interface gigabitethernet1/0/1
description server1
switchport mode access
switchport access vlan 10
exit
interface gigabitethernet1/0/2
description server2
switchport mode access
switchport access vlan 20
exit
interface gigabitethernet1/0/3
description uplink to router
switchport mode trunk
exit
Can data from server1 (connected to gi1/0/1) still be transferred to server2 (connected to gi1/0/2) without traversing the trunk interface to the router? There are no IPs for the corresponding VLANs configured on the switch. The ip routing command is still active though.
Unfortunnately we have lots of vlans. If inter vlan routing wont work after we introduced a router, the interface(s) to the router will be under extremely heavy load.
Thanks for your time having a look into this situation.
Solved! Go to Solution.
06-15-2017 06:29 AM
Traffic between vlans would have to go via the router in your proposed setup.
With the information you have provided I cannot see the point in doing this as you are creating a bottleneck with the router.
And L3 switches are better suited in terms of performance to do the routing between vlans.
Jon
06-15-2017 06:29 AM
Traffic between vlans would have to go via the router in your proposed setup.
With the information you have provided I cannot see the point in doing this as you are creating a bottleneck with the router.
And L3 switches are better suited in terms of performance to do the routing between vlans.
Jon
06-15-2017 07:10 AM
Hi Jon
Thanks for your answer. So would you recommend leaving the switches as the default gateway for the clients and configuring the router as a gateway of last resort on the switches via a transfer network?
Regards,
Mario
06-15-2017 07:13 AM
If you have servers connected to the switches yes I would because L3 switches have much greater throughput capacity than the equivalent router.
And then as you say just have a default route pointing to the router and obviously the router will need to know about the IP subnets on the switch(es).
It's not clear though what you meant by HSRP etc. and how using routers would increase redundancy so if you want to discuss further can you provide some more details on what you were thinking of doing ?
Jon
06-16-2017 12:21 AM
Ok, thats what i wanted to know, thank you.
About HSRP i just meant that i would form a HSRP standby group with two routers where the virtual IP is then the destination for the default route on the switches.
Thanks for th quick response
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide