cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
448
Views
0
Helpful
5
Replies
Highlighted

IOS-XE - NAT 'tcp load balancing' (using "ip nat inside destination list pool") is not supported?

trying to configure this on an Azure CSR instance running ios-xe 16.10.1b, and it acts weird:

it accepts "ip nat inside destination list <number>", but there's no "pool" option after it:

(config)#ip nat inside destination list 50 ?
redundancy NAT redundancy operation
<cr> <cr>

 

trying to configure a typical NAT 'load balance' scenario, as per the example below:

interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface Serial0
ip address 207.35.14.82 255.255.255.252
ip nat outside
!
ip nat pool V-Server 192.168.1.2 192.168.1.4 prefix-length 24 type rotary
ip nat inside destination list 1 pool V-Server
!
ip route 0.0.0.0 0.0.0.0 Serial0
!    
access-list 1 permit 199.198.5.1
!

5 REPLIES 5
Highlighted
VIP Mentor

Hello,

 

I am using Cisco IOS XE Software, Version 03.17.00.S, and the command is available. Which version is the AWS router running ?

Highlighted

This is Cisco CSR in Azure running:

Cisco IOS XE Software, Version 16.10.01b
Cisco IOS Software [Gibraltar], Virtual XE Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.10.1b, RELEASE SOFTWARE (fc1)

Highlighted

Hello,

 

I am running the AX (Application Experience) feature set, maybe that is the problem...which one are you running (sh lic) ?

Highlighted

the AX is what I'm running as well. Opened support case, and the engineer is contacting developers...
Highlighted

Hello,

 

maybe AWS, for some reason, has disabled that command ? Always worth checking maybe...