cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1770
Views
0
Helpful
2
Replies

IP DHCP Helper Address

gil.juguilon
Level 1
Level 1

Hi,

I would like to ask for some solutions about the problem that I am havving right now.

My aim was to remove the DCHP Pool on the router and add the IP helper address to get their IP address from a remote DHCP server.

After removing and adding some configurations. Some of the PC's could not get their IP address. But come of the PC's managed to have an address.

== Original Configuration ==

R01#

!

version 12.3

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname R01

!

!

!

!

!

!

ip dhcp excluded-address 192.168.2.120 192.168.2.126

!

!

!

!

!        

interface FastEthernet0/0

description Connection to LAN

ip address 192.168.9.254 255.255.255.0 secondary

ip address 192.168.2.126 255.255.255.192

ip accounting output-packets

speed 100

full-duplex

no cdp enable

!

!

ip classless

!

ip dhcp excluded-address 192.168.2.120 192.168.2.126   ======remove

ip dhcp excluded-address 192.168.9.151 192.168.9.254

ip dhcp excluded-address 192.168.9.152 192.168.9.254

ip dhcp excluded-address 192.168.9.153 192.168.9.254

ip dhcp excluded-address 192.168.9.154 192.168.9.254

ip dhcp excluded-address 192.168.9.155 192.168.9.254

ip dhcp excluded-address 192.168.9.156 192.168.9.254

ip dhcp excluded-address 192.168.9.157 192.168.9.254

ip dhcp excluded-address 192.168.9.158 192.168.9.254

ip dhcp excluded-address 192.168.9.159 192.168.9.254

ip dhcp excluded-address 192.168.9.192 192.168.9.254

ip dhcp excluded-address 192.168.9.193 192.168.9.254

ip dhcp excluded-address 192.168.9.194 192.168.9.254

ip dhcp excluded-address 192.168.9.195 192.168.9.254

!

ip dhcp pool USERS1                                                       ======remove

   network 192.168.2.64 255.255.255.192

   dns-server 192.168.32.162 192.168.16.163 192.168.1.201

   default-router 192.168.2.126

!

ip dhcp pool USERS2                                                       ======remove

   network 192.168.9.0 255.255.255.0

   dns-server 192.168.32.162 192.168.16.163 192.168.1.201

   default-router 192.168.9.254

!

== New Configuration ==

R01#

!

version 12.3

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname R01

!

!

!

!

!

!

ip dhcp excluded-address 192.168.2.120 192.168.2.126

!

!

!

!

!        

interface FastEthernet0/0

description Connection to LAN

ip address 192.168.9.254 255.255.255.0 secondary

ip address 192.168.2.126 255.255.255.192

ip helper-address 192.168.1.201   ==============added

ip helper-address 192.168.1.202   ==============added

ip accounting output-packets

speed 100

full-duplex

no cdp enable

!

!

ip classless

Hoping for your pieces of advise.
Thanks in advance.
Gil

2 Replies 2

martin ofner
Level 1
Level 1

hello!

i think the problem is the secondary ip address. Whenever a router sources an IP packet, it will always come from the primary IP address on the interface.

So if the PC gateway is the secondary IP you have a Problem

Martin

if you want to forward DHCP packets with giaddr set to secondary ip of an interface use

"ip dhcp smart-relay" in global config mode along with  "ip dhcp helper-address"