cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3084
Views
0
Helpful
2
Replies

IP DHCP Helper: Cannot ping default Gateway

nwekechampion
Level 3
Level 3

Hi all,

 

I was just checking a dhcp ip helper address concept.

 

I have a router as dhcp server from another network (through WAN), it give s dhcp thorugh an ip heper address configuration on LAN succesfully.

 

However problem is I cannot ping default gateway from LAN. Is this how it meant to work, or do I have possible routing issue?

 

Diagram and configs attached.

 

R1==> DHCp Server

C2==> Ip helper L3 cissco switch

A2 ==> Access layer Switch

 

++++++++++++++++++++++++++++++++++++++++++++++++

R1

Building configuration...

Current configuration : 3283 bytes
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
ip dhcp excluded-address 192.168.50.1 192.168.50.100
!
ip dhcp pool VLAN 50
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.96.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
!
router eigrp 123
network 192.168.96.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
!
!
control-plane
!

line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
transport input none
!
no scheduler allocate
!
end

 

+++++++++++++++++++++++++++++++++

C2

Building configuration...

Current configuration : 4369 bytes
!
! Last configuration change at 01:42:17 UTC Mon Aug 10 2020
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname C2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
no switchport
ip address 192.168.12.2 255.255.255.252
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet0/0
no switchport
no ip address
shutdown
negotiation auto
channel-group 1 mode passive
!
interface GigabitEthernet0/1
no switchport
no ip address
shutdown
negotiation auto
channel-group 1 mode passive
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
media-type rj45
negotiation auto
channel-protocol pagp
channel-group 2 mode desirable
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
media-type rj45
negotiation auto
channel-protocol pagp
channel-group 2 mode desirable
!
interface GigabitEthernet1/0
no switchport
ip address 192.168.96.2 255.255.255.0
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
switchport mode access
media-type rj45
negotiation auto
!
interface GigabitEthernet1/3
media-type rj45
negotiation auto
!
interface GigabitEthernet2/0
media-type rj45
negotiation auto
!
interface GigabitEthernet2/1
media-type rj45
negotiation auto
!
interface GigabitEthernet2/2
media-type rj45
negotiation auto
!
interface GigabitEthernet2/3
media-type rj45
negotiation auto
!
interface GigabitEthernet3/0
media-type rj45
negotiation auto
!
interface GigabitEthernet3/1
media-type rj45
negotiation auto
!
interface GigabitEthernet3/2
media-type rj45
negotiation auto
!
interface GigabitEthernet3/3
media-type rj45
negotiation auto
!
interface Vlan50
ip address 192.168.50.2 255.255.255.0
ip helper-address 192.168.96.1
!
!
router eigrp 123
network 192.168.50.0
network 192.168.96.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet1/0
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end

 

++++++++++++++++++++++++++++++++++++++++++

A2

Building configuration...

Current configuration : 3897 bytes
!
! Last configuration change at 01:42:15 UTC Mon Aug 10 2020
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname A1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/2
switchport mode access
media-type rj45
negotiation auto
spanning-tree bpduguard enable
!
interface GigabitEthernet0/3
switchport access vlan 50
switchport mode access
switchport port-security maximum 2
switchport port-security violation restrict
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
media-type rj45
negotiation auto
!
interface GigabitEthernet1/3
media-type rj45
negotiation auto
!
interface GigabitEthernet2/0
media-type rj45
negotiation auto
!
interface GigabitEthernet2/1
media-type rj45
negotiation auto
!
interface GigabitEthernet2/2
media-type rj45
negotiation auto
!
interface GigabitEthernet2/3
media-type rj45
negotiation auto
!
interface GigabitEthernet3/0
media-type rj45
negotiation auto
!
interface GigabitEthernet3/1
media-type rj45
negotiation auto
!
interface GigabitEthernet3/2
media-type rj45
negotiation auto
!
interface GigabitEthernet3/3
media-type rj45
negotiation auto
!
interface Vlan50
ip address 192.168.50.3 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!

!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end

 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

Would really appreciate any help

 

Regards

 

 

 

 

1 Accepted Solution

Accepted Solutions

Hello,

 

on the router, your DHCP pool is configured with a default router IP address that doesn't exist on the layer 3 switch:

 

ip dhcp pool VLAN 50
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1

 

interface Vlan50
ip address 192.168.50.2 255.255.255.0
ip helper-address 192.168.96.1

 

Change the IP address of interface Vlan50 to 192.168.50.1 so they both match...

View solution in original post

2 Replies 2

Hello,

 

on the router, your DHCP pool is configured with a default router IP address that doesn't exist on the layer 3 switch:

 

ip dhcp pool VLAN 50
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1

 

interface Vlan50
ip address 192.168.50.2 255.255.255.0
ip helper-address 192.168.96.1

 

Change the IP address of interface Vlan50 to 192.168.50.1 so they both match...

Many many thanks George..

That worked..

 

Thanks again