cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2197
Views
0
Helpful
10
Replies

IP SLA with 2 ISP's

Faisal Khan
Level 1
Level 1

I hv connected 2 ISP with my edge router (ISP1 & ISP2) and also set IP SLA with ISP1. If ISP1 is down or drop 3 packets my connectivity moves to ISP 2 and it works fine.

but i want to apply same things on ISP2

my default gateway primery ISP (ISP1);

can anybody provide a solution.

10 Replies 10

Sandeep Choudhary
VIP Alumni
VIP Alumni

Hi Faisal,

se this example:

            ------------- ISP1 -------------
             |                                |
             |                                |
LAN -- WAN router                          Internet
             |                                |
             |                                |
              ------------- ISP2 -------------

Configuration

interface FastEthernet0/0

Description Primary link ISP1

ip address 12.x.x.x 255.255.255.240

ip nat outside


interface FastEthernet1/0

Description Secondary link ISP2

ip address 76.x.x.x. 255.255.255.0

ip nat outside


interface FastEthernet1/1

Description Inside LAN segment

ip address 172.168.60.1 255.255.255.0

ip nat inside


access-list 100 permit ip 172.168.60.0 0.0.0.255 any


route-map isp1 permit 10

match ip address 100

match interface FastEthernet0/0


route-map isp2 permit 10

match ip address 100

match interface FastEthernet1/0


ip nat inside source route-map isp1 interface FastEthernet0/0 overload

ip nat inside source route-map isp2 interface FastEthernet1/0 overload


ip route 0.0.0.0 0.0.0.0 12.y.y.y   -----> Primary Default route pointing towards Next hop ip of ISP1

ip route 0.0.0.0 0.0.0.0 76.y.y.y 10  -----> Backup Default route with higher AD (10) pointing towards Next hop ip of ISP2


route-map isp1static permit 10

match interface FastEthernet0/0


route-map isp2static permit 10

match interface FastEthernet1/0


ip nat inside source static 172.168.60.2 12.x.x.x route-map isp1static

ip nat inside source static 172.168.60.2 76.x.x.x route-map isp2static

is this you nedd to know or  ???

Hope it helps!

or follow this links for edge router:

https://supportforums.cisco.com/docs/DOC-8313

Regards

Please rate if it helps.

Thanks for replay;

One more thing...i allowed specific IP's for using ISP1 and other is using ISP2 for load balancing.

your mentioned configuration is applied for both...if ISP2 is down all traffic will routed to ISP1 and vice versa (if ISP1 is down all traffic will routed to ISP2).

I did not understand your question:

did you want to say that specific  trafiic is allowed with a ISP  ????

Regards

is there any method to divert traffic to another ISP if one ISP is down... and this rule is apply for both Links. 

Hi,

Post your existing config.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

There is no load balancing with this setting, this is Primary or Backup routing.

I am in same boat. I cannot use ISP2 untill ISP1 route is down.

I cannot even ping out the ISP2 interface if ISP1 route is up! 

If load balancing is available on Cisco 2951 or 2921 I would like to know about it.

thanks for ur replay....

what about your VPN users if ISP1 is down.VPN users dailing a public IP of ISP1.

VPN user is SOL

If ISP1 (25 down 2 up) is down, then they hardly want ISP2 (6 down .75 up)

I have reprogramed VPN in long outages.

Hi,

there is no load-balancing but only per src-dst load-sharing accomplished by CEF switching.

So some traffic will use one link and other will use another, just using 2 static routes of equal AD( default is 1).

if you want to send specific traffic out one link and other traffic down the other you will need to use PBR.

You could also use Pfr/OER if you wanted the router to dynamically choose the best outgoing link according to delay, jitter, ip sla probes,...

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

hi,

first i define our scenerio

LAN ------ Firewall--------- router 2 ---- isp 1 & isp 2

LAN connects to router 2 directly, however in my scenario we connect to  router 1   where we have a nat command  for traffic exiting from router  1 to router 2 which is controlled by an ACL to choose selected ip  addresses which are allowed to be natted .

when user connected through VPN with public IP 202.Xx.XX.150(ISP1) it connects, router 2 fwd is to FW.

Now i m confused there... if ISP 1 is down how user dails VPN.     

Review Cisco Networking for a $25 gift card