I have an 871w device connected to a cable modem. It is receiving an ipv4 address and I am NAT'ing easily enough behind it. Recently I decided I wanted to try to work with Comcast's native ipv6, but I'm running into problems with my home devices on the inside vlan and routing. To summarize the problem...
I can ping some external prefixes but not all. For example, I can ping OpenDNS 2620:0:ccc::2, but I can't ping Google DNS 2001:4860:4860::8888. I also have an external linode I spun up, which can ping both of those ipv6 addresses, but can't ping my home network (and vice versa). I feel like this is a routing issue, but it could also be a configuration issue. Here is my basic config related to the ipv6 stack:
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool COMCAST_IPV6
prefix-delegation pool comcast-ipv6 lifetime 1800 60
dns-server 2001:558:FEED::1
dns-server 2001:558:FEED::2
domain-name home.local
interface FastEthernet4
description WAN/OUTSIDE
ip address dhcp
ip access-group WAN_INBOUND in
no ip redirects
no ip unreachables
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd comcast-ipv6 rapid-commit
interface Vlan20
description INSIDE
ip address 10.100.100.1 255.255.255.248
ip nat inside
ip virtual-reassembly
ipv6 address comcast-ipv6 ::1:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server COMCAST_IPV6
It's pretty simple... my desktop Windows box on vlan 20 can ping out with ipv4 easy, and to some ipv6. Here's a traceroute to OpenDNS:
C:\Windows\system32>tracert -6 2620:0:ccc::2
Tracing route to 2620:0:ccc::2 over a maximum of 30 hops
1 2 ms <1 ms 1 ms 2601:8:af00:47:1::1
2 10 ms 11 ms 11 ms 2001:558:4082:5e::1
3 14 ms 11 ms 11 ms te-0-2-0-7-ur08.seattle.wa.seattle.comcast.net [
2001:558:a2:114::1]
4 12 ms 11 ms 11 ms ae-20-0-ar03.seattle.wa.seattle.comcast.net [200
1:558:a0:212::1]
5 18 ms 14 ms 13 ms he-1-3-0-0-10-cr01.seattle.wa.ibone.comcast.net
[2001:558:0:f769::1]
6 12 ms 12 ms 11 ms he-0-10-0-1-pe04.seattle.wa.ibone.comcast.net [2
001:558:0:f54f::2]
7 16 ms 12 ms 12 ms ae-19.r04.sttlwa01.us.bb.gin.ntt.net [2001:418:0
:2000::5d]
8 14 ms 12 ms 11 ms xe-0-0-0-34.r04.sttlwa01.us.ce.gin.ntt.net [2001
:418:c00:5000::52]
9 11 ms 11 ms 12 ms 2620:0:ccc::2
But to Google IPv6 DNS, I get nothing, it dies on the first hop. I can ping a few other websites, such as paulbanks.org, ccc.de, etc (sites on https://www.sixxs.net/wiki/IPv6_Enabled_Websites). ; My results from the ipv6 test sites commonly available indicate I'm 100% ready, but I time out visiting multiple sites.
Is it me, or is it my provider? I get mostly request time outs, sometimes icmp unreachables back.
Throwing packets since 2012