cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
2938
Views
5
Helpful
26
Replies

IR829 WAN + Dual SIM configuration help

magnus42
Level 1
Level 1

Hi!

I've got an IR829-2LTE-EA-EK9 that I have an intention of setting up as following if possible.

Primary: WAN - Connected to a router providing IP over DHCP.

Secondary: Cellular 0 - Primary LTE.

Secondary 2: Cellular 1 - Secondary LTE.

I've been trying to set it up as to have a failover to the Cellular 0/0 interface when the WAN connection is down (as fast as possible),  and also switch to Cellular 1/0 if the Cellular 0/0 has a low signal. There is no need to switch back to the primary interfaces if they become available again, unless the current one goes down/has a low signal. 

 

Attached is my current configuration. I've got network when I'm connected to WAN, but when I unplug the cable I'm not getting any network on my computer anymore. I can ping from the console, so I suspect that there is some issue with my routing that I'm not seeing.

 

I've been searching a lot, so the config might be a compilation of different threads I've found in the community.

Thanks for any help!


version 15.7(3)M2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
!
hostname ir829
!
boot-start-marker
boot-end-marker
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 11
!
no ignition enable

!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool VLAN1
network 10.0.0.0 255.255.255.0
dns-server 1.1.1.1
default-router 10.0.0.1
!
no ip domain lookup
ip cef
no ipv6 cef

!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
license udi pid IR829-2LTE-EA-EK9
!
redundancy
notification-timer 120000

!
controller Cellular 0
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description LTE_PRIMARY
!
controller Cellular 1
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description LTE_SECONDARY
!
track 1 ip sla 1 reachability
!
interface GigabitEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
shutdown
!
interface GigabitEthernet3
no ip address
shutdown
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 2
no peer default ip address
async mode interactive
routing dynamic
!
interface Cellular1/0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 2
dialer-group 3
no peer default ip address
async mode interactive
routing dynamic
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
shutdown
!
interface Vlan1
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
interface Dialer1
ip address negotiated
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 2
!
interface Dialer2
ip address negotiated
encapsulation slip
dialer pool 2
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 3
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip nat inside source route-map WAN interface GigabitEthernet0 overload
ip nat inside source route-map LTE_SECONDARY interface Dialer2 overload
ip nat inside source route-map LTE_PRIMARY interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 10
ip route 0.0.0.0 0.0.0.0 Dialer2 20
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp
!
ip access-list extended nat-list
permit ip object-group local_lan_subnets any
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0
frequency 5
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
ipv6 ioam timestamp
!
route-map LTE_SECONDARY permit 10
match ip address 1
match interface Dialer2
!
route-map WAN permit 10
match ip address 1
match interface GigabitEthernet0
!
route-map LTE_PRIMARY permit 10
match ip address 1
match interface Dialer1
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
control-plane
!
vstack
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 9
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 15
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password 7
login
transport input none
!

26 Replies 26

Hello,

 

I think the config below should work (important parts marked in bold). You basically have two IP SLAs, three static routes, and a boolean tracker.

 

version 15.7(3)M2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
!
hostname ir829
!
boot-start-marker
boot-end-marker
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 11
!
no ignition enable
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool VLAN1
network 10.0.0.0 255.255.255.0
dns-server 1.1.1.1
default-router 10.0.0.1
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
license udi pid IR829-2LTE-EA-EK9
!
redundancy
notification-timer 120000
!
track 1 ip sla 1 reachability
!
track 2 ip sla 2 reachability
!
track 3 list boolean or
object 1
object 2
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description LTE_PRIMARY
!
controller Cellular 1
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description LTE_SECONDARY
!
interface GigabitEthernet0
description Primary ISP
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
shutdown
!
interface GigabitEthernet3
no ip address
shutdown
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0
description Primary LTE
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 2
no peer default ip address
async mode interactive
routing dynamic
!
interface Cellular1/0
description Secondary LTE
ip address negotiated
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 2
dialer-group 3
no peer default ip address
async mode interactive
routing dynamic
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
shutdown
!
interface Vlan1
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
interface Dialer1
description Primary LTE
ip address negotiated
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 2
!
interface Dialer2
description Secondary LTE
ip address negotiated
encapsulation slip
dialer pool 2
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 3
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip nat inside source route-map WAN interface GigabitEthernet0 overload
ip nat inside source route-map LTE_SECONDARY interface Dialer2 overload
ip nat inside source route-map LTE_PRIMARY interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
ip route 0.0.0.0 0.0.0.0 Dialer2 20
!
ip access-list extended nat-list
permit ip object-group local_lan_subnets any
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0
threshold 1000
frequency 3
!
ip sla 2
icmp-echo 8.8.8.8 source-interface Dialer 1
threshold 1000
frequency 3
!
ip sla schedule 1 life forever start-time now
ip sla schedule 1 life forever start-time now
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
ipv6 ioam timestamp
!
route-map LTE_SECONDARY permit 10
match ip address 1
match interface Dialer2
!
route-map WAN permit 10
match ip address 1
match interface GigabitEthernet0
!
route-map LTE_PRIMARY permit 10
match ip address 1
match interface Dialer1
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
event manager applet CLEAR_NAT
event track 3 state any
action 1.0 cli command ā€œenableā€
action 2.0 cli command ā€œclear ip nat translation *ā€
action 3.0 cli command "end"

!
control-plane
!
vstack
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 9
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 15
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password 7
login
transport input none
!

*double post*

Thank you for your reply!

I've tried to incorporate your advice into the config file, but I cant get it to work properly. I've tried a lot of things for a few hours. I found for instance that "ip nat outside" was missing in the Dialer configuration, so I wouldn't get any network on the client. 

I could not get the following command to be accepted:

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp track 1 

"track" is not a valid command following "dhcp". 

I also guess that this had a typo and the second line should be 2, not 1.
ip sla schedule 1 life forever start-time now
ip sla schedule 1 life forever start-time now

 

Both cellular interfaces are online, with IP's and showing as ACTIVE on data-profile. 


ir829#show ip int brief (IPs on dialers changed)
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0 192.168.1.6 YES DHCP up up
GigabitEthernet1 unassigned YES unset up up
Cellular0/0 unassigned YES NVRAM up up
Cellular1/0 unassigned YES NVRAM up up
Cellular0/1 unassigned YES NVRAM down down
Cellular1/1 unassigned YES NVRAM down down
Dialer1 100.90.90.184 YES IPCP up up
Dialer2 80.90.131.159 YES IPCP up up
NVI0 127.1.3.2 YES unset up up
Vlan1 10.0.0.1 YES NVRAM up up

 

#show ip route when WAN is connected. (I've changed the IPs on dialers)

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 192.168.1.1, GigabitEthernet0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, Vlan1
L 10.0.0.1/32 is directly connected, Vlan1
80.0.0.0/32 is subnetted, 1 subnets
C 80.90.131.159 is directly connected, Dialer2
100.0.0.0/32 is subnetted, 1 subnets
C 100.90.90.184 is directly connected, Dialer1
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0
L 192.168.1.6/32 is directly connected, GigabitEthernet0

 

When I disconnect WAN 

S* 0.0.0.0/0 is directly connected, Dialer2
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, Vlan1
L 10.0.0.1/32 is directly connected, Vlan1
80.0.0.0/32 is subnetted, 1 subnets
C 80.90.131.159 is directly connected, Dialer2
100.0.0.0/32 is subnetted, 1 subnets
C 100.90.90.184 is directly connected, Dialer1

 

When I disconnect the WAN cable it switches to Dialer2 (and not Dialer1) within a few seconds and the following is shown in console.

Jul 7 :42:50.542: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed state to down
Jul 7 :42:56.042: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed state to down
Jul 7 :42:56.802: %TRACK-6-STATE: 1 ip sla 1 reachability Up -> Down
Jul 7 :42:56.802: %TRACK-6-STATE: 3 list boolean or Up -> Down
Jul 7 :43:01.802: %TRACK-6-STATE: 1 ip sla 1 reachability Down -> Up
Jul 7 :43:01.802: %TRACK-6-STATE: 3 list boolean or Down -> Up

 

The new routing table: (IPs changed)

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, Dialer2
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, Vlan1
L 10.0.0.1/32 is directly connected, Vlan1
100.0.0.0/32 is subnetted, 1 subnets
C 100.90.45.145 is directly connected, Dialer1
109.0.0.0/32 is subnetted, 1 subnets
C 109.90.140.123 is directly connected, Dialer2

 

I don't know why it doesn't use Dialer 1?

I tried to disconnect the antenna for Dialer2 (Cellular 1 (1/0)) but it will not switch to Dialer1 when the network goes down. 

When I connect WAN again, it switches over but the "clear ip nat translation *" commands does not seem to work as I don't get any connection until i issue the command manually. 

 

Any further help is highly appreciated!

 

 

version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
!
hostname ir829
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 11
!
no ignition enable
!
!
!
!
!
!
!
!
!
!
!
!
!


!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool VLAN1
network 10.0.0.0 255.255.255.0
dns-server 1.1.1.1
default-router 10.0.0.1
!
!
!
no ip domain lookup
ip inspect WAAS flush-timeout 10
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
!
license udi pid IR829-2LTE-EA-EK9
!
!
!
redundancy
notification-timer 120000

!
!
!
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery disable
description LTE_PRIMARY
!
controller Cellular 1
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery disable
description LTE_SECONDARY
!
track 1 ip sla 1 reachability
!
track 2 ip sla 2 reachability
!
track 3 list boolean or
object 1
object 2
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
description Primary ISP
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
shutdown
!
interface GigabitEthernet3
no ip address
shutdown
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0
description Primary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
no peer default ip address
ipv6 address autoconfig
async mode interactive
routing dynamic
!
interface Cellular1/0
description Secondary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 2
dialer-group 2
no peer default ip address
ipv6 address autoconfig
async mode interactive
routing dynamic
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
interface Dialer1
description Primary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 1
!
interface Dialer2
description Secondary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 2
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 2
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source route-map LTE_PRIMARY interface Dialer1 overload
ip nat inside source route-map LTE_SECONDARY interface Dialer2 overload
ip nat inside source route-map WAN interface GigabitEthernet0 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
ip route 0.0.0.0 0.0.0.0 Dialer2 20
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp
!
ip access-list extended nat-list
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0
threshold 1000
frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 8.8.8.8 source-interface Dialer1
threshold 1000
frequency 5
ip sla schedule 2 life forever start-time now
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
dialer-list 2 protocol ip permit
ipv6 ioam timestamp
!
route-map LTE_PRIMARY permit 10
match ip address 1
match interface Dialer1
!
route-map WAN permit 10
match ip address 1
match interface GigabitEthernet0
!
route-map LTE_SECONDARY permit 10
match ip address 1
match interface Dialer2
!
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
control-plane
!
!
!
vstack
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 9
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 15
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
login
transport input none
!
no scheduler max-task-time
ntp server 34.202.215.187
no iox hdm-enable
iox client enable interface GigabitEthernet5
no iox recovery-enable
!
!
!
!
!
!
event manager applet CLEAR_NAT
event track 3 state any
action 1.0 cli command "enable"
action 2.0 cli command "clear ip nat translation *"
action 3.0 cli command "end"
!
end

Hello,

 

the tracking on the static routes needs to be as below (marked in bold). Also, I would use the Google DNS servers in your DHCP pool.

 

version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
!
hostname ir829
!
boot-start-marker
boot-end-marker
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 11
!
no ignition enable
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool VLAN1
network 10.0.0.0 255.255.255.0
--> dns-server 8.8.8.8 8.8.4.4
default-router 10.0.0.1
!
no ip domain lookup
ip inspect WAAS flush-timeout 10
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
license udi pid IR829-2LTE-EA-EK9
!
redundancy
notification-timer 120000
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery disable
description LTE_PRIMARY
!
controller Cellular 1
lte sim data-profile 1 attach-profile 1
no lte gps enable
lte modem link-recovery disable
description LTE_SECONDARY
!
track 1 ip sla 1 reachability
!
track 2 ip sla 2 reachability
!
track 3 list boolean or
object 1
object 2
!
interface GigabitEthernet0
description Primary ISP
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
shutdown
!
interface GigabitEthernet3
no ip address
shutdown
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0
description Primary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
no peer default ip address
ipv6 address autoconfig
async mode interactive
routing dynamic
!
interface Cellular1/0
description Secondary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 2
dialer-group 2
no peer default ip address
ipv6 address autoconfig
async mode interactive
routing dynamic
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
interface Dialer1
description Primary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 1
!
interface Dialer2
description Secondary LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 2
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 2
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source route-map LTE_PRIMARY interface Dialer1 overload
ip nat inside source route-map LTE_SECONDARY interface Dialer2 overload
ip nat inside source route-map WAN interface GigabitEthernet0 overload
--> ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
--> ip route 0.0.0.0 0.0.0.0 Dialer2 20
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1
!
--> no ip access-list extended nat-list
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0
threshold 1000
frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 8.8.8.8 source-interface Dialer1
threshold 1000
frequency 5
ip sla schedule 2 life forever start-time now
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
dialer-list 2 protocol ip permit
ipv6 ioam timestamp
!
route-map LTE_PRIMARY permit 10
match ip address 1
match interface Dialer1
!
route-map WAN permit 10
match ip address 1
match interface GigabitEthernet0
!
route-map LTE_SECONDARY permit 10
match ip address 1
match interface Dialer2
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
control-plane
!
vstack
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 9
script dialer lte
modem InOut
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 15
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
login
transport input none
!
no scheduler max-task-time
ntp server 34.202.215.187
no iox hdm-enable
iox client enable interface GigabitEthernet5
no iox recovery-enable
!
event manager applet CLEAR_NAT
event track 3 state any
action 1.0 cli command "enable"
action 2.0 cli command "clear ip nat translation *"
action 3.0 cli command "end"
!
end

Thanks! I've changed what you commented.

I still however can't get ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1 to work properly, as the routing goes over Dialer2 then.

I found another thread that proposed this for a similar problem. It seems to work, but as Dialer1 does not function properly I'm not entirely sure. 

interface GigabitEthernet0
ip dhcp client route track 1
ip route 0.0.0.0 0.0.0.0 GigabitEthernet dhcp
ip route 0.0.0.0 0.0.0.0 dhcp
sh ip route track-table
 ip route 0.0.0.0 0.0.0.0 192.168.1.1 254 track 1 state is [up]
 ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 192.168.1.1 track 1 state is [up]
 ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2 state is [down]

I'm also looking into the problem of Dialer1 not working. When I add another routing for Dialer1 without the "track 2" it works (network on client), so I guess that there might be some issue with the sla?

I tried to do the "icmp-echo" with 8.8.4.4 as well. 

ip sla 2
 icmp-echo 8.8.4.4 source-interface Dialer1
 threshold 1000
 frequency 10
ip sla schedule 2 life forever start-time now

Thanks!

Hello,

 

when you configure:

 

--> ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
--> ip route 0.0.0.0 0.0.0.0 Dialer2 20
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1

 

and check the routing table (sh ip route), the 0.0.0.0 0.0.0.0 route via GigabitEthernet0 should be the only route in there, is that the case ?

I've changed it again, and reloaded the router. 

After startup, before the modems is online it wont use gi0.

 

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Vlan1
L        10.0.0.1/32 is directly connected, Vlan1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0
L        192.168.1.6/32 is directly connected, GigabitEthernet0

When the Dialers is online this is the new routing.

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      2.0.0.0/32 is subnetted, 1 subnets
C        2.90.71.238 is directly connected, Dialer2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Vlan1
L        10.0.0.1/32 is directly connected, Vlan1
      100.0.0.0/32 is subnetted, 1 subnets
C        100.90.58.111 is directly connected, Dialer1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0
L        192.168.1.6/32 is directly connected, GigabitEthernet0
show ip route track-table
 ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1 state is [down]
 ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2 state is [up]

So it seems like Dialer1 is now working. But it's not using the primary gi0. 

When I'm disconnecting the antenna of Dialer1 to simulate a loss of signal it changes over to Dialer2 successfully! :) 

(Dialer1 antenna disconnected)
Jul 8 11:53:39.278: %TRACK-6-STATE: 2 ip sla 2 reachability Up -> Down Jul 8 11:53:39.294: %TRACK-6-STATE: 3 list boolean or Up -> Down ir829#show ip route Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP a - application route + - replicated route, % - next hop override, p - overrides from PfR Gateway of last resort is 0.0.0.0 to network 0.0.0.0 S* 0.0.0.0/0 is directly connected, Dialer2 2.0.0.0/32 is subnetted, 1 subnets C 2.90.71.238 is directly connected, Dialer2 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks C 10.0.0.0/24 is directly connected, Vlan1 L 10.0.0.1/32 is directly connected, Vlan1 100.0.0.0/32 is subnetted, 1 subnets C 100.105.58.111 is directly connected, Dialer1 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.1.0/24 is directly connected, GigabitEthernet0 L 192.168.1.6/32 is directly connected, GigabitEthernet0 ir829#show ip route track-table ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1 state is [down] ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2 state is [down]

The WAN cable is still connected, so I don't understand why that one is not working anymore. 

 

interface GigabitEthernet0
 description Primary ISP
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
!
ip nat inside source route-map LTE_PRIMARY interface Dialer1 overload
ip nat inside source route-map LTE_SECONDARY interface Dialer2 overload
ip nat inside source route-map WAN interface GigabitEthernet0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
ip route 0.0.0.0 0.0.0.0 Dialer2 20
!
ip sla 1
 icmp-echo 8.8.8.8 source-interface GigabitEthernet0
 threshold 1000
 frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 8.8.4.4 source-interface Dialer1
 threshold 1000
 frequency 10
ip sla schedule 2 life forever start-time now

When I connect Dialer1 antenna again nothing happens (I guess it is nominal as long as Dialer2 is online), but when I then disconnect Dialer2 antenna nothing happens. 

 

 

I can clarify that it is not a requirement that it must go back to the GigabitEthernet0 interface if that one goes down and then comes back up, as long as it switches between the interfaces as they go down. Gi0 is connected to another wireless providers network, so the intention is to have a triple redundancy.

Hello,

 

can you ping 8.8.8.8 with source interface GigabitEthernet0 ?

 

829#ping 8.8.8.8 source GigabitEthernet0

 

?

That is a negative.

ir829#ping 8.8.8.8 source GigabitEthernet0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.6
.....
Success rate is 0 percent (0/5)

There is your problem. You need to make sure all connections are working. What if your source the ping from Dialer 1 ?

Yes. All of them is working by themselves, but not with the current routing table. 

Pinging with Gi0 works with a routing table like this

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp 
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
ip route 0.0.0.0 0.0.0.0 Dialer2 20

but not when I have it like this

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
ip route 0.0.0.0 0.0.0.0 Dialer2 20

It will not ping with Dialer1 either, only with Dialer2. 

All of them work independently, but when I add one or the other together one or both of the others stops working. 

 

Hello,

 

so dialer 1 is working by itself.

 

What if you just use these two routes:

 

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 10 

 

Does that work when GigabitEthernet0 goes down ?

Yes, then Dialer1 is the working interface. 


ir829#show run | begin ip route
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 10

ir829#show track Track 1 IP SLA 1 reachability Reachability is Down 19 changes, last change 00:03:13 Latest operation return code: Timeout Tracked by: Static IP Routing 0 Track List 3 Track 2 IP SLA 2 reachability Reachability is Up 8 changes, last change 00:00:12 Latest operation return code: OK Latest RTT (millisecs) 30 Tracked by: Track List 3 Track 3 List boolean or Boolean OR is Up 24 changes, last change 00:00:12 object 1 Down object 2 Up Tracked by: EEM applet CLEAR_NAT

When I disconnect the Dialer1 antenna nothing happens. I see that Gi0 is reported as reachability down either way. 

Do I need to specify a routing for the icmp-echo address maybe? 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card