07-15-2020 08:00 AM
Hi everyone,
I am trying to get LTE running on ISR 11xx routers.
Old config (dialer interface with "dialer pool" command and the cellular interface with "dialer pool-member" command) ist not working.
As I read there is new way to configure that.
That is what I tried:
TEST#cellular 0/2/0 lte profile create 1 internet.telekom
conf t
controller Cellular 0/2/0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
interface cellular 0/2/0
ip address negotiated
dialer in-band
dialer watch-group 1
dialer idle-timeout 0
dialer-group 1
pulse-time 1
ip route 0.0.0.0 0.0.0.0 cellular 0/2/0
dialer-list 1 protocol ip list 1
access-list 1 permit any
dialer watch-list 1 ip 5.6.7.8 255.255.255.255
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
Unfortunately I am not getting an IP address assigned.
Modem is up:
TEST#sh cel 0/2/0 radio
Radio power mode = online
LTE Rx Channel Number = 1600
LTE Tx Channel Number = 65535
LTE Band = 3
LTE Bandwidth = 20 MHz
Current RSSI = -58 dBm
Current RSRP = -87 dBm
Current RSRQ = -8 dB
Current SNR = 11.8 dB
Physical Cell Id = 92
Number of nearby cells = 4
Idx PCI (Physical Cell Id)
--------------------------------
1 92
2 12
3 322
4 432
Radio Access Technology(RAT) Preference = LTE
Radio Access Technology(RAT) Selected = LTE
But I am not getting a connection:
TEST#sh cel 0/2/0 network
Current System Time = Sun Jan 6 2:3:22 1980
Current Service Status = No service
Current Service = Unknown
Current Roaming Status = Roaming
Network Selection Mode = Automatic
Network = o2 - de
Mobile Country Code (MCC) = 262
Mobile Network Code (MNC) = 3
Packet switch domain(PS) state = Not attached
LTE Carrier Aggregation state = Deconfigured
Registration state(EMM) = Not registered
EMM Sub State = Limited Service
Tracking Area Code (TAC) = 0
Cell ID = 0
Network MTU = Not Available
Any ideas how to fix that?
What commands am I missing?
Thank you very much in advance.
Kind Regards
Ben
Solved! Go to Solution.
07-17-2020 03:16 AM
Hello,
it is possible that the provider has tied the SIM to the MAC address of the old device, for security purposes. It might be worth checking with your provider if that is the case...
07-15-2020 08:21 AM
Hello,
try the simplified configuraion below, then ping 8.8.8.8.
interface cellular 0/2/0
ip address negotiated
ip nat outside
dialer in-band
dialer idle-timeout 0
dialer-group 1
pulse-time 1
!
ip nat inside source list 1 interface Cellular0/2/0 overload
ip route 0.0.0.0 0.0.0.0 cellular 0/2/0
dialer-list 1 protocol ip permit
access-list 1 permit any
07-15-2020 08:37 AM
Hi Georg,
thanks for your quick response.
Unfortunately it's still not working.
Same output on the cel 0/2/0 network, no ip adress assigned, all pings failing.
Actually the cellular interface is in state down/down.
How do I get that into up/up state?
07-15-2020 09:10 AM
Hello,
what is the output of:
show cellular 0/2/0 profile
Try the dialer watch below:
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
interface cellular 0/2/0
ip address negotiated
ip nat outside
dialer in-band
dialer watch-group 1
dialer idle-timeout 0
dialer-group 1
pulse-time 1
!
ip route 0.0.0.0 0.0.0.0 cellular 0/2/0
dialer-list 1 protocol ip permit
access-list 1 permit any
!
dialer watch-list 1 ip 8.8.8.8 255.255.255.255
07-15-2020 09:23 AM
Hi,
#sh cel 0/2/0 profile
Profile password Encryption level = 7
Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = internet.telekom
Authentication = None
* - Default profile
** - LTE attach profile
Configured default profile for active SIM 0 is profile 1.
I applied the config you provided.
One thing I noticed now:
Most of the time, the cellular interface is down/down. But from time to time it is up for a very short time, displaying the following:
Cellular0/2/0 is up (spoofing), line protocol is up (spoofing)
07-15-2020 11:51 AM
Hello,
can you issue the exec command:
test cellular 0/2/0 modem-power-cycle
and post the output ?
07-16-2020 05:16 AM
Hi,
#test cellular 0/2/0 modem-power-cycle *Jul 16 14:15:28: %CELLWAN-4-MODEM_RESTART_IND: Cellular0/2/0 Modem restart User - PowerCycle *Jul 16 14:15:30: %IOSXE-3-PLATFORM: R0/0: ngiolite: CWAN:FD close request from IOS *Jul 16 14:15:35: %IOSXE-3-PLATFORM: R0/0: ngiolite: update_modem_ctrl : MODEM_CTRL_MSG_RESET: *Jul 16 14:15:48: %CELLWAN-2-MODEM_DOWN: Modem in slot 0/2 is DOWN *Jul 16 14:15:48: %IOSXE-3-PLATFORM: R0/0: ngiolite: SWI modem Action:[remove] State[2] Modem Power cycled successfully *Jul 16 14:16:21: %IOSXE-3-PLATFORM: R0/0: ngiolite: SWI modem Action:[add] State[1] *Jul 16 14:18:30: %CELLWAN-2-MODEM_UP: Modem in slot 0/2 is now UP *Jul 16 14:18:30: %CELLWAN-2-MODEM_RADIO: Cellular0/2/0 Modem radio has been turned on
07-16-2020 05:48 AM - edited 07-16-2020 05:52 AM
are you able to use that sim from a mobile? does it have PIN?
do you have your ISP SIM APN details?
cellular 0/2/0 lte sim unlock <PIN>
cellular 0/2/0 lte profile create 1 <APN (i.e. apn.movistar.com)> <pap/chap> <user> <pass> ipv4
yes
yes
controller Cellular 0/2/0
lte sim data-profile 1 attach-profile 1 slot 0 ! in case this is the slot you have the sim in
..
and the rest is said here already.
07-16-2020 07:54 AM
Hi,
sim is working in another device.
There is no PIN assigned at the moment.
ISP SIM APN details are configured.
I also did
"controller Cellular 0/2/0
lte sim data-profile 1 attach-profile 1 slot 0"
--> command is accepted, but i cannot see it in running config (neither in show run all)
07-16-2020 05:56 AM
Hello,
since you say the interface comes up from time to time, can you turn on:
debug modem
debug cellular 0 messages callcontrol
and post the output ?
07-16-2020 07:57 AM
hello,
*Jul 16 16:57:03: debug information ipc sent successfully *Jul 16 16:57:03: Debug information set successfully module=16,mask=65536 #Cellular0/2/0: Data connection setup failed sincemodem (PS=2,EMM=0) unattached #Cellular0/2/0: Data connection setup failed sincemodem (PS=2,EMM=0) unattached #Cellular0/2/0: Data connection setup failed sincemodem (PS=2,EMM=0) unattached
07-16-2020 12:32 PM
Hello,
there is definitely something wrong with your SIM card.
The output of:
TEST#sh cel 0/2/0 network
should render:
Current Service Status = Normal
Try to configure auto-sim:
TEST#conf t
TEST(config)#controller cellular 0/2/0
TEST(config-controller)#lte firmware auto-sim
Wait for 5 minutes, then power cycle the modem:
TEST#test cellular 0/2/0 modem-power-cycle
07-16-2020 04:05 PM - edited 07-16-2020 04:06 PM
-deleted-
07-16-2020 04:12 PM
Hey,
well, the sim was used before in another device.
So actually it should be working.
I tried "lte firmware auto-sim", but no changes.
I will be some days off, but after I will test the sim inside a smartphone again to check if it's still working.
Maybe I will even try another router just to be sure.
I will write back here if I got some new information.
Thank you so far.
07-17-2020 03:16 AM
Hello,
it is possible that the provider has tied the SIM to the MAC address of the old device, for security purposes. It might be worth checking with your provider if that is the case...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide