cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
459
Views
0
Helpful
7
Replies

ISR 4431 stuck in Controller Mode

Jason F
Beginner
Beginner

I have an ISR 4431 router that is stuck in Controller Mode, running IOS XE 16.12.03 Gibraltar.

The command

controller-mode disable

does not exist in this IOS XE version.

Also, having the file

ciscortr.cfg

in

bootflash:/ 

and it doesn't seem to make a difference.

The only documentation I found refers to IOS XE 17.2 and later: https://www.cisco.com/c/en/us/td/docs/routers/sdwan/configuration/sdwan-xe-gs-book/install-upgrade-17-2-later.html#switch-modes-using-cisco-cli

How do I change the ISR 4431 back to Autonomous Mode on 16.12.03?

Thank you!

Jason

1 Accepted Solution

Accepted Solutions

Jason F
Beginner
Beginner

I was able to recover the unit using a 2nd ISR 4431 that had IOS XE 16.06.04.  I copied the older IOS image to

bootflash:/ 

and the

startup-config

from the working 2nd router to

nvram:/.

  Then I reloaded the bad router and interrupted the boot process to enter rommon and executed the following command:

boot bootflash:/<ISR_4400_16.06.04_image>.  

When the system booted, I confirmed it was now operating in autonomous mode.

View solution in original post

7 Replies 7

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

If the router is in ROMMON, post the complete output to the command

set

 

If the router boots into IOS, post the complete output to the command

dir

Jason F
Beginner
Beginner

I was able to recover the unit using a 2nd ISR 4431 that had IOS XE 16.06.04.  I copied the older IOS image to

bootflash:/ 

and the

startup-config

from the working 2nd router to

nvram:/.

  Then I reloaded the bad router and interrupted the boot process to enter rommon and executed the following command:

boot bootflash:/<ISR_4400_16.06.04_image>.  

When the system booted, I confirmed it was now operating in autonomous mode.

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

I still want to see the complete output to the command

set

to make sure the settings is permanent.

Jason F
Beginner
Beginner

I have confirmed that the settings are permanent.

Here is the output from the set command:

romon 1 > set

PS1=rommon 1 >

THRPUT=

MCP_STARTUP_TRACEFLAGS=00000000:00000000

BOOT=bootflash:/isr4400-universalk9.16.06.04.SPA.bin,1;

LICENSE_BOOT_LEVEL=

BSI=0

RANDOM_NUM=19058…

RED_2_RTS=20:32:50…

RED_2_RCALTS=16710…

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

In ROMMON, do the following: 

DEVICE_MANAGED_MODE autonomous

or

DEVICE_MANAGED_MODE = autonomous

And then reboot.

Jason F
Beginner
Beginner

Both 

DEVICE_MANAGED_MODE autonomous

and 

DEVICE_MANAGED_MODE = autonomous

have the error message monitor: command "DEVICE_MANAGED_MODE" not found.

However, "DEVICE_MANAGED_MODE=autonomous" is accepted and I can see new entry in the output of the "set" command.  When I reboot the router and go in to ROMMON, I notice that the "DEVICE_MANAGED_MODE=autonomous" setting is not persistent.

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

Post the complete output to the command "dir flash:".

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers