the router is able to get a DHCP address but once expired it will not renew itself.
in order to renew the DHCP lease, NAT has to be disabled, it will then pull an IP, and NAT re-enabled for internet connectivity.
any help would be greatly appreciated.
bellow is the running-configuration
interface GigabitEthernet0/0/0
description Connection to ISP
ip address dhcp
ip nat outside
negotiation auto
!
interface GigabitEthernet0/0/1
description Connection to switch
ip address 192.168.1.1 255.255.255.0
ip nat inside
negotiation auto
!
interface GigabitEthernet0/0/1.10
description ###LOCAL-LAN###
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp
!
!
access-list 1 permit any