cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
634
Views
0
Helpful
5
Replies

Issue in Router 2911

itp.farouk
Level 1
Level 1

 Hi all, i have Router Cisco 2911 with 4 wic ADSL and 3 GIGAethernet. the issue is i configure 2 wic ADSL and its up, but i can't assign each dialer to specify Ethernet interface. all traffic routed to 1st dialer and don't want to routing to dialer2.

mainly i want to use this router to static routing 4 local sub-net for internet every subnet run through dialer without load balance or fail over.

my configuration as below:

 

!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!

!
boot-start-marker
boot-end-marker
!
!

!
no aaa new-model
ethernet lmi ce
memory-size iomem 25
clock timezone UTC 2 0
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!

!

!
redundancy
!
!
controller VDSL 0/0/0
!
controller VDSL 0/1/0
!
controller VDSL 0/2/0
!
controller VDSL 0/3/0
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
ip broadcast-address 0.0.0.0
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 8
ip address 192.168.8.2 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly in
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 121
ip address 192.168.121.2 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface GigabitEthernet0/1

shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2

shutdown
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
ip broadcast-address 0.0.0.0
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface Ethernet0/0/0
no ip address
ip broadcast-address 0.0.0.0
!
interface ATM0/1/0
no ip address
ip broadcast-address 0.0.0.0
no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
pvc 0/35
pppoe-client dial-pool-number 3
!
!
interface Ethernet0/1/0
no ip address
ip broadcast-address 0.0.0.0
!
interface ATM0/2/0
no ip address
ip broadcast-address 0.0.0.0
no atm ilmi-keepalive
!
interface ATM0/2/0.1 point-to-point
pvc 0/35
pppoe-client dial-pool-number 3
!
!
interface Ethernet0/2/0
no ip address
ip broadcast-address 0.0.0.0
!
interface ATM0/3/0
no ip address
no atm ilmi-keepalive
!
interface Ethernet0/3/0
no ip address
ip broadcast-address 0.0.0.0
!
interface Dialer1
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip policy route-map dialer1
dialer pool 2
dialer-group 2
ppp authentication pap callin
ppp pap sent-username xxx@xxxx.com password 0 xxxx
ppp ipcp dns request
!
interface Dialer2
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip policy route-map dialer2
dialer pool 3
dialer-group 3
ppp chap hostname xxx@xxxx.com
ppp chap password 0 xxx
ppp pap sent-username username xxx@xxxx.com password 0 xxxx
ppp ipcp dns request
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static 192.168.8.2 interface Dialer1
ip nat inside source static 192.168.121.2 interface Dialer2
ip nat inside source list 190 interface Dialer2 overload
ip route profile
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0.1
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0.2
ip ssh time-out 60
ip ssh source-interface GigabitEthernet0/1
!
ip access-list extended line1
!
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
!
route-map dialer2 permit 10
match ip address 160
set ip next-hop dynamic dhcp
!
route-map dialer1 permit 10
match ip address 150
set ip next-hop dynamic dhcp
!
!
access-list 1 permit any
access-list 150 permit ip 192.168.8.0 0.0.0.255 any
access-list 160 permit ip 192.168.121.0 0.0.0.255 any
access-list 190 permit ip any any

control-plane host
!
!
control-plane
!
!
vstack
!

 

!
end

5 Replies 5

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

Please can you provide us with the output from:

sh route-map

sh version

 

Also whilst we are here, you may want to disable the smart install feature on your router;

!
no vstack
!

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20120328-smartinstall

 

...unless you are using it, in which case secure it with an ACL.

 

cheers,

Seb.

ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)

System image file is "flash0:c2900-universalk9_npe-mz.SPA.155-3.M6a.bin"

 

router#sh route-map
route-map dialer2, permit, sequence 10
Match clauses:
ip address (access-lists): 160
Set clauses:
ip next-hop dynamic dhcp - current value is UNKNOWN
Policy routing matches: 0 packets, 0 bytes
route-map dialer1, permit, sequence 10
Match clauses:
ip address (access-lists): 150
Set clauses:
ip next-hop dynamic dhcp - current value is UNKNOWN
Policy routing matches: 11 packets, 728 bytes

 

OK, there is your problem:

ip next-hop dynamic dhcp - current value is UNKNOWN

 

..neither route-map knows which gateway to use via DHCP.

The configuration guides states:

 

Spoiler
The set ip next-hop dynamic dhcp command supports only a single DHCP interface. If multiple interfaces have DHCP configured, the gateway that was most recently learned among all interfaces running DHCP will be used by the route map.

https://www.cisco.com/en/US/products/ps6922/products_command_reference_chapter09186a00806c0a3f.html#wp1013323

 

...but neither route-map has a gateway.

 

Is it possible to statically assign the ISP IP address used on dialer2 ? Check the arp cache (sh ip arp) to determine this.

 

cheers,

Seb.

 

it's already configured ip next-hop dynamic dhcp

but i don't know you it's appear Unknown

 

 

route-map dialer2, permit, sequence 10
  Match clauses:
    ip address (access-lists): 160
  Set clauses:
    ip next-hop dynamic dhcp - current value is UNKNOWN
  Policy routing matches: 0 packets, 0 bytes
route-map dialer1, permit, sequence 10
  Match clauses:
    ip address (access-lists): 150
  Set clauses:
    ip next-hop dynamic dhcp - current value is UNKNOWN
  Policy routing matches: 11 packets, 728 bytes

 

 

hossien#sh ip int br dialer 1
Interface                  IP-Address      OK? Method Status                Protocol
Dialer1                    41.244.1.162   YES IPCP   up                    up

 

What is the output of sh int dialer 2 ?

 

There should be a line starting with 'Internet address x.x.x.x'

 

Use the IP address specified in your route-map:

!
route-map dialer2 permit 10
  match ip address 160
  set ip next-hop x.x.x.x
!

cheers,

Seb.

Review Cisco Networking for a $25 gift card