cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1345
Views
0
Helpful
2
Replies

Issue with OSPF and VRF

Me again with more CCNP studying.  So in gns 3 I have the following topology:

2020-09-22 17_26_05-S-TEST1 - s-test1 - Remote Desktop Connection.png

 

R1 is running a multi vrf/multi ospf process.  I'm trying to simulate something like what an ISP would potentially do.  So the ospf adjacency between R1 and R3 comes up fine...and the other 2 do not.  I have no clue what I'm doing wrong.  Probably being stupid and missing something simple but I can't figure it out.  Here's the configs:

 

R1:

R1#sh run int g1/0
Building configuration...

Current configuration : 183 bytes
!
interface GigabitEthernet1/0
 description TO-R2
 ip vrf forwarding R2
 ip address 10.255.5.1 255.255.255.0
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 negotiation auto
end

R1#sh run int g2/0
Building configuration...

Current configuration : 183 bytes
!
interface GigabitEthernet2/0
 description TO-R4
 ip vrf forwarding R4
 ip address 10.255.6.1 255.255.255.0
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 negotiation auto
end

R1#sh run int g3/0
Building configuration...

Current configuration : 183 bytes
!
interface GigabitEthernet3/0
 description TO-R3
 ip vrf forwarding R3
 ip address 10.255.7.1 255.255.255.0
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 negotiation auto
end

R1#sh run | s ospf
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 ip ospf dead-interval 3
 ip ospf hello-interval 1
router ospf 1 vrf R2
 router-id 5.1.1.1
 network 10.255.5.1 0.0.0.0 area 0
router ospf 2 vrf R4
 router-id 5.1.1.2
 network 10.255.6.1 0.0.0.0 area 0
router ospf 3 vrf R3
 router-id 5.1.1.3
 network 10.255.7.1 0.0.0.0 area 0

R2:

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
GigabitEthernet1/0         10.255.5.2      YES manual up                    up      
GigabitEthernet2/0         192.168.1.1     YES manual up                    up      
GigabitEthernet3/0         unassigned      YES unset  administratively down down    
GigabitEthernet4/0         unassigned      YES unset  administratively down down    
GigabitEthernet5/0         unassigned      YES unset  administratively down down    
GigabitEthernet6/0         unassigned      YES unset  administratively down down    
Loopback1                  172.65.1.1      YES manual up                    up      
Loopback2                  172.65.2.1      YES manual up                    up      
Loopback3                  172.65.3.1      YES manual up                    up      
R2#     
R2#sh run int g1/0
Building configuration...

Current configuration : 161 bytes
!
interface GigabitEthernet1/0
 description TO-R1
 ip address 10.255.5.2 255.255.255.0
 ip ospf dead-interval 2
 ip ospf hello-interval 1
 negotiation auto
end

R2#
R2#sh run | s ospf
 ip ospf dead-interval 2
 ip ospf hello-interval 1
router ospf 1
 router-id 2.2.2.2
 network 10.255.5.2 0.0.0.0 area 0
 network 172.65.1.1 0.0.0.0 area 0
 network 172.65.2.1 0.0.0.0 area 0
 network 172.65.3.1 0.0.0.0 area 0

R4:

R4#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
GigabitEthernet1/0         10.255.6.2      YES manual up                    up      
GigabitEthernet2/0         192.168.2.1     YES manual up                    up      
GigabitEthernet3/0         unassigned      YES unset  administratively down down    
GigabitEthernet4/0         unassigned      YES unset  administratively down down    
GigabitEthernet5/0         unassigned      YES unset  administratively down down    
GigabitEthernet6/0         unassigned      YES unset  administratively down down    
Loopback1                  172.65.4.1      YES manual up                    up      
Loopback2                  172.65.5.1      YES manual up                    up      
Loopback3                  172.65.6.1      YES manual up                    up      
R4#
R4#sh run int g1/0
Building configuration...

Current configuration : 142 bytes
!
interface GigabitEthernet1/0
 ip address 10.255.6.2 255.255.255.0
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 negotiation auto
end

R4#
R4#sh run | s ospf
 ip ospf dead-interval 3
 ip ospf hello-interval 1
router ospf 1
 router-id 4.4.4.4
 network 10.255.6.1 0.0.0.0 area 0
 network 172.65.4.1 0.0.0.0 area 0
 network 172.65.5.1 0.0.0.0 area 0
 network 172.65.6.1 0.0.0.0 area 0

R3:

R3#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
GigabitEthernet1/0         10.255.7.2      YES manual up                    up      
GigabitEthernet2/0         192.168.3.1     YES manual up                    up      
GigabitEthernet3/0         unassigned      YES unset  administratively down down    
GigabitEthernet4/0         unassigned      YES unset  administratively down down    
GigabitEthernet5/0         unassigned      YES unset  administratively down down    
GigabitEthernet6/0         unassigned      YES unset  administratively down down    
Loopback1                  172.65.7.1      YES manual up                    up      
Loopback2                  172.65.8.1      YES manual up                    up      
Loopback3                  172.65.9.1      YES manual up                    up      
R3#
R3#sh run int g1/0
Building configuration...

Current configuration : 142 bytes
!
interface GigabitEthernet1/0
 ip address 10.255.7.2 255.255.255.0
 ip ospf dead-interval 3
 ip ospf hello-interval 1
 negotiation auto
end

R3#
R3#sh run | s ospf
 ip ospf dead-interval 3
 ip ospf hello-interval 1
router ospf 1
 router-id 3.3.3.3
 network 10.255.7.2 0.0.0.0 area 0
 network 172.65.7.1 0.0.0.0 area 0
 network 172.65.8.1 0.0.0.0 area 0
 network 172.65.9.1 0.0.0.0 area 0

So again, the R3 stuff works fine.  If I go on R1 and do 

sh ip ro vrf R3

 I get

R1#sh ip ro vrf R3

Routing Table: R3
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.255.7.0/24 is directly connected, GigabitEthernet3/0
L        10.255.7.1/32 is directly connected, GigabitEthernet3/0
      172.65.0.0/32 is subnetted, 3 subnets
O        172.65.7.1 [110/2] via 10.255.7.2, 00:05:42, GigabitEthernet3/0
O        172.65.8.1 [110/2] via 10.255.7.2, 00:05:42, GigabitEthernet3/0
O        172.65.9.1 [110/2] via 10.255.7.2, 00:05:42, GigabitEthernet3/0

But the vrf/ospf between R2 and R4 doesn't work.  debug ip ospf adjacency shows nothing.  debug ip ospf packets shows

*Sep 22 17:41:29.082: OSPF-1 PAK  : rcv. v:2 t:1 l:44 rid:2.2.2.2 aid:0.0.0.0 chk:D8C8 aut:0 auk: from GigabitEthernet1/0
*Sep 22 17:41:29.410: OSPF-3 PAK  : rcv. v:2 t:1 l:48 rid:3.3.3.3 aid:0.0.0.0 chk:BCBD aut:0 auk: from GigabitEthernet3/0
R1#
*Sep 22 17:41:30.082: OSPF-1 PAK  : rcv. v:2 t:1 l:44 rid:2.2.2.2 aid:0.0.0.0 chk:D8C8 aut:0 auk: from GigabitEthernet1/0
*Sep 22 17:41:30.410: OSPF-3 PAK  : rcv. v:2 t:1 l:48 rid:3.3.3.3 aid:0.0.0.0 chk:BCBD aut:0 auk: from GigabitEthernet3/0
*Sep 22 17:41:31.026: OSPF-1 PAK  : rcv. v:2 t:1 l:44 rid:2.2.2.2 aid:0.0.0.0 chk:D8C8 aut:0 auk: from GigabitEthernet1/0
R1#
*Sep 22 17:41:31.338: OSPF-3 PAK  : rcv. v:2 t:1 l:48 rid:3.3.3.3 aid:0.0.0.0 chk:BCBD aut:0 auk: from GigabitEthernet3/0
*Sep 22 17:41:31.930: OSPF-1 PAK  : rcv. v:2 t:1 l:44 rid:2.2.2.2 aid:0.0.0.0 chk:D8C8 aut:0 auk: from GigabitEthernet1/0
*Sep 22 17:41:32.334: OSPF-3 PAK  : rcv. v:2 t:1 l:48 rid:3.3.3.3 aid:0.0.0.0 chk:BCBD aut:0 auk: from GigabitEthernet3/0
R1#
*Sep 22 17:41:32.894: OSPF-1 PAK  : rcv. v:2 t:1 l:44 rid:2.2.2.2 aid:0.0.0.0 chk:D8C8 aut:0 auk: from GigabitEthernet1/0
*Sep 22 17:41:33.338: OSPF-3 PAK  : rcv. v:2 t:1 l:48 rid:3.3.3.3 aid:0.0.0.0 chk:BCBD aut:0 auk: from GigabitEthernet3/0
*Sep 22 17:41:33.818: OSPF-1 PAK  : rcv. v:2 t:1 l:44 rid:2.2.2.2 aid:0.0.0.0 chk:D8C8 aut:0 auk: from GigabitEthernet1/0

and that just repeats.  

I've already removed all the ospf instances on R1 and remade them, and I took all the cables out of GNS3 and re-did those as well.  Not sure what I'm doing wrong.  

1 Accepted Solution

Accepted Solutions

And my routing advertisement on R4 had 10.255.6.1 instead of 10.255.6.2

 

I guess I just needed to post it to see it all laid out haha.  Thanks for all who took the time to read anyway.

View solution in original post

2 Replies 2

Ok so as soon as I posted I realized I had the dead interval wrong on the link to R2.  Fixed that and it came up.  Still no luck with R4 though.

And my routing advertisement on R4 had 10.255.6.1 instead of 10.255.6.2

 

I guess I just needed to post it to see it all laid out haha.  Thanks for all who took the time to read anyway.