09-21-2011 11:29 PM - edited 03-04-2019 01:41 PM
We are implementing the network design between the two sites (OLD Data center and NEW Data Center), scheme in attachement.
We have chosen this scheme on the following criteria:
- A single IP network between the sites (for simplicity migration);
- Fault tolerance via different ISPs.
But the problem is L2 etherchannel doesn't work correctly:
when one side port is shutting down, on the other side etherchannel will not rebuild and does not see that link down on the other end.
We have tried to use LACP in etherchannel (mode active on ports), but result was the same.
What may be the problem? Is it on the ISPs side?
Should we use this design or we have to subneting the network and make connections between the data centers classically with L3 channels and OSPF?
The configures of Core ports listed below:
OLD data center core (Cat 6509):
interface GigabitEthernet2/6
description #### TO DATA-CENTER core 1#####
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
logging event link-status
logging event trunk-status
logging event bundle-status
speed 100
duplex full
udld port aggressive
channel-group 2 mode on
end
!
interface GigabitEthernet2/7
description #### TO DATA-CENTER core 2#####
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
logging event link-status
logging event trunk-status
logging event bundle-status
shutdown
speed 100
duplex full
udld port aggressive
channel-group 2 mode on
end
!
interface Port-channel2
description #### TO DATA-CENTER core 1#####
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
logging event link-status
logging event trunk-status
logging event bundle-status
speed 100
duplex full
end
NEW data center core (Stack 2x3750):
interface GigabitEthernet1/0/1
description -- to MC-16R2-Core, port gi 2/6 --
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
speed 100
duplex full
udld port aggressive
channel-group 1 mode on
end
!
interface GigabitEthernet2/0/1
description -- to MC-16R2-Core, port gi 2/7 --
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
shutdown
speed 100
duplex full
udld port aggressive
channel-group 1 mode on
end
interface Port-channel1
description ### to MC-16R2-Core ###
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
speed 100
duplex full
end
I would be grateful for any advice.
09-24-2011 01:45 PM
Hi Dmitry,
I couldn't open the .vsd file, so I will just give it a try - I think having a L2VPN in that case would be beneficial, as you are trying to bridge two disperse segments via a 3d-party carrier.
HTH,
Ivan.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide