Hi
I'm not sure if what I'm attempting to achieve is even possible..
I have a cisco 887VAG router with a working cellular configuration. This gives me a private IP address on the Cellular 0 interface.
We then have a VPN tunnel from our cellular provider back to our LNS. I am then trying to establish an L2TP tunnel back to a LNS over that working cellular connection and VPN.
I can ping between the IP address on the cellular 0 interface and the LNS so there isn't a communication issue there.
Has anyone attempted this before? Is it even possible?
Config we have tried so far is below:
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname 3G-TEST
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authorization network default none
!
aaa session-id common
!
!
no ip domain lookup
ip domain name test.com
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
vpdn enable
vpdn search-order domain
!
vpdn-group 1
request-dialin
protocol l2tp
domain test.com
initiate-to ip 192.168.168.2
local name 3G_TEST-RT1
l2tp tunnel password 0 password
!
chat-script gsm "" "AT!SCACT=1" TIMEOUT 30 "OK"
license udi pid C887VAG+7-K9 sn FCZ183790Y9
!
!
!
controller VDSL 0
!
controller Cellular 0
gsm sim profile 4 slot 0
gsm sim profile 5 slot 1
gsm failovertimer 1
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
!
interface Loopback11
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0
no ip address
shutdown
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
switchport mode trunk
no ip address
!
interface Virtual-Template1
ip unnumbered Cellular0
no ip route-cache
peer default ip address dhcp
ppp authentication chap callin
ppp chap hostname test@test.com
ppp chap password 0 password
!
interface Cellular0
ip address negotiated
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string gsm
dialer-group 1
!
interface Vlan1
description $ETH_LAN$
no ip address
ip tcp adjust-mss 1452
shutdown
!
interface Vlan10
ip address 172.16.200.2 255.255.255.128
ip tcp adjust-mss 1452
no autostate
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callout
ppp chap hostname test@test.com
ppp chap password 0 password
ppp direction callout
no cdp enable
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.55.4.144 255.255.255.240 Cellular0
ip route 192.168.168.0 255.255.255.0 Cellular0
!
access-list 1 permit any
access-list 23 permit 10.10.200.0 0.0.0.7
access-list 23 permit 172.16.0.0 0.15.255.255
dialer-list 1 protocol ip list 1
no cdp run
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 14400 0
password vodafone
script dialer gsm
no modem enable
line aux 0
modem InOut
transport input all
autoselect during-login
autoselect ppp
speed 38400
flowcontrol hardware
line 3
exec-timeout 0 0
script dialer gsm
modem InOut
no exec
transport input all
autoselect ppp
rxspeed 21600000
txspeed 5760000
line vty 0 4
access-class 23 in
privilege level 15
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
transport input telnet ssh
!
!
end