cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
298
Views
10
Helpful
2
Replies
Highlighted

Limit Bandwidth on Cisco router 2901

Hello,

we have a   2901 Cisco router  with 2Mb bandwidth with access to a remote site (data center) so we have 2 servers A and B we want to limit the bandwidth for accessing the server A to a 512Kb Max for all users (Not per IP) how can i do that and thank you. 

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant

Re: Limit Bandwidth on Cisco router 2901

Hi,

 

You may apply service-policy on output interface (facing data centre).

 

Here is used 10.0.0.1 as an example to represent SERVER A

 

ip access-list extended TRAFFIC_TO_SERVER_A
   permit ip any host 10.0.0.1
class-map TRAFFIC_TO_SERVER_A
   match access name TRAFFIC_TO_SERVER_A
policy-map OUTPUT_POLICY
  class-map TRAFFIC_TO_SERVER_A
     shape average 512000
interface Fa0/0
    service-policy output OUTPUT_POLICY

View solution in original post

2 REPLIES 2
Highlighted
Participant

Re: Limit Bandwidth on Cisco router 2901

Hi,

 

You may apply service-policy on output interface (facing data centre).

 

Here is used 10.0.0.1 as an example to represent SERVER A

 

ip access-list extended TRAFFIC_TO_SERVER_A
   permit ip any host 10.0.0.1
class-map TRAFFIC_TO_SERVER_A
   match access name TRAFFIC_TO_SERVER_A
policy-map OUTPUT_POLICY
  class-map TRAFFIC_TO_SERVER_A
     shape average 512000
interface Fa0/0
    service-policy output OUTPUT_POLICY

View solution in original post

Highlighted
VIP Expert

Re: Limit Bandwidth on Cisco router 2901

Although ngkin2010 shows (correctly) how to limit bandwidth from site to DC, what about from remote DC to your site?

Further, unless you have a real need to actaully limit bandwidth, I would suggest you instead guarantee 25% of the 2 Mbps to the server A. Doing so would allow this traffic to use more, if otherwise not being used.

Lastly, for a working with only 2 Mbps, I highly recommend using FQ; this way heavy bandwidth flows will not so much adversely impact other light bandwidth usage flows. (FQ works so well, that using it alone may be all you need.

Example policies for the three:

policy-map OUTPUT_POLICY
class-map TRAFFIC_TO_SERVER_A
bandwidth percent 25
class-map class-default
bandwidth percent 75

policy-map OUTPUT_POLICY
class-map TRAFFIC_TO_SERVER_A
bandwidth percent 25
fair-queue
class-map class-default
bandwidth percent 75
fair-queue

policy-map OUTPUT_POLICY
class-map class-default
fair-queue