cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

660
Views
10
Helpful
18
Replies
Beginner

MPLS connection move from Switch to router

Here is the scenario - we have MPLS connected from ISP onto a switch, and this is due to not having the wic card in place day of delivery - no WIC is in place in the router (2901) and working - MPLS has been working perfect, i can ping the PE device ip address from my router so on and so forth - here is the problem, i need to move that MPLS connection to my router - and i thought i had this figured out but i guess not - not as easy as just moving cat cable from switch to router and keeping config the same - 

 

thoughts?

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Advisor

Re: MPLS connection move from Switch to router

Hi

Just a couple of questions, This configuration (blue) looks an iBGP to your internal network is that correct? and is it just for internal not to connect to the ISP?

 

interface GigabitEthernet0/1.1
description DATA VLAN
encapsulation dot1Q 1 native
ip address 10.179.129.253 255.255.255.0
ip nat inside

 

But you are now trying connecting to a Etherswitch module the ISP's router, is that correct?

 

Physical WIC port

!
interface GigabitEthernet0/1/0
no ip address
!
interface GigabitEthernet0/1/1
no ip address
!
interface GigabitEthernet0/1/2
no ip address
!
interface GigabitEthernet0/1/3
no ip address
duplex full
speed auto

 

So I would like to see the current configuration for the connection with the ISP. With Etherswich module you could configure:

 

Example:

vlan 100

name ISP

 

ip routing

 

interface vlan 100

ip address x.x.x.x y.y.y.y (P2P with provider)

no shutdown

 

interface g0/1/3

switchport access vlan 100

switchport mode access

no shutdown

 

ip route 0.0.0.0 0.0.0.0 x.x.x.x  (pointing to ISP router interface IP)

 

Could you please share a Low level topology?

Thank you in advance

 

:-)

View solution in original post

VIP Advisor

Re: MPLS connection move from Switch to router

Hello

Then providing the wic is working you should obtain connectivity - Which makes me wonder if its the wic

 

Can you confirm its installed correctly ( in the correct slot)

Have you rebooted the rtr?
Can you ping the interface on the wic when its connected to your laptop?

 

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

18 REPLIES 18
VIP Advisor

Re: MPLS connection move from Switch to router

Hi

It is a little bit confuse, could you please a diagram (details are not requested, it could be a simple scheme). Your router is the CE? If you want to change your current CE (Switch) by a router you need to verify the configuration to mirror it to the router. 

Beginner

Re: MPLS connection move from Switch to router

....that's where i'm confused, so the router has been the CE device all along, but, there was a switch in the middle - so picture..... (router CE)-----[switch]----(router PE) - now we want to remove switch and go (router CE)--------(router PE) - in my eye the config hasnt changed, all we did was add the WIC card on the router so that the PE device could connect to it. Make sense?

 

....wanted to add this from debug.

001795: Jan 13 18:06:25.546 EST: BGP: Regular scanner timer event
001796: Jan 13 18:06:25.546 EST: BGP: Performing BGP general scanning
001797: Jan 13 18:06:25.546 EST: BGP: topo global:IPv4 Unicast:base Scanning routing tables
001798: Jan 13 18:06:25.546 EST: BGP: tbl IPv4 Unicast:base Performing BGP Nexthop scanning for general scan
001799: Jan 13 18:06:25.546 EST: BGP(0): Future scanner version: 1418, current scanner version: 1417
001800: Jan 13 18:06:25.546 EST: BGP: topo global:IPv4 Multicast:base Scanning routing tables
001801: Jan 13 18:06:25.546 EST: BGP: tbl IPv4 Multicast:base Performing BGP Nexthop scanning for general scan
001802: Jan 13 18:06:25.546 EST: BGP(6): Future scanner version: 1419, current scanner version: 1418
001803: Jan 13 18:06:35.838 EST: BGP: 10.179.129.252 open failed: Connection timed out; remote host not responding
001804: Jan 13 18:06:35.838 EST: BGP: 10.179.129.252 Active open failed - tcb is not available, open active delayed 13312ms (35000ms max, 60% jitter)
001805: Jan 13 18:06:35.838 EST: BGP: ses global 10.179.129.252 (0x23D7E0FC:0) act Reset (Active open failed).
001806: Jan 13 18:06:35.838 EST: BGP: tbl IPv4 Unicast:base Service reset requests
001807: Jan 13 18:06:35.838 EST: BGP: tbl IPv4 Multicast:base Service reset requests
001808: Jan 13 18:06:35.838 EST: BGP: 10.179.129.252 active went from Active to Idle
001809: Jan 13 18:06:35.838 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
001810: Jan 13 18:06:35.838 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
001811: Jan 13 18:06:48.846 EST: BGP: 10.179.129.252 active went from Idle to Active
001812: Jan 13 18:06:48.846 EST: BGP: 10.179.129.252 open active, local address 10.179.129.253

VIP Advisor

Re: MPLS connection move from Switch to router

Hi

Thank you for the clarification, if the switch is configured as layer 2 and it is just for transit you should not have any problem, as you mentioned just disconnect the cable from the PE to the new CE, the key is verify how is configure the switch if it has an IP address or what is different.  

 

Is possible to see the configuration on the switch? was it running BGP?

 

 

Beginner

Re: MPLS connection move from Switch to router

HI Julio - switch has absolutely no config at all, simple L2 device - so yes a transition device... here is the port config from switch.... this is the port MPLS was coming in on.

interface GigabitEthernet1/0/14
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos

..

VIP Advisor

Re: MPLS connection move from Switch to router

You should not have any problem at all, unless there is a configuration on the PE with negotiation like duplex or speed. I suggest talk with the ISP and verify its configuration and request a maintenance window along with them. 

Highlighted
Beginner

Re: MPLS connection move from Switch to router

right....that's where i'm stuck - so if i put it back on the switch everything go back to normal. i believe the router is set to auto/auto for both speed and duplex - did you happen to take a look at the debug messages i posted? i will open a ticket with ISP and go from there.... thanks.

VIP Advisor

Re: MPLS connection move from Switch to router

You could try cleaning the ARP entries or remove the BGP configuration and paste it again but I strongly suggest do that along with the provider during an authorized maintenance to avoid any problem.

 

Remember get a backup of your configuration. 

 

:-)

VIP Advisor

Re: MPLS connection move from Switch to router

Hello

 


@mrochac wrote:

....that's where i'm confused, so the router has been the CE device all along, but, there was a switch in the middle - so picture..... (router CE)-----[switch]----(router PE) - now we want to remove switch and go (router CE)--------(router PE) - in my eye the config hasnt changed, all we did was add the WIC card on the router so that the PE device could connect to it. Make sense?

 

....wanted to add this from debug.

001795: Jan 13 18:06:25.546 EST: BGP: Regular scanner timer event
001796: Jan 13 18:06:25.546 EST: BGP: Performing BGP general scanning
001797: Jan 13 18:06:25.546 EST: BGP: topo global:IPv4 Unicast:base Scanning routing tables
001798: Jan 13 18:06:25.546 EST: BGP: tbl IPv4 Unicast:base Performing BGP Nexthop scanning for general scan
001799: Jan 13 18:06:25.546 EST: BGP(0): Future scanner version: 1418, current scanner version: 1417
001800: Jan 13 18:06:25.546 EST: BGP: topo global:IPv4 Multicast:base Scanning routing tables
001801: Jan 13 18:06:25.546 EST: BGP: tbl IPv4 Multicast:base Performing BGP Nexthop scanning for general scan
001802: Jan 13 18:06:25.546 EST: BGP(6): Future scanner version: 1419, current scanner version: 1418
001803: Jan 13 18:06:35.838 EST: BGP: 10.179.129.252 open failed: Connection timed out; remote host not responding
001804: Jan 13 18:06:35.838 EST: BGP: 10.179.129.252 Active open failed - tcb is not available, open active delayed 13312ms (35000ms max, 60% jitter)
001805: Jan 13 18:06:35.838 EST: BGP: ses global 10.179.129.252 (0x23D7E0FC:0) act Reset (Active open failed).
001806: Jan 13 18:06:35.838 EST: BGP: tbl IPv4 Unicast:base Service reset requests
001807: Jan 13 18:06:35.838 EST: BGP: tbl IPv4 Multicast:base Service reset requests
001808: Jan 13 18:06:35.838 EST: BGP: 10.179.129.252 active went from Active to Idle
001809: Jan 13 18:06:35.838 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
001810: Jan 13 18:06:35.838 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
001811: Jan 13 18:06:48.846 EST: BGP: 10.179.129.252 active went from Idle to Active
001812: Jan 13 18:06:48.846 EST: BGP: 10.179.129.252 open active, local address 10.179.129.253


Why are you adding a WIC card when when the rtr didn’t have one prior to this especially when the switch inbetween as you say was just acting as L2 transit connection?

 

The bgp debug is stating no tcp connection hence no established peering is successful 

 

From your PE rtr perspective  nothing  would have change so all your u need to do is get the physical interface on your CE rtr talking to the PE  

 

One possible reason could be the switch was mdix compatibie  and now as your directly connected to the PE rtr your may require a crossover cable

 

res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
VIP Advisor

Re: MPLS connection move from Switch to router

Hi Paul,

Good point, the reason could be the cable, a crossover is required to interconnect routers and probably it was missed during the first implementation and that is the reason of the switch. 

Beginner

Re: MPLS connection move from Switch to router

Hi Paul - the switch was a short term band-aid so i can bring up MPLS connection and setup BGP - i'm not a fan of having the switch in the middle, its an access switch adn the MPLS should be connecting to rtr anyways - the WIC was installed because i didnt have a port available. I will see if i can find a xover cable and attempt what you suggested.... thanks

VIP Advisor

Re: MPLS connection move from Switch to router

Hello


@mrochac wrote:

the WIC was installed because i didnt have a port available.


Glad to hear that -  but your comment above  i dont understand  -  if you didnt have port available how is the rtr connecting without the wic into the switch?

 

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: MPLS connection move from Switch to router

... so the router right now has 3 ports being used for WAN (GE/0), LAN (GE/1), CGI (WIC/0) (secure connection) - now i'm adding an addition WAN connection to MPLS which is going into WIC - so the router has 2 GE ports an additional WIC for the CGI connection - and now i'm adding a 2nd WIC with 4GE ports... hope this clears things up...

Beginner

Re: MPLS connection move from Switch to router

gents - so i changed the cable between the routers to a xover - having issues again... here is some info that i hope it can help you guys help me...

 

NLCU-TBAMBER-R1#sh ip bgp neighbors 10.179.129.252
BGP neighbor is 10.179.129.252, remote AS 65057, internal link
BGP version 4, remote router ID 0.0.0.0
BGP state = Active
Neighbor sessions:
0 active, is not multisession capable (disabled)

 

and....

NLCU-TBAMBER-R1#
012980: Jan 14 14:40:16.281 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 120: Neighbor 10.101.11.18 (GigabitEthernet0/0.38) is up: new adjacency
012981: Jan 14 14:40:19.949 EST: BGP: 10.179.129.252 open failed: Connection timed out; remote host not responding
012982: Jan 14 14:40:19.949 EST: BGP: 10.179.129.252 Active open failed - tcb is not available, open active delayed 12288ms (35000ms max, 60% jitter)
012983: Jan 14 14:40:19.949 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) act Reset (Active open failed).
012984: Jan 14 14:40:19.949 EST: BGP: tbl IPv4 Unicast:base Service reset requests
012985: Jan 14 14:40:19.949 EST: BGP: tbl IPv4 Multicast:base Service reset requests
012986: Jan 14 14:40:19.949 EST: BGP: 10.179.129.252 active went from Active to Idle
012987: Jan 14 14:40:19.949 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
012988: Jan 14 14:40:19.949 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
012989: Jan 14 14:40:31.321 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 120: Neighbor 10.101.11.18 (GigabitEthernet0/0.38) is down: Interface PEER-TERMINATION received
012990: Jan 14 14:40:31.965 EST: BGP: 10.179.129.252 active went from Idle to Active
012991: Jan 14 14:40:31.965 EST: BGP: 10.179.129.252 open active, local address 10.179.129.253
012992: Jan 14 14:40:36.301 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 120: Neighbor 10.101.11.18 (GigabitEthernet0/0.38) is up: new adjacency
012993: Jan 14 14:40:51.169 EST: BGP: Regular scanner timer event
012994: Jan 14 14:40:51.169 EST: BGP: Performing BGP general scanning
012995: Jan 14 14:40:51.173 EST: BGP: topo global:IPv4 Unicast:base Scanning routing tables
012996: Jan 14 14:40:51.173 EST: BGP: tbl IPv4 Unicast:base Performing BGP Nexthop scanning for general scan
012997: Jan 14 14:40:51.173 EST: BGP(0): Future scanner version: 2649, current scanner version: 2648
012998: Jan 14 14:40:51.173 EST: BGP: topo global:IPv4 Multicast:base Scanning routing tables
012999: Jan 14 14:40:51.173 EST: BGP: tbl IPv4 Multicast:base Performing BGP Nexthop scanning for general scan
013000: Jan 14 14:40:51.173 EST: BGP(6): Future scanner version: 2650, current scanner version: 2649
013001: Jan 14 14:41:01.965 EST: BGP: 10.179.129.252 open failed: Connection timed out; remote host not responding
013002: Jan 14 14:41:01.965 EST: BGP: 10.179.129.252 Active open failed - tcb is not available, open active delayed 12288ms (35000ms max, 60% jitter)
013003: Jan 14 14:41:01.965 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) act Reset (Active open failed).
013004: Jan 14 14:41:01.965 EST: BGP: tbl IPv4 Unicast:base Service reset requests
013005: Jan 14 14:41:01.965 EST: BGP: tbl IPv4 Multicast:base Service reset requests
013006: Jan 14 14:41:01.965 EST: BGP: 10.179.129.252 active went from Active to Idle
013007: Jan 14 14:41:01.965 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
013008: Jan 14 14:41:01.965 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running

 

...starting to think something is up on the PE side, unless i made i bad cable!!

 

 

..in addition, as soon as i move to switch.....

 

013324: Jan 14 14:53:43.744 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 120: Neighbor 10.101.11.18 (GigabitEthernet0/0.38) is down: Interface PEER-TERMINATION received
013325: Jan 14 14:53:48.024 EST: BGP: 10.179.129.252 open failed: Connection timed out; remote host not responding
013326: Jan 14 14:53:48.024 EST: BGP: 10.179.129.252 Active open failed - tcb is not available, open active delayed 11264ms (35000ms max, 60% jitter)
013327: Jan 14 14:53:48.024 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) act Reset (Active open failed).
013328: Jan 14 14:53:48.024 EST: BGP: tbl IPv4 Unicast:base Service reset requests
013329: Jan 14 14:53:48.024 EST: BGP: tbl IPv4 Multicast:base Service reset requests
013330: Jan 14 14:53:48.024 EST: BGP: 10.179.129.252 active went from Active to Idle
013331: Jan 14 14:53:48.024 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
013332: Jan 14 14:53:48.024 EST: BGP: nbr global 10.179.129.252 Active open failed - open timer running
013333: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive open to 10.179.129.253
013334: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive went from Idle to Connect
013335: Jan 14 14:53:48.540 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) pas Setting open delay timer to 60 seconds.
013336: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcv message type 1, length (excl. header) 38
013337: Jan 14 14:53:48.540 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) pas Receive OPEN
013338: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcv OPEN, version 4, holdtime 180 seconds
013339: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcv OPEN w/ OPTION parameter len: 28
013340: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcvd OPEN w/ optional parameter type 2 (Capability) len 6
013341: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has CAPABILITY code: 1, length 4
013342: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has MP_EXT CAP for afi/safi: 1/1
013343: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcvd OPEN w/ optional parameter type 2 (Capability) len 2
013344: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has CAPABILITY code: 128, length 0
013345: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has ROUTE-REFRESH capability(old) for all address-families
013346: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcvd OPEN w/ optional parameter type 2 (Capability) len 2
013347: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has CAPABILITY code: 2, length 0
013348: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has ROUTE-REFRESH capability(new) for all address-families
013349: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcvd OPEN w/ optional parameter type 2 (Capability) len 2
013350: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has CAPABILITY code: 70, length 0
013351: Jan 14 14:53:48.540 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) pas Enhanced Refresh cap received in open message
013352: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcvd OPEN w/ optional parameter type 2 (Capability) len 6
013353: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has CAPABILITY code: 65, length 4
013354: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive OPEN has 4-byte ASN CAP for: 65057
013355: Jan 14 14:53:48.540 EST: BGP: nbr global 10.179.129.252 neighbor does not have IPv4 MDT topology activated
013356: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive rcvd OPEN w/ remote AS 65057, 4-byte remote AS 65057
013357: Jan 14 14:53:48.540 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) pas Adding topology IPv4 Unicast:base
013358: Jan 14 14:53:48.540 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) pas Send OPEN
013359: Jan 14 14:53:48.540 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:0) pas Building Enhanced Refresh capability
013360: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive went from Connect to OpenSent
013361: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive sending OPEN, version 4, my as: 65057, holdtime 180 seconds, ID AB381FD
013362: Jan 14 14:53:48.540 EST: BGP: 10.179.129.252 passive went from OpenSent to OpenConfirm
013363: Jan 14 14:53:48.544 EST: BGP: 10.179.129.252 passive went from OpenConfirm to Established
013364: Jan 14 14:53:48.544 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:1) pas Assigned ID
013365: Jan 14 14:53:48.544 EST: BGP: nbr global 10.179.129.252 Stop Active Open timer as all topologies are allocated
013366: Jan 14 14:53:48.544 EST: BGP: ses global 10.179.129.252 (0x23A98EE0:1) Up
013367: Jan 14 14:53:48.544 EST: BGP: nopeerup-delay post-boot, set to default, 60s
013368: Jan 14 14:53:48.544 EST: %BGP-5-ADJCHANGE: neighbor 10.179.129.252 Up
013369: Jan 14 14:53:48.544 EST: BGP(0): 10.179.129.252 NEXT_HOP is set to self for net 172.24.5.0/24,
013370: Jan 14 14:53:48.544 EST: BGP(0): (base) 10.179.129.252 send UPDATE (format) 172.24.5.0/24, next 10.179.129.253, metric 28416, path Local
013371: Jan 14 14:53:48.544 EST: BGP(0): 10.179.129.252 NEXT_HOP is set to self for net 192.168.5.0/24,
013372: Jan 14 14:53:48.544 EST: BGP(0): 10.179.129.252 NEXT_HOP is set to self for net 10.182.15.0/24,
013373: Jan 14 14:53:48.544 EST: BGP(0): 10.179.129.252 NEXT_HOP is set to self for net 10.35.0.0/16,
013374: Jan 14 14:53:48.544 EST: BGP(0): (base) 10.179.129.252 send UPDATE (format) 10.35.0.0/16, next 10.179.129.253, metric 25653760, path Local
013375: Jan 14 14:53:48.544 EST: BGP(0): 10.179.129.252 NEXT_HOP is set to self for net 10.45.0.0/16,
013376: Jan 14 14:53:48.544 EST: BGP(0): 10.179.129.252 NEXT_HOP is set to self for net 10.100.10.24/30,
013377: Jan 14 14:53:48.548 EST: BGP(0): (base) 10.179.129.252 send UPDATE (format) 10.100.10.24/30, next 10.179.129.253, metric 0, path Local
013378: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd UPDATE w/ attr: nexthop 10.179.129.252, origin ?, localpref 100, metric 0, merged path 11079 65055, AS_PATH
013379: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.18.110.0/24
013380: Jan 14 14:53:48.548 EST: BGP: bgp_rwatch_notify: BGP_RWATCH_APPL_NHOP
013381: Jan 14 14:53:48.548 EST: EvD: charge penalty 500, new accum. penalty 500, flap count 10
013382: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.50.110.0/24
013383: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.70.110.0/23
013384: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.90.110.0/24
013385: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.172.110.0/23
013386: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.172.112.0/24
013387: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.182.110.0/23
013388: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.182.112.0/24
013389: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd UPDATE w/ attr: nexthop 10.179.129.252, origin ?, localpref 100, metric 0, merged path 11079 65052, AS_PATH
013390: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.2.0/24
013391: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.3.0/24
013392: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.4.0/24
013393: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.5.0/24
013394: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.6.0/24
013395: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.7.0/24
013396: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.8.0/24
013397: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.9.0/24
013398: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.10.0/24
013399: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.11.0/24
013400: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.100.13.0/24
013401: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.2.0/24
013402: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.3.0/24
013403: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.4.0/24
013404: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.5.0/24
013405: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.6.0/24
013406: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.7.0/24
013407: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.8.0/24
013408: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.9.0/24
013409: Jan 14 14:53:48.548 EST: BGP(0): 10.179.129.252 rcvd 10.101.10.0/24
013410: Jan 14 14:53:48.552 EST: BGP(0): 10.179.129.252 rcvd 10.101.13.0/24
013411: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.18.110.0/24 -> 10.179.129.252(global) to main IP table
013412: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.50.110.0/24 -> 10.179.129.252(global) to main IP table
013413: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.70.110.0/23 -> 10.179.129.252(global) to main IP table
013414: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.90.110.0/24 -> 10.179.129.252(global) to main IP table
013415: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.2.0/24 -> 10.179.129.252(global) to main IP table
013416: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.3.0/24 -> 10.179.129.252(global) to main IP table
013417: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.4.0/24 -> 10.179.129.252(global) to main IP table
013418: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.5.0/24 -> 10.179.129.252(global) to main IP table
013419: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.6.0/24 -> 10.179.129.252(global) to main IP table
013420: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.7.0/24 -> 10.179.129.252(global) to main IP table
013421: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.8.0/24 -> 10.179.129.252(global) to main IP table
013422: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.9.0/24 -> 10.179.129.252(global) to main IP table
013423: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.10.0/24 -> 10.179.129.252(global) to main IP table
013424: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.11.0/24 -> 10.179.129.252(global) to main IP table
013425: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.100.13.0/24 -> 10.179.129.252(global) to main IP table
013426: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.2.0/24 -> 10.179.129.252(global) to main IP table
013427: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.3.0/24 -> 10.179.129.252(global) to main IP table
013428: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.4.0/24 -> 10.179.129.252(global) to main IP table
013429: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.5.0/24 -> 10.179.129.252(global) to main IP table
013430: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.6.0/24 -> 10.179.129.252(global) to main IP table
013431: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.7.0/24 -> 10.179.129.252(global) to main IP table
013432: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.8.0/24 -> 10.179.129.252(global) to main IP table
013433: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.9.0/24 -> 10.179.129.252(global) to main IP table
013434: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.10.0/24 -> 10.179.129.252(global) to main IP table
013435: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.101.13.0/24 -> 10.179.129.252(global) to main IP table
013436: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.172.110.0/23 -> 10.179.129.252(global) to main IP table
013437: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.172.112.0/24 -> 10.179.129.252(global) to main IP table
013438: Jan 14 14:53:48.552 EST: BGP(0): Revise route installing 1 of 1 routes for 10.182.110.0/23 -> 10.179.129.252(global) to main IP table
013439: Jan 14 14:53:48.556 EST: BGP(0): Revise route installing 1 of 1 routes for 10.182.112.0/24 -> 10.179.129.252(global) to main IP table
013440: Jan 14 14:53:48.556 EST: BGP_Router: unhandled major event code 128, minor 0
013441: Jan 14 14:53:48.716 EST: %DUAL-5-NBRCHANGE: EIGRP-IPv4 120: Neighbor 10.101.11.18 (GigabitEthernet0/0.38) is up: new adjacency
013442: Jan 14 14:53:53.384 EST: BGP: Regular scanner timer event
013443: Jan 14 14:53:53.384 EST: BGP: Performing BGP general scanning
013444: Jan 14 14:53:53.384 EST: BGP: topo global:IPv4 Unicast:base Scanning routing tables
013445: Jan 14 14:53:53.384 EST: BGP: tbl IPv4 Unicast:base Performing BGP Nexthop scanning for general scan
013446: Jan 14 14:53:53.384 EST: BGP(0): Future scanner version: 2662, current scanner version: 2661
013447: Jan 14 14:53:53.384 EST: BGP: topo global:IPv4 Multicast:base Scanning routing tables
013448: Jan 14 14:53:53.384 EST: BGP: tbl IPv4 Multicast:base Performing BGP Nexthop scanning for general scan
013449: Jan 14 14:53:53.384 EST: BGP(6): Future scanner version: 2663, current scanner version: 2662
013450: Jan 14 14:53:55.912 EST: BGP: aggregate timer expired
013451: Jan 14 14:53:58.232 EST: BGP(0): treating modify event for route 10.200.21.0/24 not appearing in BGP table as up event
013452: Jan 14 14:54:53.560 EST: BGP: Regular scanner timer event
013453: Jan 14 14:54:53.560 EST: BGP: Performing BGP general scanning
013454: Jan 14 14:54:53.560 EST: BGP: topo global:IPv4 Unicast:base Scanning routing tables
013455: Jan 14 14:54:53.560 EST: BGP: tbl IPv4 Unicast:base Performing BGP Nexthop scanning for general scan
013456: Jan 14 14:54:53.560 EST: BGP(0): Future scanner version: 2663, current scanner version: 2662
013457: Jan 14 14:54:53.560 EST: BGP: topo global:IPv4 Multicast:base Scanning routing tables
013458: Jan 14 14:54:53.560 EST: BGP: tbl IPv4 Multicast:base Performing BGP Nexthop scanning for general scan
013459: Jan 14 14:54:53.560 EST: BGP(6): Future scanner version: 2664, current scanner version: 2663

VIP Advisor

Re: MPLS connection move from Switch to router

Hello

 

First did you test with a cross-over cable?

Also apologies but  I still dont get  it -

 

 

@mrochac wrote:

... so the router right now has 3 ports being used for WAN (GE/0), LAN (GE/1), CGI (WIC/0) (secure connection) - now i'm adding an addition WAN connection to MPLS which is going into WIC - so the router has 2 GE ports an additional WIC for the CGI connection - and now i'm adding a 2nd WIC with 4GE ports... hope this clears things up...

So basically we are on about  interface Ge/0 thats all correct? Which when working attaches to a switch which also has the PE rtr attached, but when you remove the switch and attach this rtr via it Ge/0 port  direct to the PE rtr connectivity fails correct?  - but so whats the additional WIC for, would this be for an additional peering or addition to a multipoint.

 

Can you also post the config of your router please.

 

Did you test

res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here