cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
358
Views
5
Helpful
1
Replies

Multicast communication between (Lite) VRFs

TomAL
Level 1
Level 1

Hello everyone,
I am a beginner in the subject of VRFs, so please be understanding.

Here are my tasks to do:
- possibility of connecting many of the same subnets 192.168.50.0/24 to one router
- ensuring communication between them through NAT
- ensuring multicast connectivity between 192.168.50.100 servers (over static NAT) and other VRFs.

I managed to ensure unicast communication between all VRFs, unfortunately multicast transmission does not go beyond the given VRF.
Can I ask for help, what should be done to make multicast communication available?

Here is my router setup.
 

 

ip vrf RD_VRF
 rd 65000:1
  route-target export 65000:1
 route-target import 65000:1
!
ip vrf S10_1_VRF
 rd 65000:32
 export map to_RD_VRF
 route-target export 65000:32
 route-target import 65000:1
!
ip vrf S20_1_VRF
 rd 65000:21
 export map to_RD_VRF
 route-target export 65000:21
 route-target import 65000:1
!
ip vrf S20_2_VRF
 rd 65000:19
 export map to_RD_VRF
 route-target export 65000:19
 route-target import 65000:1
!
ip multicast-routing distributed
ip multicast-routing vrf RD_VRF distributed
ip multicast-routing vrf S20_1_VRF distributed
ip multicast-routing vrf S20_2_VRF distributed
ip multicast-routing vrf S10_1_VRF distributed
!

interface Loopback19
 ip vrf forwarding S20_2_VRF
 ip address 10.50.19.1 255.255.255.240
 ip pim sparse-dense-mode
 ip nat outside
!
interface Loopback21
 ip vrf forwarding S20_1_VRF
 ip address 10.50.21.1 255.255.255.240
 ip pim sparse-dense-mode
 ip nat outside
!
interface Loopback32
 ip vrf forwarding S10_1_VRF
 ip address 10.50.32.1 255.255.255.240
 ip pim sparse-dense-mode
 ip nat outside
!
interface Port-channel1
 no ip address
 no negotiation auto
!
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip vrf forwarding RD_VRF
 ip address 172.16.1.2 255.255.255.0
 ip information-reply
 ip pim sparse-dense-mode
!
interface Port-channel1.19
 encapsulation dot1Q 19
 ip vrf forwarding S20_2_VRF
 ip address 192.168.50.1 255.255.255.0
 ip nat inside
!
interface Port-channel1.21
 encapsulation dot1Q 21
 ip vrf forwarding S20_1_VRF
 ip address 192.168.50.1 255.255.255.0
 ip nat inside
!
interface Port-channel1.32
 encapsulation dot1Q 32
 ip vrf forwarding S10_1_VRF
 ip address 192.168.50.1 255.255.255.0
 ip pim sparse-dense-mode
 ip nat inside
 !
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
 spanning-tree portfast
 channel-group 1 mode active
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
 spanning-tree portfast
 channel-group 1 mode active
!
!
router eigrp 1
 !
 address-family ipv4 vrf RD_VRF
  redistribute bgp 65000 metric 1000000 100 255 1 1500
  network 172.16.1.0 0.0.0.255
  autonomous-system 1
 exit-address-family
 eigrp event-logging
!
router bgp 65000
 bgp log-neighbor-changes
 !
 address-family ipv4 vrf RD_VRF
  redistribute connected
  redistribute eigrp 1 metric 100
 exit-address-family
 !
 address-family ipv4 vrf S10_1_VRF
  redistribute connected
 exit-address-family
 !
 address-family ipv4 vrf S20_1_VRF
  redistribute connected
 exit-address-family
 !
 address-family ipv4 vrf S20_2_VRF
  redistribute connected
 exit-address-family
!

ip pim vrf RD_VRF rp-address 172.16.1.2
ip pim vrf S20_1_VRF rp-address 172.16.1.2
ip pim vrf S20_2_VRF rp-address 172.16.1.2
ip pim vrf S10_1_VRF rp-address 172.16.1.2
ip pim vrf S20_1_VRF register-source Loopback21
ip pim vrf S20_2_VRF register-source Loopback19
ip pim vrf S10_1_VRF register-source Loopback32
ip nat inside source static 192.168.50.100 10.50.21.2 vrf S20_1_VRF
ip nat inside source static 192.168.50.100 10.50.32.2 vrf S10_1_VRF
ip nat inside source static 192.168.50.100 10.50.19.2 vrf S20_2_VRF
ip nat inside source list S_LAN interface Loopback32 vrf S10_1_VRF overload
ip nat inside source list S_LAN interface Loopback21 vrf S20_1_VRF overload
ip nat inside source list S_LAN interface Loopback19 vrf S20_2_VRF overload
!
!
ip access-list standard BGP_REDISTRIBUTE_FILTER
 10 deny   192.168.50.0 0.0.0.255
  20 permit any
ip access-list standard S_LAN
 10 permit 192.168.50.0 0.0.0.255
!
!
route-map to_RD_VRF permit 10
 match ip address BGP_REDISTRIBUTE_FILTER
 set extcommunity rt 65000:1
!

 

 

1 Reply 1

TomAL
Level 1
Level 1
 

Does anyone know the solution to the problem?
Please.

 

 

Review Cisco Networking for a $25 gift card