Showing results for 
Search instead for 
Did you mean: 

Multicast in DMVPN

Ravindra Simpi

In response to my post in I am settin up a LAB to test multicast in DMVPN.

I have three routers R_HUB, R_UNICAST, R_SPOKE, (see attachment)

R_UNICAST router (unicast cloud) is connected between R_HUB and R_SPOKE

R_HUB is configured to be NHRP NHS hub router and also Multicast RP. I want to simulate 1000 spokes on R_SPOKE router. When I created 1000 tunnels on this router each using a unique loopback interface as source of tunnel, each tunnel will be reachable from the hub router.

R_HUB's tunnel interface is configured with ip pim nbma-mode. The R_SPOKE is configured with RP address as R_HUB's IP and the route to this IP can be any one of the tunnel.  That means, when sender sends multicast packet, R_HUB will see that only one tunnel from R_SPOKE is requesting for Multicast traffic and it is only creating only multicast packet and placing it on the tunnel interface.

How do I make the R_HUB to create 1000 multicast packets?

Also, how do I make sure that multicast replication at R_HUB is taking place at hardware level?

Message was edited by: Ravindra Simpi

8 Replies 8


Simply put - you cannot, it defeats the whole multicast model. One to many.

Thanks for the reply.

There must be some way. Is there any way by which I can make individual tunnel on R_SPOKE register with the R_HUB as tunnel on R_HUB is using 'ip pim nbma-mode'.

Yes of course - just add the command "igmp join-grooup x.x.x.x" to an interface on the R_SPOKE router. The interface must have PIM enabled on it.  This will send an IGMP join request to the RP, the router will then be part of the shared tree.

Thanks a lot again.

The router is able to replicate 1000 packets with this approach. However the time taken by the router to replicate 1000 packets is around 150ms. I feel this is a very large value.

Is there any way to reduce this replication time. How do I check whether the multicast replication is taking place in hardware and not in software?

Ensure you have ip mroute-cache enabled on the PIM interfaces to enable multicast fast switching

ip mroute-cache is enabled on PIM interface in R_HUB. Still I see replication time of multicast packets very high.

make sure it is enabled on both ends and test, if it;s slow, try disabling it on both ends.  What is the link betweend devices? Be mindful of any other over heads, Tunnels/GRE/Enryption/Serialisation etc

Tried by enabling/disabling mroute-cache on both the ends without any luck. The replication time still remains same.

THe link between the devices is 1GB.

No encryption and serialisation. GRE is supposed to be handled at hardware as I am using SUP-720.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers