04-29-2005 11:15 AM - edited 03-03-2019 09:25 AM
Ok, i've gone through a ton of cisco doc's, tried everything they've stated, now i'm lost and clueless???
can anybody look at my config, and tell me what to do?
all i need is for 1760-V to dial 1-800 number when t-1 goes down...
thanks in advance
AL
interface Serial0/0:0.1 point-to-point
backup delay 15 15
backup interface Async5
ip address 10.0.129.2 255.255.255.252
frame-relay interface-dlci 1000
class map_vofr
vofr data 4 call-control 5
!
interface Async5
ip unnumbered Serial0/0:0.1
encapsulation ppp
dialer in-band
dialer string 1866xxxxxxx modem-script cisco-default
dialer-group 1
async mode interactive
04-29-2005 11:45 AM
With backup interface on serial0/0:0.1 the async 5 will not attempt to dial (and will not answer a call) until there is a real problem on the serial. (shutdown of the interface will not trigger an attempt to dial - it must be a real failure of the primary interface) So how have you attempted to test this?
Also it would be more helpful if you could be more specific about what you have tried and what the symptoms are of it not working.
There is a possibility that there is a problem with dialer-list 1 which should correspond to dialer-group 1 on the async interface. Would you post the dialer-list - and if there is an associated access-list post it also.
I note that there is no authentication on the async interface. Most dialing interfaces do some form of authentication. But since I am not sure that it is causing the problems that you are having, we will wait to discuss this till the other problems are solved.
HTH
Rick
04-29-2005 11:59 AM
Rick, thanls for the reply...
All i've done so far is to try and config as per documents from cisco... I have 1760 setup with loop t-1 plug, so i pull connection to simulate drop...
Basically i copied from documents i've read, which were spotty at best... so i'm just trying to start from scratch, all i want to accomplish is for 1760 with wic-1am modem card, to dial corporate number to reconnect to lan when circuit goes down...
so anything from scratch would help...
AL
04-29-2005 02:08 PM
here is debug...
debug dialer
Dial on demand events debugging is on
store129#
00:26:21: Di1: No free dialer - starting fast idle timer
00:26:26: Di1: No free dialer - starting fast idle timer
00:26:27: As5 DDR: re-enable timeout
00:26:30: As5 DDR: Dialing cause ip (s=10.0.129.2, d=224.0.0.10)
00:26:30: As5 DDR: Attempting to dial 1800
00:26:30: CHAT5: Attempting async line dialer script
00:26:30: CHAT5: no matching chat script found for 1800
00:26:30: CHAT5: Dialing using Modem script: d0efault-d0ials0cript &
System script: none
00:26:30: CHAT5: process started
00:26:30: CHAT5: Asserting DTR
00:26:30: CHAT5: Chat script d0efault-d0ials0cript started
00:26:30: Di1: No free dialer - starting fast idle timer
00:26:35: CHAT5: Chat script d0efault-d0ials0cript finished, status
= Connection timed out; remote host not responding
00:26:35: As5 DDR: disconnecting call
00:26:35: Di1: No free dialer - starting fast idle timer
00:26:40: Di1: No free dialer - starting fast idle timer
00:26:44: Di1: No free dialer - starting fast idle timer
00:26:48: Di1: No free dialer - starting fast idle timer
00:26:50: As5 DDR: re-enable timeout
00:26:53: As5 DDR: Dialing cause ip (s=10.0.129.2, d=224.0.0.10)
00:26:53: As5 DDR: Attempting to dial 1800
00:26:53: CHAT5: Attempting async line dialer script
00:26:53: CHAT5: no matching chat script found for 1800
00:26:53: CHAT5: Dialing using Modem script: d0efault-d0ials0cript &
System script: none
00:26:53: CHAT5: process started
00:26:53: CHAT5: Asserting DTR
00:26:53: CHAT5: Chat script d0efault-d0ials0cript started
00:26:53: Di1: No free dialer - starting fast idle timer
00:26:58: Di1: No free dialer - starting fast idle timer
00:26:58: CHAT5: Chat script d0efault-d0ials0cript finished, status
= Connection timed out; remote host not responding
00:26:58: As5 DDR: disconnecting calldebug dialer
00:27:03: Di1: No free dialer - starting fast idle timer
All possible debugging has been turned off
store129#
AL
04-30-2005 07:40 AM
Al
Posting the output from your debug is helpful. For one thing it shows that the router is attempting to dial, which confirms that it has recognized a failure of the primary interface and is using the backup. This answers one of the questions that I asked.
The debug also shows that it is attempting to dial because it has an EIGRP update to send. It has an EIGRP update because the async interface is unnumbered using the address of the serial subinterface which does match an EIGRP network statement. You may decide later whether you want to run EIGRP over the backup interface, but for now I would like to get it out of the way because it complicates what we are trying to do (I am not sure what is causing the no free dialer message but it may be due in part to trying to use the dialer for so many update/hello messages). So please put a passive-interface async5 under your EIGRP process. Or in the access list which is used by the dialer list put deny up any host 224.0.0.10.
I am wondering about the message:
no matching chat script found for 1800
the 1800 does not seem to match anything in the part of the config that you posted. Would you post a more complete part of the config which might help us figure that this relates to?
HTH
Rick
04-30-2005 01:29 PM
Rick, thanks for the help... got totally frustrated with this, wiped out config and i'm starting from scratch with this DDR... as i kept researching and finding doc's saying try this way... so i'm starting all over from scratch...
AL
04-30-2005 02:05 PM
Rick here is current config and debug..
hostname Store129
!
enable secret 5
!
username backup password 0 connection
tdm clock T1 0/0 both export line
ip subnet-zero
!
!
ip dhcp excluded-address 172.16.129.1 172.16.129.100
ip dhcp excluded-address 172.16.129.106 172.16.129.254
!
ip dhcp pool 0
network 172.16.129.0 255.255.255.0
default-router 172.16.129.254
!
chat-script dialup ABORT ERROR "" "ATDT \T" TIMEOUT 40 CONNE
CT
!
controller T1 0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-2
!
!
!
interface Loopback0
ip address 172.16.229.254 255.255.255.0
!
interface Loopback1
ip address 172.16.228.253 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.129.254 255.255.255.0
speed auto
!
interface Serial0/0:0
no ip address
encapsulation frame-relay
frame-relay traffic-shaping
!
interface Serial0/0:0.1 point-to-point
backup delay 15 15
backup interface Async5
ip address 10.0.129.2 255.255.255.252
frame-relay interface-dlci 1000
class map_vofr
vofr data 4 call-control 5
!
interface Async5
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 2
async default routing
no fair-queue
!
interface Dialer1
ip unnumbered Loopback1
encapsulation ppp
dialer pool 2
dialer idle-timeout 300
dialer string 1800xxxxxxx
dialer hold-queue 50
dialer-group 1
no peer default ip address
no cdp enable
ppp authentication chap
ppp chap hostname perle
ppp chap password 7
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip http access-class 1
ip pim bidir-enable
!
!
!
map-class frame-relay map_vofr
frame-relay cir 64000
frame-relay bc 640
frame-relay mincir 64000
no frame-relay adaptive-shaping
frame-relay fair-queue
frame-relay voice bandwidth 16000
frame-relay fragment 80
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
voice-port 2/0
echo-cancel coverage 32
!
voice-port 2/1
echo-cancel coverage 32
!
dial-peer cor custom
dial-peer voice 1 pots
destination-pattern 7129
port 2/0
!
dial-peer voice 2 vofr
destination-pattern 7...
session target Serial0/0:0 1002
!
dial-peer voice 3 vofr
destination-pattern 5...
session target Serial0/0:0 1002
!
dial-peer voice 4 vofr
destination-pattern 3..
session target Serial0/0:0 1002
!
!
line con 0
line aux 0
script dialer cisco_101
modem InOut
transport input all
line vty 0 4
password
login
Dial on demand events debugging is on
Store129#
00:51:22: As5 DDR: re-enable timeout
00:51:22: DDR: Dialing failed, 2 packets unqueued and discar
ded
00:51:25: As5 DDR: rotor dialout [priority]
00:51:25: As5 DDR: Dialing cause ip (s=172.16.228.253, d=224
.0.0.10)
00:51:25: As5 DDR: Attempting to dial 1800xxxxxxx
00:51:25: CHAT5: Attempting async line dialer script
00:51:25: CHAT5: no matching chat script found for 1800
00:51:25: CHAT5: Dialing using Modem script: d0efault-d0ials
0cript & System script: none
00:51:25: CHAT5: process started
00:51:25: CHAT5: Asserting DTR
00:51:25: CHAT5: Chat script d0efault-d0ials0cript started
00:51:30: CHAT5: Chat script d0efault-d0ials0cript finished,
status = Connection timed out; remote host not responding
00:51:30: As5 DDR: disconnecting call
00:51:45: As5 DDR: re-enable timeout
00:51:45: DDR: Dialing failed, 2 packets unqueued and discarded
04-30-2005 02:10 PM
Here is another debug, couldn't fit in last posting..
Store129#debug modem
Modem control/process activation debugging is on
Store129#
01:01:12: TTY5: restoring DTR
01:01:12: TTY5: Set DTR to 1
01:01:24: CHAT5: Attempting async line dialer script
01:01:24: CHAT5: process started
01:01:24: CHAT5: Asserting DTR
01:01:24: TTY5: Set DTR to 1
01:01:29: TTY5: Line reset by "Async dialer"
01:01:29: TTY5: Modem: (unknown)->HANGUP
01:01:29: TTY5: no timer type 0 to destroy
01:01:29: TTY5: no timer type 1 to destroy
01:01:29: TTY5: no timer type 3 to destroy
01:01:29: TTY5: no timer type 4 to destroy
01:01:29: TTY5: no timer type 2 to destroy
01:01:29: TTY5: dropping DTR, hanging up
01:01:29: TTY5: Set DTR to 0
01:01:29: tty5: Modem: HANGUP->(unknown)
01:01:34: TTY5: restoring DTR
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide